CPE210 - Forwarding of DHCP addressing

CPE210 - Forwarding of DHCP addressing
CPE210 - Forwarding of DHCP addressing
2020-05-02 00:04:33 - last edited 2020-05-02 00:05:47
Model: CPE210
Hardware Version:
Firmware Version:

Hello all :)
At the beginning I wanted to say that I'm green when it comes to hardware configurations related to networks.

I have 3 tp-link cpe210 devices and I would like to connect my two buildings to the internet, I want one device to act as a transmitter and the other two as receivers, but I want devices to transmit DHCP addresses. I would like to get the effect as in the picture:

Summarizing; How to configure cpe210 devices to relay DHCP address and work properly?

Thank you for all the help :)

0
0
#1
Options
8 Reply
Re:CPE210 - Forwarding of DHCP addressing
2020-05-02 23:03:25 - last edited 2020-05-02 23:06:54

@urbciech,

 

if you use the CPE in »Router« operation mode, it is not possible to assign the second network (LAN2 »behind« the CPE router) the same IP address 192.168.1.0 used in the primary network (LAN). This can't work.

 

If you use the CPE in »Access Point« operation mode, it will automatically forward DHCP requests and replies. All CPEs then become part of the primary LAN. This allows to use fixed IP addresses for all CPEs and EAPs and dynamic IP addresses for the wireless clients connecting to the EAPs.

 

So, just select »Access Point« as operation mode for the CPE connected to the ISP router at MyHome1 and »Client« as operation mode for the two CPEs at MyHome2 and MyHome3.

༺ 0100 1101 0010 10ཏ1 0010 0110 1010 1110 ༻
1
1
#2
Options
Re:CPE210 - Forwarding of DHCP addressing
2020-05-02 23:46:02

@R1D2 I understand if WDS should be enabled for cpe210 in "client" mode in home2 and home3?

0
0
#4
Options
Re:CPE210 - Forwarding of DHCP addressing
2020-05-02 23:52:07 - last edited 2020-05-02 23:53:21

 

urbciech wrote

@urbciech I understand if WDS should be enabled for cpe210 in "client" mode in home2 and home3?

 

No. You would need WDS if clients connect directly to a CPE in »Repeater« op mode and you need layer-2 transparency for any reason (e.g. for a Captive Portal). But repeater mode is usually not used with CPEs due to the directional nature of their built-in antennas.

 

WDS is not needed if clients connect to an external AP which uses the CPE only as a backhaul.

༺ 0100 1101 0010 10ཏ1 0010 0110 1010 1110 ༻
1
1
#5
Options
Re:CPE210 - Forwarding of DHCP addressing
2020-05-03 14:13:00

@R1D2 Thank you very much in your direction :). Everything works as it should.
I have the last question, I noticed that the EAP110 upload is 80Mb / s and the download is 35Mb / , I have a 150 / 150Mb symmetric link. Should it be that way?

0
0
#6
Options
Re:CPE210 - Forwarding of DHCP addressing
2020-05-03 19:52:59 - last edited 2020-05-03 19:59:12

@urbciech,

 

no, it should be more or less symmetric, too. This sounds to me that the antennas are not aligned propery or that the CPE clients cause interference on the main CPE in AP mode.

 

Things you can try:

 

  • set WiFi mode of the CPEs to 802.11n-only, encryption must me WPA2-AES to have 802.11n work at full WiFi rate (N300),
  • set 20 MHz channel width in overcrowded areas (reduces througphut somewhat) or 40 MHz in rural areas,
  • set »Distance« to either real distance + 0.1km or to »Auto«,
  • align the antennas properly (use the antenna alignment tool in »Tools« menu,

 

and in case the two CPEs interfere with the main CPE in AP mode:

  • enable MAXtream TDMA to have the CPE in AP mode manage AirTime distribution between both CPEs in Client mode.

 

As for max. throughput one can reach with CPEs see my story here. But I used CPE510 b/c I live in an overcrowded area and with CPE210 I was not able to get more than ~5 Mbps throughput over the link described in this story due to ~140 foreign APs around visible to the CPE210. Just not much AirTime left for my CPE210.

 

 

 

༺ 0100 1101 0010 10ཏ1 0010 0110 1010 1110 ༻
0
0
#7
Options
Re:CPE210 - Forwarding of DHCP addressing
2020-05-03 23:41:03

@R1D2 

hello, i wanted to use WPA2-AES encryption unfortunately i don't know if i do it properly. For CPE210 (home 1) I cannot set the username that is needed to connect in (home2 and home3).

 

What I have to enter in the fields:
- WPA user name
- authentication server IP

 

Look at the screenshot. 

0
0
#9
Options
Re:CPE210 - Forwarding of DHCP addressing
2020-05-04 00:57:34

@urbciech, you need to select WPA2-PSK (pre-shared key), not WPA2 Enterprise:

 

༺ 0100 1101 0010 10ཏ1 0010 0110 1010 1110 ༻
0
0
#10
Options
Re:CPE210 - Forwarding of DHCP addressing
2021-10-30 03:13:28

@R1D2 

Hi all and thanks to all those that post responses here - fantastic pool of knowledge for us "Newbies".

I have the exact same setup as "urbciech" with 3 CPE210 - the "MY HOME 1" is in AP mode with DHCP off - both "MY HOME 2" and "MY HOME 3" are in Client mode with DHCP off to share the Wan but both networks behind these are routed rather than off EAP's.

My question is how to configure the 2 routed Lans to communicate whilst retaining Wan access for both?

Turn off DHCP on both routers off and effectively make both routers just switches with firewalls and use static IP's for the connected devices in both Lans?

 

Cheers

OldSod

0
0
#11
Options