Sonos latency problems with TL-SG108E switch

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Sonos latency problems with TL-SG108E switch

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Sonos latency problems with TL-SG108E switch
Sonos latency problems with TL-SG108E switch
2020-11-02 11:44:46 - last edited 2020-11-19 23:25:51
Model: TL-SG108E  
Hardware Version: V5
Firmware Version:

Hi,  I have an older Sonos system with 4 zones. One Sones device (Connect) died and I changed it for a Sonos port.

It is connected via an ethernet cable to a TL-SG108E switch which is connected to the router, also with an ethernet cable. No cable is longer than 2 meters

Now, the problem is that the Sonos Port gets latency problems (says the Sonos support) when connected via the TL-SG108E switch, it results in that the music pauses about 10secs every 3-5 minutes.

I have tested to connect the Sonos Port directly to the router and it works fine (...except that I cannot use any other Sonos zones). I just tested to pull out the ethernat cable from the Sonos Port and let it run wireles and it also works well.

The network guys, Sonos support, everybody is scratching their heads. Any idea how to make it work via ethernet, anyone?

  0      
  0      
#1
Options
1 Accepted Solution
Re:Sonos latency problems with TL-SG108E switch -Solution
2020-11-19 23:25:30 - last edited 2020-11-19 23:25:51
Ooops, my wrong! I turned off the TV and the troublesome zone started palying the music. It must be some sort of priority between TV and Sonos. Thanks Fae, I see it as problem solved.
Recommended Solution
  0  
  0  
#4
Options
3 Reply
Re:Sonos latency problems with TL-SG108E switch
2020-11-04 08:35:21

Dear @OlleB,

 

Now, the problem is that the Sonos Port gets latency problems (says the Sonos support) when connected via the TL-SG108E switch, it results in that the music pauses about 10secs every 3-5 minutes.

 

Try the following suggestion and check if it helps:

 

1. Ensure the wireless connection is disabled on Sonos system when it connects to the SG108E with an Ethernet cable.

2. Check the cable type you are using, it is recommended to use CAT5e above cable with good quality for the connection.

3. Disconnect other cables/devices to avoid any possible influence, simply connect Router ----SG108E----Sonos to double check it.

4. Connect a PC to the SG108E and try to log into the web UI of SG108E (refer to the QIG if you don't know how to do it),

    1) go to Switching > Port Setting, check whether the Speed/Duplex of the Sonos Port is at 1000MF.

    2) go to QoS > QoS Basic, select QoS mode as 802.1P Based, and specify the Priority Queue for the Sonos Port as 4 for checking.

    3) go to System > System Info, check the current firmware (Build number) and ensure it is up to date.

Happy New Year! Meet Us at CES 2023 | Featuring Wi-Fi 7, Omada Business Networking, VIGI Video Surveillance
  0  
  0  
#2
Options
Re:Sonos latency problems with TL-SG108E switch
2020-11-19 23:14:07

@Fae 

Thanks for your help.

- I changed the Speed/Duplex of the Sonos Port from 100MF to 1000MF,

- set the QoS mode as 802.1P Based (I see no possibilty to set the Priorit que, it seems to belong to Port setting, not to 802.1P based) and 

- updated the firmware, kit was one version old.

 

I am afraid it did not solve the problem, it even worsened it. No sound what so ever comes from the Sonos loadspeaker zone belonging to the Sonos Port; all other zones work well as earlier.

 

All ideas are appreciated....

 

  0  
  0  
#3
Options
Re:Sonos latency problems with TL-SG108E switch -Solution
2020-11-19 23:25:30 - last edited 2020-11-19 23:25:51
Ooops, my wrong! I turned off the TV and the troublesome zone started palying the music. It must be some sort of priority between TV and Sonos. Thanks Fae, I see it as problem solved.
Recommended Solution
  0  
  0  
#4
Options

Information

Helpful: 0

Views: 939

Replies: 3

Related Articles