ER605 - DNS SERVER (pi hole) cannot ping router - router can ping DNS ???

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

ER605 - DNS SERVER (pi hole) cannot ping router - router can ping DNS ???

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
ER605 - DNS SERVER (pi hole) cannot ping router - router can ping DNS ???
ER605 - DNS SERVER (pi hole) cannot ping router - router can ping DNS ???
2021-11-20 07:21:13 - last edited 2021-11-22 01:05:06
Model: ER605 (TL-R605)  
Hardware Version: V1
Firmware Version: 1.1.1

Hi,

 

I am having an extremely weird issue if no one else could solve this its 100% a bug as I cannot get my head around it.

 

Okay purchased a new ER605 set it up all worked fine, now I have a pi hole server which runs my DNS and DHCPs always worked fine with my previous router no issues. now when setting up the router I had my primary DNS set to 192.168.0.2 (dns and dhcp server) I connect to the internet perfectly fine and all other hosts are fine too. 

 

I noticed in the system logs that router cannot connect to NTP server, so I did a quick ping test from the router - the router was not connecting to the outside and it said it couldnt reach DNS !!! even though everyone is connected to the internet. so what I did was I added a secondary DNS server 1.1.1.1 or 8.8.8.8 (external DNS server) and boom it connected to the outside and synced with the NTP all working fine. 

 

NOW the main issue I found is the my pihole (which is also an adblocker) was acting a bit weird on the logs so I thought ill give the router a ping and the pings were not getting replied too, yet everyone else can ping the router perfectly fine.

 

I did a lot of searches and I simply could not find where the issue was. The only way I could make the DNS/DHCP Server (pihole) to ping the router was when I removed the DNS primary ip (192.168.0.2) from the PPPoe settings and had 8.8.8.8 instead !!! that is so weird.

 

I am not an expert in routing but I know my way around it a bit - when I do an ip route check the following shows.

 

ID Destination IP Subnet Mask Next Hop Interface Metric
1 0.0.0.0 0.0.0.0 195.*.*.* WAN 0
2 127.0.0.0 255.0.0.0 0.0.0.0 lo 0
3 168.*.*.* 255.255.255.255 0.0.0.0 eth1.4094 0
4 192.168.0.2 255.255.255.255 195.*.*.* WAN 0
5 195.*.*.* 255.255.255.255 0.0.0.0 WAN 0
6 8.8.8.8              255.255.255.255 195.*.*.* WAN 0
7 192.168.0.0 255.255.255.0 0.0.0.0 LAN 0

 

 

now I dont know about you guys but ID 4 doesnt look right to me? I could be wrong... by the way these all automatically generated.

 

 

 

Could someone please HELP as I have no other ideas... 

 

 

Thanks in advance. 

  0      
  0      
#1
Options
1 Reply
Re:ER605 - DNS SERVER (pi hole) cannot ping router - router can ping DNS ???
2021-11-22 22:34:08

@TechMech I am going to throw in an issue i had setting up Pihole with my new ER605 and maybe it might help.

I was having similar issues and found that if I also changed the DNS server settings in LAN (Wired Networks > LAN) as well as in the normal WAN DNS everything started to work as expected.

However, DHCP is managed by my ER605 and not the PiHole.

Just an idea for you to look at.

 

 

 

 

 

 

  1  
  1  
#2
Options

Information

Helpful: 0

Views: 922

Replies: 1

Related Articles