(Linux) Unable to upgrade from 5.0.30 to 5.1.7

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
(Linux) Unable to upgrade from 5.0.30 to 5.1.7
(Linux) Unable to upgrade from 5.0.30 to 5.1.7
2022-03-25 01:35:04 - last edited 2022-03-26 00:24:35
Hardware Version:
Firmware Version: 5.0.30

It appears the mongodb dependencies were changed on the deb package for the software controller? This is causing issues during upgrade. Anyone else having issues with this? I've been running 4.4.x of mongodb and it's been fine.

 

 Package: omadac
 Version: 5.0.30
 Section: java
 Priority: optional
 Architecture: all
 Depends: adduser, jsvc (>=1.0.8), curl,
  mongodb-server (>= 3.0.0) | mongodb-10gen (>= 3.0.0) | mongodb-org-server (>= 3.0.0),
  mongodb-server (<< 1:4.5.0) | mongodb-10gen (<< 4.5.0) |  mongodb-org-server (<< 4.5.0),
  java8-runtime-headless

 

 

 

 Package: omadac
 Version: 5.1.7
 Section: java
 Priority: optional
 Architecture: all
 Depends: adduser, jsvc (>=1.0.8), curl,
  mongodb-server (>= 3.0.0) | mongodb-10gen (>= 3.0.0) | mongodb-org-server (>= 3.0.0),
  mongodb-server (<< 1:4.0.0) | mongodb-10gen (<< 4.0.0) |  mongodb-org-server (<< 4.0.0),
  java8-runtime-headless

  0      
  0      
#1
Options
9 Reply
Re:(Linux) Unable to upgrade from 5.0.30 to 5.1.7
2022-03-25 09:58:54

Dear @iamperson347 ,

 

iamperson347 wrote

It appears the mongodb dependencies were changed on the deb package for the software controller? This is causing issues during upgrade. Anyone else having issues with this? I've been running 4.4.x of mongodb and it's been fine.

 

Actually we have a detailed article to guide you how to set the device working with mongodb, please check it:

https://www.tp-link.com/support/faq/3272/

 

You may follow this article to setup again to test.

 

Best Regards!

If this was helpful click the Triangles button below. If this solved your issue, please mark it "Recommended Solution" to help others.
  0  
  0  
#2
Options
Re:(Linux) Unable to upgrade from 5.0.30 to 5.1.7
2022-03-25 10:29:35 - last edited 2022-03-25 10:30:54

  @Hank21 

 

I actually used that guide to setup my controller. The problem is, the newly released 5.1.7 .Deb pkg will NOT work with mongodb 4.4 based on the dependencies being changed to not allowing 4.4 (see my dpkg output in the first post showing the issue).

 

If 4.4 is supposed to still be supported then the recently released 5.1.7 Deb pkg needs to be fixed.

  0  
  0  
#3
Options
Re:(Linux) Unable to upgrade from 5.0.30 to 5.1.7
2022-03-25 10:46:32

  @iamperson347 This forum software is VERY STUPID, SEEMS TO BE FOR IDIOTS AND TP-LINK THINKS EVERYBODY IS IDIOT:

 

  0  
  0  
#4
Options
Re:(Linux) Unable to upgrade from 5.0.30 to 5.1.7
2022-03-25 10:54:23
I believe mongodb 3.6 is end of life. Additionally, if a piece of software says it supports a given version of a dependency (mongodb in this case) and their help article even recommends installing a certain version of that dependency.... It should work. The core issue here is that the 5.1.7 Deb was released with incorrect dependencies defined. It's very clear from the dpkg output I posted in my first post.
  1  
  1  
#5
Options
Re:(Linux) Unable to upgrade from 5.0.30 to 5.1.7
2022-03-25 11:52:31

iamperson347 wrote

I believe mongodb 3.6 is end of life. Additionally, if a piece of software says it supports a given version of a dependency (mongodb in this case) and their help article even recommends installing a certain version of that dependency.... It should work. The core issue here is that the 5.1.7 Deb was released with incorrect dependencies defined. It's very clear from the dpkg output I posted in my first post.

  @iamperson347 in short you do not need v4 and you have no clue what it gives you compared to v3, you believe also that making your system less stable is better, because it is newer. That is typical behavior of normal Joe user on Mickey softs Windolls, but in general, those who maintenance official repositories might have more clue why there is v3 and not v4 which obviously is not dead. As we talk about it, what is the difference for you from v3 to v4 and which functions do you miss? Lastly, you broke your system with such "logic" in thinking you keep it up to date, using 3rd party repositories or packages in different versions than those on the repo is anyway bad idea if one has no clue at all why one needs it.

 

It should work .... => is not equal => it works, as is "thinking" => not knowing.

 

Anyway, regardless what you have read, I recommend using stable packages from the repo which your OS offers, if you need higher version, then use latest package repository or build your own with all omada dependencies if you are bored and insist that you need v4 before developers release it in their stable repositories, just do not break your system with not knowingly upgrading something that you might not want just to end up like now that your cloud controller stands still and is not working.

 

  0  
  0  
#6
Options
Reply
2022-03-25 12:08:39 - last edited 2022-03-25 12:08:57

  @btx ,

 

I would kindly ask that you no longer post in this thread so that someone from TP-Link will hopefully see someone reporting a valid issue and have a chance to fix it. I'm not sure what prompted you to attack someone for no reason. I haven plenty of experience with Linux both personally and professionally.

 

Second, my controller is just fine. I take snapshots of my vm that runs the controller before upgrades.

 

Finally, I recommend you read tplinks RECOMMENDED INSTALLATION INSTRUCTIONS for v5.0.29 and later. They clearly recommend v4.4 of mongodb.

 

https://www.tp-link.com/support/faq/3272/

 

  1  
  1  
#7
Options
Reply
2022-03-25 12:57:01

iamperson347 wrote

  @btx ,

 

I would kindly ask that you no longer post in this thread so that someone from TP-Link will hopefully see someone reporting a valid issue and have a chance to fix it. I'm not sure what prompted you to attack someone for no reason. I haven plenty of experience with Linux both personally and professionally.

 

Second, my controller is just fine. I take snapshots of my vm that runs the controller before upgrades.

 

Finally, I recommend you read tplinks RECOMMENDED INSTALLATION INSTRUCTIONS for v5.0.29 and later. They clearly recommend v4.4 of mongodb.

 

https://www.tp-link.com/support/faq/3272/

 

  @iamperson347 I kindly ask you to refrain from posting nonsense in public if you are incapable to discuss about what you post, sorry, but it is your own problem if anger overtakes you, there was no attack at all except pointing out how useless your support request as.

 

As for your "I am professional", you prove that you are neither a professional nor honest person, you straight lie, later you will claim that from your point of view a professional can be somebody who does not know anything about the topic he claims to be professional. Well, you want it, you want me to point out how you lie in public simply because I think you could learn something from it, there are enough trolls here. So, plenty experience would mean that you are capable to compile all required dependencies, which you as non professional seem not to know. Beside that, your OS offers official support for the packages, as professional you seem not to know that it is waste of time for tp-link or your OS distro to release new version which would just fit purpose of one user and probably break it for everybody. You also seem not to be even capable to compile on your own a package which you claim to need, one really does not need to be a developer to actually compile a package, if one wastes time on it instead of trolling, then as professional you would maybe compile it including all dependencies, but hey, how would you know if you have no clue and waste time in lying and calling yourself professional :). Well, at least it would explain with which logic tp-link says their business line is business ready, which it probably is, for professionals like you yes

 

Finally, seriously, are you incapable to read or are you one of the cases who did not learn to read in school? Please explain to us what does this mean and how is this a recommendation:

 

Install MongoDB

Omada SDN Controller supports MongoDB v3 and v4. Here we will show how to install v4.4.

 

 

For your incapability to even read and understand, yes, there is one recommendation which equals what I previously told you:

 

2. Supported Linux distributions

Omada Software Controller on the Linux platform supports the following distributions. It is recommended that you use one of these distributions.

Ubuntu 16.04, 18.04, 20.04

CentOS 6, 7

Debian 8, 9, 10

 

Are you capable to understand as somebody who lies to be a professional that tp-link recommends supported linux distros which support omada, all required packages are available for those distros and this is highly recommended for professionals like you because you only need to install java and mongodb which is available from repo.

 

Before you continue insulting or interpret eye opener as attack, you might want to read a book and train your reading capabilities.

 

 

  0  
  0  
#8
Options
Re:(Linux) Unable to upgrade from 5.0.30 to 5.1.7
2022-03-25 13:38:49

  @iamperson347 whatever, simple and probably the only official solution would be for you

 

if you use supported OS distro, latest ubuntu has supported mongodb:

1. uninstall manually installed mongodb and its dependencies

2. install mongodb from repository

 

If you use unsupported distro:

1. compile and install all missing packages and their dependencies manually.

 

As you use VM:

1. use it without vm

    (even if it is windows machine, running omada will waste much less resources as well as it would resolve many known troubles of vm usage together with omada.)

 

If you are not satisfied with any of available solution, then you probably should bug in the right place, tp-link forum is not, simply request and troll your OS's support to upgrade mongodb to version which you need.

 

Why is here wrong place to ask?:

Because tp-link does not maintain packages for your OS and supported OS's include v3.

 

What did tp-link guide not tell you or what is missing?:

Guides do not cover often everything around like basic user experience, like what is a difference for a user if one compiles manually packages and how to maintenance upgrades, that is out of scope for a guide about how to install something. In general, most distros provide what in general by most its users is required. Exactly for that reason, tp-link SHOULD EDIT their guide with ⚠️WARNING⚠️ that if one installs manually packages then they need to take care about updates and that tp-link is not able to offer such support, instead recommended solution would be to use OS's available packages which they officially support and if some OS maintainers decide to upgrade mongodb to higher version, then at least omada would work and normal user would just need to keep its system up to date and does not break compatibility with further releases.

  0  
  0  
#9
Options
Re:(Linux) Unable to upgrade from 5.0.30 to 5.1.7
2022-03-26 00:24:13

  @btx 

 

Installing from tar on the exact same VM is working fine.

 

Locking thread. 

  0  
  0  
#10
Options