Syslog not working

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Syslog not working

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Syslog not working
Syslog not working
2022-11-14 08:17:48
Model: TL-R600VPN  
Hardware Version: V4
Firmware Version: 4.0.4 Build 20200313 Rel.41831

I have configured my TL-R600VPN to send syslog messages to my syslog server.

 

Logging messages show up fine in the Log console within the TP-Link GUI.  But they never get sent to the syslog server.

 

Other devices on the network send messages fine to the syslog server, so it is not a syslog server problem.

 

The syslog server configuration within the TP-Link GUI is very straightforward (just enter the syslog server IP address) so I don't see what if anything I'm doing wrong.

  0      
  0      
#1
Options
3 Reply
Re:Syslog not working
2022-11-15 12:37:51

  @hspindel 

 

Did you set a static IP or DHCP resevation for the syslog server?

Just striving to develop myself while helping others.
  0  
  0  
#2
Options
Re:Syslog not working
2022-11-15 21:57:45

  @hspindel 

I had a problem like that, too. I was sending, and still do, syslog messages from several devices in my network to one of my Synology NASes. There were two TP-Link APs among them. Everything was fine for a couple of months, but one day syslog messages from one of those APs stopped coming. I have never found out why. I even tried to send them to another Synology NAS, but it did not work either. Now, when I think about it, I suspect that it might’ve been related to the Omada Controller I installed on my Linux server about the same time. However I were not using the Controller at that time at all. I did not adopt any devices into it for at least three weeks and I did not make any changes to its default configuration. I certainly did not set it up to send syslog messages at that time. I was still managing the APs with their Web Admin portals. Now, I have both APs adopted into the Controller and its syslog messages sent to the NAS so I’m not trying to solve that mystery anymore.

Kris K
  0  
  0  
#3
Options
Re:Syslog not working
2022-11-16 02:44:02

  @Virgo 

 

The computer with the Syslog server gets its IP via DHCP.  But the TP-Link Syslog target is configured with a hardcoded IP address for the Syslog server.  And yes, the TP-Link Syslog target is always correct because the DHCP IP address assigned to the Syslog server is reserved to a specific IP address.  And I've verified that they match.

  0  
  0  
#4
Options

Information

Helpful: 0

Views: 341

Replies: 3

Related Articles