DDNS not sending updates

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

DDNS not sending updates

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
DDNS not sending updates
DDNS not sending updates
2023-03-27 11:52:57 - last edited 2023-04-06 07:04:37
Model: ER605 (TL-R605)  
Hardware Version: V2
Firmware Version: 2.1.2

I use az ER605 with a SW controller. Tried  version 5.8.4, 5.9.9 and now 5.9.31, they all behave the same. After I configure NO-IP DDNS, the first update arrives, but nothing else.

I tried to select NO-IP from the drop-down but also did a custom config with the update-url. Tried 1 hour and 6 hours. Restarted everything multiple times.
Nothing seems to resolve the issue unfortunately.

Is there something I miss?
Thanks!

  0      
  0      
#1
Options
1 Accepted Solution
Re:DDNS not sending updates-Solution
2023-04-06 07:04:09 - last edited 2023-04-06 07:04:37

Seems like I'll be another user who got this magically working without knowing what have I done wrong.

I tried the same with the 3rd version of the controller. I deleted all ddns configuration, restarted every single device and the controller. Recreated the exact same configuration, and now, if I force a new IP from my ISP by restarting the modem, NO-IP gets updated. Finally.

Recommended Solution
  0  
  0  
#8
Options
7 Reply
Re:DDNS not sending updates
2023-03-28 08:19:20

  @dudasm 

 

Hi, can you confirm if the DDNS server updated?

If you disable DDNS settings and enable it, will it update?

Do you have a screenshot to show your issue?

Just striving to develop myself while helping others.
  0  
  0  
#2
Options
Re:DDNS not sending updates
2023-03-28 09:05:23

  @Virgo 

Yes, when I switch the config off and on again, it sends a single update.

 

Although I think it was not the case with the previous controller versions, I needed to create a completely new configuration, to send a single update if I remember correctly.

 

I'll add screenshots later today. 

 

My problem is really similar to this one here:

https://community.tp-link.com/en/business/forum/topic/273946

 

But the first ~10 restart of every single device did not resolve the issue for me.

 

Thanks!

  0  
  0  
#3
Options
Re:DDNS not sending updates
2023-03-29 09:25:57

I don't expect anything to be wrong here, as both of these configurations send a single update, but here they are:




Yes, I tried to enable it when I was trying to debug. ;) 

 


This one also send a single update when I enable it, so the URL should be good here as well.



There are quite a few similar issues:
DDNS Not updating - Business Community (tp-link.com)
Omada OC300 with ER7206 no DDNS Update via No-IP - Business Community (tp-link.com)
No-IP DDNS not updating after v5.0.30 - Business Community (tp-link.com)
DDNS (NO-IP) not updating with Omada Configuration - Business Community (tp-link.com)

But these are not resolved or magically gone...
I could set up the ddns on the server running the controller separately as a workaround, but this should be a basic feature even in a commercial router...

I'll try to create a new configuration now, as that is something I haven't tried since upgrading to 5.9.31.

  0  
  0  
#4
Options
Re:DDNS not sending updates
2023-03-30 14:52:07

Hi,

 

I have the same Issue with my ER8411. One Time update and that's it.

 

I wonder what is functioning at this "Buisniss Grade" Router. First NAT Mapping does not work and now DDNS Service. 
 

I think it back

 

Greetings

Wally

 

  1  
  1  
#5
Options
Re:DDNS not sending updates
2023-03-31 03:26:03 - last edited 2023-03-31 03:28:07

Hello @dudasm, @WallyRT ,

 

Thank you all for reporting this issue to our community.

 

May I double confirm more details about the DDNS not sending updates issue as follow?

1. Do you mean the public WAN IP is updated but the NO-IP DDNS domain name resolves to a WAN IP that is still not updated (unchanged)?

 

2. How did you find this issue?

For example, you try to trigger the WAN IP change manually and then find the DDNS domain name resolves to a WAN IP that is still not updated.
Or you found there are no DDNS update logs on the controller so you thought the NO-IP was not updated.

 

3. Could you please confirm if the IP shown in your NO-IP server is the same as the current WAN IP?

You may try resolving the domain name on the PC with the nslookup command to see if the IP returned is correct.
Here is the link (point1 and 4) for your reference.

Best Regards! >> Omada EAP Firmware Trial Available Here << >> Get the Latest Omada SDN Controller Releases Here << *Try filtering posts on each forum by Label of [Early Access]*
  0  
  0  
#6
Options
Re:DDNS not sending updates
2023-03-31 11:19:49

  @Hank21 

1. yes

 

2. I can force a new WAN IP by restarting the modem, I can just wait because periodically my ISP assigns new IP. 

I can see no logs re DDNS update (though I don't know whether I should see something or not?) in the controller. 

I can see no change in the last update date on the NO-IP website.

 

3. When I switch the DDNS config off and on again, and it updates for the first and only time, my WAN IP on the NO-IP website is correct.
 

  0  
  0  
#7
Options
Re:DDNS not sending updates-Solution
2023-04-06 07:04:09 - last edited 2023-04-06 07:04:37

Seems like I'll be another user who got this magically working without knowing what have I done wrong.

I tried the same with the 3rd version of the controller. I deleted all ddns configuration, restarted every single device and the controller. Recreated the exact same configuration, and now, if I force a new IP from my ISP by restarting the modem, NO-IP gets updated. Finally.

Recommended Solution
  0  
  0  
#8
Options

Information

Helpful: 0

Views: 504

Replies: 7