TL-ER604W Router stops responding after vpn + bugs found

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

TL-ER604W Router stops responding after vpn + bugs found

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
TL-ER604W Router stops responding after vpn + bugs found
TL-ER604W Router stops responding after vpn + bugs found
2015-01-27 06:44:22 - last edited 2021-08-21 04:37:59
Region : Greece

Model : TL-ER604W

Hardware Version : V1

Firmware Version : 1.1.0 Build 20141031 Rel.32628s

ISP : Forthnet


Hello, i bought this router 3 days ago and i experience some problems..
I've updated the firmware from day 1.. Also after some changes that i've made i have made a factory reset but all the problems remain.

1st. The SIP ALG even when disabled still works and my asterisk server could not work correctly... I had to change the default ports from 5060 to another

2. When i reboot the router, the wan 1 connection which is configured as PPPOE/Russina PPPOE says that it cannot connect because it has a wrong password... Sometimes it gets a weird ip that is not provided from my ISP. 10.99.something
Sometimes after the wrong password it manage to connect without on its own without making any changes...

3. The big problem...

LAN: 10.2.2.1
WAN1: PPOE
WAN2: 10.2.5.2 (using a static ip with gateway 10.2.5.1 from another router)
PPTP_POOL: 10.2.3.100 - 150
Netbios Passthrough Enabled
Encryption on PPTP = OFF

When i connect to pptp the remote computer cannot connect to my local network..but its not a routing problem (as i think..) Because every time i connect with pptp , the router stops responding ..
I cannot access the web interface , DNS requests won't work but routing works ... (can ping outside world,and if i use another dns on my pc can see some pages )
Sometime things work fine but not always

Also , i see on the logs for some udp flood and packets dropped when i manage to connect to PPTP without the router crashing...

The problem with the PPTP is the most frustrating problem.. Please advice
  0      
  0      
#1
Options
3 Reply
Re:TL-ER604W Router stops responding after vpn + bugs found
2015-01-27 19:51:34 - last edited 2021-08-21 04:37:59
:)

1. Why SIP ALG will effect your asterisk server? How do ya know SIP ALG still works?

2. Just an ISP issue I think, make a call I suggest

3. When remote computer wants to connect, 604w stops responding? You mean hang up? Totally dead?

How about access web page from internal, to have a look at the status of PPTP tunnel, has it been established?
  0  
  0  
#2
Options
Re:TL-ER604W Router stops responding after vpn + bugs found
2015-01-27 21:36:51 - last edited 2021-08-21 04:37:59

rockryan wrote

:)

1. Why SIP ALG will effect your asterisk server? How do ya know SIP ALG still works?

2. Just an ISP issue I think, make a call I suggest

3. When remote computer wants to connect, 604w stops responding? You mean hang up? Totally dead?

How about access web page from internal, to have a look at the status of PPTP tunnel, has it been established?


THank you for answering my post.

Well..
1. Because the same problem occurs even if its on or off .. This was not happening with my old router.. Only when i bought TD-W8960N dsl-router and now with the tl-er604w..
My old router didn't have ALG firewall and everything was fine.from the day i bought the tp link routers with the ALG firewall the problem started to happen..
One way calls, or dropping the call at 20 sec. (A lot of people,owners of td-8960nd mentioned this problem..)
When you change the standart sip port from 5060 to 24900 (for example) so that the firewall is not monitoring this traffic, everything works fine
Configuring the asterisk behind SIP ALG firewall is pain in the ......and this is not an answer if someone thinks to say to configure everything again.

2. Never happened with none of my routers . Its definitely from the router . im sure!

3. Yes when a remote computer connects to pptp on 604w The DNS stops working, The web interface is not accessible from anywhere, the telnet is connecting but not responding normally(just answers but does not give the option to give user/pass)
BUT! you can ping the outside world... And i made a test i've used another dns instead of 604w and i was able to browse the net. And after that i have to reboot the router for everything to work again.

From some experiments that i've done its working now but not sure for how long..
PPTP ALG =on if it's turnet off pptp doesn't work
ATTAK Defence -> All the flood defence options enabled.. If i turn off some of the options the router will stop responding again .Maybe the problem is located there , but not 100% sure about this.
  0  
  0  
#3
Options
Re:TL-ER604W Router stops responding after vpn + bugs found
2015-02-03 14:08:06 - last edited 2021-08-21 04:37:59
  0  
  0  
#4
Options

Information

Helpful: 0

Views: 916

Replies: 3

Related Articles