TL-ER604W and RDP

TL-ER604W and RDP
TL-ER604W and RDP
2015-04-02 05:36:19
Region : UnitedStates

Model : TL-ER604W

Hardware Version :

Firmware Version :

ISP :


I have a TP-Link TL-ER604W and I'm trying to get it to pass Microsoft RDP (Remote Desktop Protocol) traffic from the WAN port through to the LAN port and to a specific IP address behind the 604W. I have double and triple checked all the options. Nothing. Here are the settings:

Incoming = WAN
Address = ALL
Outgoing = LAN
Address = 10.x.x.7
Start Port = 3389
End Port = 3389

What am I missing? RDP works just fine behind the 604W firewall. But I can not get the 604W to port forward for some reason. HELP!

TIA.
0
0
#1
Options
7 Replies
Re:TL-ER604W and RDP
2015-05-14 06:48:39
Is anyone ever going to answer my question / issue?
0
0
#2
Options
Re:TL-ER604W and RDP
2015-05-14 10:36:53
You are trying to open port 3389 for 10.x.x.7 on ER604W and access it remotely via remote desktop connection, right?
Protocol is TCP? WAN IP is public?
0
0
#3
Options
Not sure where you are putting those settings but...
2015-05-15 03:03:24

KWheelerAZ wrote

Region : UnitedStates

Here are the settings:

Incoming = WAN
Address = ALL
Outgoing = LAN
Address = 10.x.x.7
Start Port = 3389
End Port = 3389

TIA.


I am not sure where you are pulling these settings from or where you set them. But it should look something more like this.

Go to Advanced
Go to NAT
Go to the Tab that says Virtual Server

Here is where your settings should be:

Name: RDP to PC Name
Interface: WAN1
External Port: 3389-3389
Internal Port: 3389-3389
Protocol: TCP/UDP
Internal Server IP: 10.x.x.7
Status: Activate

And Click Add

Then you should be good to go

If you are testing RDP from another location and are using your WAN address to connect to RDP you can use the following site to make sure your port is open: http://www.canyouseeme.org/ and check the port 3389
0
0
#4
Options
Re:TL-ER604W and RDP
2015-05-15 05:52:58

Tony Seaford wrote

You are trying to open port 3389 for 10.x.x.7 on ER604W and access it remotely via remote desktop connection, right?


Correct

Protocol is TCP?


Correct

WAN IP is public?


Also correct. Right on all counts.

I have a few of these scattered around my clients. I tried on a couple and could not get RDP to pass, period.
0
0
#5
Options
Re:TL-ER604W and RDP
2015-05-15 10:52:31
Thank you quigley0908! That was it!

I was working in the Firewall / Security area. I forgot all about the Virtual Server section. Viola! All better now. Thanks.
0
0
#6
Options
Re:TL-ER604W and RDP
2018-03-27 11:35:29
Hi Guys,

I have tried to forward particular port inside my network using that Virtual server settings but it is not working.

Your advise / suggestions are very much appreciated. Is there any lacking in my config??

Thanks!
0
0
#7
Options
Re:TL-ER604W and RDP
2018-03-27 20:11:03
Such a great post to know different useful information.
0
0
#8
Options