Tl-r470t+: Virtual server doesn't work

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Tl-r470t+: Virtual server doesn't work

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Tl-r470t+: Virtual server doesn't work
Tl-r470t+: Virtual server doesn't work
2015-10-27 00:45:53 - last edited 2021-08-21 05:28:12
Model : TL-R470T+

Hardware Version : V4

Firmware Version : 1.1.0 Build 20150526 Rel.71817s

ISP :



[/TD]









[TR][TD="class: FRAMEWORK_LEFT"]Firmware Version:[TD]1.1.0 Build 20150526 Rel.71817s
Hardware Version: TL-R470T+ v4.0

[/TD]
[/TR]



Hi I have a problem setting up the virtual server on my TL-R470T+.

I configured it with 2 wan and failover, with WAN1 main line and WAN2 backup line.
Then I need some external connection for some service inside my network, so I set up this Virtual server configuration:

[COLOR=#173A7E]List of Rules















[TD="class: EDIT"]
[/TD]
[TD="class: NORMAL, width: 5%"]1
Service WAN-ALL TCP/UDP 8080 80 192.168.3.239 Active [TABLE="class: AUTO_CENTER"]
[/TD]
[TD="class: DELETE"]

[/TD]


[/TD]
[TD="class: NORMAL"]2
c1
WAN-ALL
TCP/UDP
65001
81
192.168.3.234
Active





[TD="class: EDIT"]
[/TD]
[TD="class: DELETE"]

[/TD]


[/TD]
[TD="class: NORMAL"]3
c2
WAN-ALL
TCP/UDP
65002
81
192.168.3.235
Active





[TD="class: EDIT"]
[/TD]
[TD="class: DELETE"]

[/TD]


[/TD]
[TD="class: NORMAL"]4
c3
WAN-ALL
TCP/UDP
65003
81
192.168.3.236
Active





[TD="class: EDIT"]
[/TD]
[TD="class: DELETE"]

[/TD]


[/TD]
[TD="class: NORMAL"]5
c4
WAN-ALL
TCP/UDP
65004
81
192.168.3.237
Active





[TD="class: EDIT"]
[/TD]
[TD="class: DELETE"]

[/TD]


[/TD]
[TD="class: NORMAL"]6
c5
WAN-ALL
TCP/UDP
65005
81
192.168.3.238
Active





[TD="class: EDIT"]
[/TD]
[TD="class: DELETE"]

[/TD]

[/TABLE]




But when I try to connect to one of this services from outside the connection doesn't work because all this port are closed.

If I setup the virtual server like this on an old router every server works fine.

Is this a bug of this TL-R470T+?
How can I fix this problem?
I miss something?

Thanks for the answers.
  0      
  0      
#1
Options
6 Reply
Re:Tl-r470t+: Virtual server doesn't work
2015-11-02 15:48:10 - last edited 2021-08-21 05:28:12
I don't see bugs in your config (assuming you're using "Advanced -> NAT -> Virtual server". Some have reported that they needed to restart their routers.

I also have portforwarding enabled but I use it on"WAN1" only - maybe try this first?
  0  
  0  
#2
Options
Re:Tl-r470t+: Virtual server doesn't work
2015-11-02 16:30:19 - last edited 2021-08-21 05:28:12
I also try to set Wan 1 only or WAN2 only, but nothing happened... i begin to think about a software bug...

PS I update with the last firmware but nothing.
  0  
  0  
#3
Options
Re:Tl-r470t+: Virtual server doesn't work
2015-11-03 14:44:17 - last edited 2021-08-21 05:28:12
I also have this firmware, it work fine for me.
remember one port on NAT can only be mapped to one host.
  0  
  0  
#4
Options
Re:Tl-r470t+: Virtual server doesn't work
2015-11-03 16:08:00 - last edited 2021-08-21 05:28:12
According to Roberto's list, it is!
  0  
  0  
#5
Options
Re:Tl-r470t+: Virtual server doesn't work
2015-11-03 16:32:46 - last edited 2021-08-21 05:28:12
I try to configure this Visrtual server setup on another router (without load balancing service) and all works fine. But I buy this router only to be able to switch automatically from WAN1 to WAN2 in failover configuration.
I think that here I have 2 possibility:
1) some configuration issue that i miss
2) a software bug

For the point 1: I ask if someone here can help me.
For the point 2: I called TP-link support and they forward the problem to china... Is it the right direction??
  0  
  0  
#6
Options
Re:Tl-r470t+: Virtual server doesn't work
2015-11-04 15:40:53 - last edited 2021-08-21 05:28:12
I also had an issue that resulted in TP-Link discovering a bug. Yes, the developers are in China.

I also use Load Balancing, but not in failover mode. Good luck!
  0  
  0  
#7
Options

Information

Helpful: 0

Views: 876

Replies: 6

Related Articles