@HieronymosX
So I got a got further ... this is now the switch config
!T1600G-52PS
#
vlan 10
name "MGMT"
#
vlan 26
name "IOTCAM"
#
vlan 62
name "USER"
#
#
hostname "Switch"
location "Brussels"
contact-info "xxxxxxxxx@gmail.com"
#
#
system-time ntp UTC+08:00 133.100.9.2 139.78.100.163 12
no system-time dst
#
#
#
user name AAAAdmin privilege admin secret 5 $1$E0C4@F=$)]{%
user name admin privilege admin secret 5 $1$E0CG6B2F=$)]{%
no service reset-disable
#
#
#
#
#
service dhcp server
ip dhcp server excluded-address 192.168.10.1 192.168.10.10
ip dhcp server excluded-address 192.168.10.250 192.168.10.254
ip dhcp server excluded-address 192.168.26.1 192.168.26.10
ip dhcp server excluded-address 192.168.26.250 192.168.26.254
ip dhcp server excluded-address 192.168.62.1 192.168.62.10
ip dhcp server excluded-address 192.168.62.250 192.168.62.254
#
ip dhcp server pool "IOTCAM"
network 192.168.26.0 255.255.255.0
default-gateway 192.168.26.254
dns-server 192.168.0.1
#
ip dhcp server pool "USER"
network 192.168.62.0 255.255.255.0
default-gateway 192.168.62.254
#
ip dhcp server pool "MGMT"
network 192.168.10.0 255.255.255.0
default-gateway 192.168.10.254
#
#
#
#
#
#
ip route 0.0.0.0 0.0.0.0 192.168.0.1
ip route 192.168.10.0 255.255.255.0 192.168.10.254
ip route 192.168.26.0 255.255.255.0 192.168.26.254
ip route 192.168.62.0 255.255.255.0 192.168.62.254
#
#
#
power inline consumption 384.0
#
#
#
#
#
#
#
interface vlan 1
no ip address
ipv6 enable
#
interface vlan 10
ip address 192.168.10.254 255.255.255.0
description "MGMT"
no ipv6 enable
#
interface vlan 26
ip address 192.168.26.254 255.255.255.0
description "IOTCAM"
no ipv6 enable
#
interface vlan 62
ip address 192.168.62.254 255.255.255.0
description "UserVLAN"
no ipv6 enable
#
interface gigabitEthernet 1/0/1
no switchport
ip address 192.168.0.2 255.255.255.248
no ipv6 enable
no ip igmp snooping
no ipv6 mld snooping
#
interface gigabitEthernet 1/0/2
#
interface gigabitEthernet 1/0/3
switchport general allowed vlan 26 untagged
switchport pvid 26
no switchport general allowed vlan 1
...ports all configured same
#
interface gigabitEthernet 1/0/12
switchport general allowed vlan 26 untagged
switchport pvid 26
no switchport general allowed vlan 1
#
interface gigabitEthernet 1/0/13
switchport general allowed vlan 62 untagged
switchport pvid 62
no switchport general allowed vlan 1
...ports all configured the same
#
interface gigabitEthernet 1/0/46
switchport general allowed vlan 62 untagged
switchport pvid 62
no switchport general allowed vlan 1
#
interface gigabitEthernet 1/0/47
switchport general allowed vlan 10 untagged
switchport pvid 10
no switchport general allowed vlan 1
#
interface gigabitEthernet 1/0/48
switchport general allowed vlan 10 untagged
switchport pvid 10
no switchport general allowed vlan 1
#
interface gigabitEthernet 1/0/49
switchport general allowed vlan 62 untagged
switchport pvid 62
no switchport general allowed vlan 1
#
interface gigabitEthernet 1/0/50
switchport general allowed vlan 62 untagged
switchport pvid 62
no switchport general allowed vlan 1
#
interface gigabitEthernet 1/0/51
switchport general allowed vlan 62 untagged
switchport pvid 62
no switchport general allowed vlan 1
#
interface gigabitEthernet 1/0/52
switchport general allowed vlan 62 untagged
switchport pvid 62
no switchport general allowed vlan 1
#
end
The clients connecting to the ports get the right IP addresses from DHCP scope, and they can each ping vlan specific default gateway on 192.168.xx.254
The switch can ping 8.8.8.8, so has internet access
But I cannot ping intervlan, nor have internet access on the vlans
The router cannot do CLI (bummer) so I need to describe the settings...
Routing table
1 192.168.62.0 255.255.255.0 0.0.0.0 LAN 0
2 192.168.10.0 255.255.255.0 0.0.0.0 LAN 0
3 0.0.0.0 0.0.0.0 192.168.1.1 WAN1 0
4 127.0.0.0 255.0.0.0 0.0.0.0 lo 0
5 192.168.0.0 255.255.255.248 0.0.0.0 LAN 0
6 192.168.1.0 255.255.255.0 0.0.0.0 WAN1 0
7 192.168.1.1 255.255.255.255 0.0.0.0 WAN1 0
Router has internet access, when I connect a client to port G1/0/3 and give manual IP of e.g. 192.168.0.3/255.255.255.248, I have internet access on the client. Also, as said, the switch itself has a route to internet...
Any advice?
Thx
J-HieronymosX