Omada Software Controller 4.1.5?

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Omada Software Controller 4.1.5?
Omada Software Controller 4.1.5?
2020-07-07 17:20:47 - last edited 2020-07-09 13:21:03
Model: EAP245
Hardware Version: V3
Firmware Version: 4.1.5

Looks like the new SDN controller is released for Windows. No Linux yet.

Note the caveats (I highlighted in red bold below), including no downgrades and required firmware versions.

Anybody trying this should backup their existing v3 controller in case they need to revert, and ideally install this separately for testing. Given a lot of changes, expect some bugs undocumented features. ;)

 

I have not tried it as I don't use Windows (Raspberry Pi for me). I just noticed it was released yesterday.

(Ignore the model and version I selected above; I had to pick something and Omada software controller is not an option).

 

https://www.tp-link.com/ca/support/download/omada-software-controller/#Controller_Software

 

 

 

Supported device models and firmware:

EAP110_V4 3.20.0 Build 20200525 Rel. 36899 and above

EAP115_V4 3.20.0 Build 20200525 Rel.36931 and above

EAP225_V3 2.20.0 Build 20200422 Rel. 70513 and above

EAP245_V3 2.20.0 Build 20200423 Rel. 36779 and above

EAP115-Wall_V1 1.20.0 Build 20200509 Rel. 63986 and above

EAP225-Wall_V2 1.20.0 Build 20200422 Rel. 70504 and above

EAP110-Outdoor_V3 3.20.0 Build 20200511 Rel. 33388 and above

EAP225-Outdoor_V1 1.20.0 Build 20200422 Rel. 70543 and above

EAP265 HD_V1

EAP230-Wall_V1

EAP235-Wall_V1

EAP660 HD_V1

EAP620 HD_V1

TL-R605_V1

TL-ER7206_V1

TL-SG2210MP_V1

TL-SG2428P_V1

TL-SG2008P_V1

TL-SG2210HP-M2_V1

 

New Feature/Enhancement:

1. Omada SDN software controller provides a unified approach to configuring enterprise networks comprised of routers, switches, and wireless access points.

2. Brand new UI and style to provide high-efficiency, rapid and comprehensive network settings and maintenance function.

3. Add brand new Dashboard interface to monitor network operation in real time.

4. Add Statistics interface to monitor devices and show the statistics of network operation data.

5. Add Topology interface to generate the network topology automatically.

6. Add Insight interface to view the detailed network history data.

7. Add Logs interface that supports 100+ types of logs and custom warning level of logs.

8. Support to configure for gateway, including Internet, LAN Network, ACL, URL Filtering, VPN, Routing, NAT, Session Limit, Bandwidth Control, Portal and so on.

9. Support to configure for switch, including 802.1Q VLAN, ACL, 802.1x, IGMP Snooping, STP and so on.

10. Add Reboot Schedule and PoE Schedule and support to set different schedules for each device.

 

Notes:

1. Omada SDN Controller can configure and manage only the certain devices with supported firmware. You need to make sure your device is compatible with Omada SDN Controller.

2. If you are using Omada Controller and plan to upgrade to this version, please follow the procedure of Omada Controller Upgrade Guide.

3. Once upgraded to this version of Omada Controller, you will NOT able to downgrade to an earlier version.   <---------

4. This version of controller is applied to Omada APP of version 3.0.X or above.

1
1
#1
Options
41 Reply
Re:Omada Software Controller 4.1.5?
2020-07-08 00:32:58 - last edited 2020-07-09 13:21:03

 

nojak wrote

Notes:

1. Omada SDN Controller can configure and manage only the certain devices with supported firmware. You need to make sure your device is compatible with Omada SDN Controller.

 

This is an important point. Make sure your device is compatible and wait until the firmware for this device is released if you want to deploy SDN controller in the field.

 

3. Once upgraded to this version of Omada Controller, you will NOT able to downgrade to an earlier version.   <---------

 

This probably needs some clarification: Of course you can always downgrade any software to any earlier version. You'll only lose settings in the new version imported from the old settings or added in the new version. The Linux community version of Omada controller could even switch on the fly between as many Omada Controller versions as had been installed if those versions had not been removed when upgrading. The Windows version can also be downgraded by removing the new version and re-installing the old version.

 

What can not be downgraded automatically is the controller's database, that's your particular setup/config of Omada Controller. But if you did save the old database before upgrading, you can restore older databases in older controller versions.

 

With SDN controller you also would have to downgrade every firmware of every device which has been upgraded to SDN-compatible firmware. But this downgrade is possible, too.

 

So, the above should read: Omada Controller does not provide a downgrade path in its web UI for the average user.

༺ 0100 1101 0010 10ཏ1 0010 0110 1010 1110 ༻
0
0
#2
Options
Re:Omada Software Controller 4.1.5?
2020-07-08 15:09:21 - last edited 2020-07-09 13:21:03

I've tried this controller, and have run into two glitches.

 

1.  Sending logs by email does not work. No matter what email address or email server I use, the end-result is an error saying "Unable to send to email address".

 

2. The controller does not have the ability to use SMS authentication.

 

When an update is released, I will test again.

 

Robert

0
0
#3
Options
Re:Omada Software Controller 4.1.5?
2020-07-12 16:35:24

After install, both EAP225 outdoor v1 and 225 v3 had an error message:

This device is not compatible with the current controller

 

I downlaoded latest firmware for both and the 225v3 still has the error and cannot be managed.

 

This despite the controller page stating:

EAP225_V3 2.20.0 Build 20200422 Rel. 70513 and above

 

I have tried EU (2.7.0) as well as EU/US 2.6.1

 

Thoughts?

 

0
0
#4
Options
Re:Omada Software Controller 4.1.5?
2020-07-12 19:55:42

Also, no way to change EAP out of mixed mode...  Uninstalling and going back to old version ASAP.  Looks pretty but isn't ready for deployment.

0
0
#5
Options
Re:Omada Software Controller 4.1.5?
2020-07-13 02:07:14

@sadpanda 

 

Hi,

 

sadpanda wrote

After install, both EAP225 outdoor v1 and 225 v3 had an error message:

This device is not compatible with the current controller

 

I downlaoded latest firmware for both and the 225v3 still has the error and cannot be managed.

 

This despite the controller page stating:

EAP225_V3 2.20.0 Build 20200422 Rel. 70513 and above

 

I have tried EU (2.7.0) as well as EU/US 2.6.1

 

Thoughts?

 

 

If your EAP225-Outdoor and EAP245 V3 are EU version, please follow the link below to download the latest firmware that supports SDN Controller.

 

1. EAP225-Outdoor (EU/US)

https://www.tp-link.com/en/support/download/eap225-outdoor/#Firmware

 

2. EAP225 V3 (EU)

https://www.tp-link.com/en/support/download/eap225/#Firmware

 

If your EAP225 v3 is US version, please wait for the lasted firmware (Build 20200630) comping up. Thank you for your patience.

New to the TP-Link Community? Getting Started from this thread: https://community.tp-link.com/en/business/forum/topic/551684
0
0
#6
Options
Re:Omada Software Controller 4.1.5?
2020-07-13 02:12:12

@sadpanda

 

Thank you for the feedback.

 

Also, no way to change EAP out of mixed mode...  Uninstalling and going back to old version ASAP.  Looks pretty but isn't ready for deployment.

 

May I know the model and firmware version of your EAPs? 

New to the TP-Link Community? Getting Started from this thread: https://community.tp-link.com/en/business/forum/topic/551684
0
0
#7
Options
Re:Omada Software Controller 4.1.5?
2020-07-13 16:03:51

@Fae 

 

EAP225 outdoor US, V1 firmware 1.20.0

 

EAP225  indoor US, V3 firmware 2.6.1

0
0
#8
Options
Re:Omada Software Controller 4.1.5?
2020-07-13 18:49:23
I'm awaiting the 4.1.5 Linux controller too (although it's running on my QNAP NAS rather than a Pi).
0
0
#9
Options
Re:Omada Software Controller 4.1.5?
2020-07-14 10:31:26

@Fae 

Why relesase it if it's not fully functional?  Seems this is definitely in beta stage.

0
0
#11
Options
Re:Omada Software Controller 4.1.5?
2020-07-14 12:34:45

R1D2 wrote

 

nojak wrote

Notes:

1. Omada SDN Controller can configure and manage only the certain devices with supported firmware. You need to make sure your device is compatible with Omada SDN Controller.

 

This is an important point. Make sure your device is compatible and wait until the firmware for this device is released if you want to deploy SDN controller in the field.

 

3. Once upgraded to this version of Omada Controller, you will NOT able to downgrade to an earlier version.   <---------

 

This probably needs some clarification: Of course you can always downgrade any software to any earlier version. You'll only lose settings in the new version imported from the old settings or added in the new version. The Linux community version of Omada controller could even switch on the fly between as many Omada Controller versions as had been installed if those versions had not been removed when upgrading. The Windows version can also be downgraded by removing the new version and re-installing the old version.

 

What can not be downgraded automatically is the controller's database, that's your particular setup/config of Omada Controller. But if you did save the old database before upgrading, you can restore older databases in older controller versions.

 

With SDN controller you also would have to downgrade every firmware of every device which has been upgraded to SDN-compatible firmware. But this downgrade is possible, too.

 

So, the above should read: Omada Controller does not provide a downgrade path in its web UI for the average user.

Hello a Firmware Upgrade caused incompatibility of connected EAP-225 Outdoor and totally remove my configuration from Version 3.2.12 with firmware 1.2.3 Build 20200430 Rel.52621 upgraded to Version 4.1.5 with firmware 1.7.0 Build 20200703 Rel. 59609. How do I revert the Firmware to its Factory Settings to "version 3.2.12 with firmware 1.2.3 Build 20200430 Rel.52621"? Please HELP

0
0
#12
Options