Help with T1600G-28PS hardware V2/V3 and SDN compatibility

Help with T1600G-28PS hardware V2/V3 and SDN compatibility
Help with T1600G-28PS hardware V2/V3 and SDN compatibility
2020-10-17 19:09:50 - last edited 2020-11-04 03:59:12
Hardware Version:
Firmware Version:

Hi,

 

Does anyone have experience using the T1600G-28PS with the new Omada SDN software?

 

I am looking at the Support site for this switch. It appears that only Version 3 will support the new Omada SDN (there is no Firmware update for Version 2). Do I have that correct?

 

The reason I ask is because I looked for purchasing it but the products for sale at both MicroCenter and at Amazon look like they are from the Version 2 hardware based on the pictures of them.

 

For example, this product picture matches the picture of the Version 2 on the TP-Link website.

 

https://www.microcenter.com/product/468221/tp-link-jetstream-24-port-gigabit-smart-poe-switch-w--4-sfp-slots

 

Can anyone shed some light on what I can expect?

 

1 - Is that picture actually a version 2?

2 - Does the V2 hardware work with SDN 4.1.x ?

 

Thank you!

0
0
#1
Options
1 Accepted Solution
Re:Help with T1600G-28PS hardware V2/V3 and SDN compatibility-Solution
2020-10-18 01:28:51 - last edited 2020-11-04 03:59:12

@Will_M 

I purchased one from Microcenter a couple of months ago and it is hardware version 3.6 (not v2 as pictured) and does work with the new Omada SDN. I would expect the version on Amazon (from the Tp-Link store) should be the latest as well. 

Recommended Solution
0
0
#2
Options
6 Reply
Re:Help with T1600G-28PS hardware V2/V3 and SDN compatibility-Solution
2020-10-18 01:28:51 - last edited 2020-11-04 03:59:12

@Will_M 

I purchased one from Microcenter a couple of months ago and it is hardware version 3.6 (not v2 as pictured) and does work with the new Omada SDN. I would expect the version on Amazon (from the Tp-Link store) should be the latest as well. 

Recommended Solution
0
0
#2
Options
Re:Help with T1600G-28PS hardware V2/V3 and SDN compatibility
2020-10-19 09:20:24

Dear @Will_M,

 

1 - Is that picture actually a version 2?

2 - Does the V2 hardware work with SDN 4.1.x ?

 

1. To confirm the hardware version, you may contact the sales agent from the store to confirm it.

The hardware version is usually printed on the package, can be found near the model number or S/N.

 

2. V2 hardware doesn't work with SDN 4.1.X.

Best Regards!
0
0
#3
Options
Re:Help with T1600G-28PS hardware V2/V3 and SDN compatibility
2020-10-20 01:48:32

@Fae isn't the firmware with (UN) labelled universal through all hardware version?

I have a T1500G-10MPS V1, and I have no problem install V2 firmware on it and manage with Omada right now

0
0
#4
Options
Re:Help with T1600G-28PS hardware V2/V3 and SDN compatibility
2020-10-20 03:12:10

@pixielark Thank you for the reply, but you are talking about a different switch and the upgrade may not have the same possibilities between hardware versions for each of the switches since there are so many. Thanks again.

0
0
#5
Options
Re:Help with T1600G-28PS hardware V2/V3 and SDN compatibility
2020-10-20 06:55:35

 

Will_M wrote

@pixielark Thank you for the reply, but you are talking about a different switch and the upgrade may not have the same possibilities between hardware versions for each of the switches since there are so many. Thanks again.

 

That's correct. Not all of the switches can upgrade between hardware versions, only a few switches can do that.

 

The T1600G-28PS V2 cannot upgrade to the V3 firmware because they adopt different platforms.

Best Regards!
0
0
#6
Options
Re:Help with T1600G-28PS hardware V2/V3 and SDN compatibility
2020-11-04 04:00:38

 

To close out the thread, I did find a new T1600G-28PS V3 was in stock at MicroCenter when I went there in person. The website picture is just out of date.

0
0
#7
Options