TL-ER6020 - custom DNS server not working

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

TL-ER6020 - custom DNS server not working

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
TL-ER6020 - custom DNS server not working
TL-ER6020 - custom DNS server not working
2020-11-03 15:41:33 - last edited 2021-04-18 10:42:52
Model: TL-ER6020  
Hardware Version: V2
Firmware Version: 2.0.3 Build 20200623 Rel.39031

Hello everyone!

 

I have migrated from a Fritzbox to the TL-ER6020, mostly because of WAN-loadbalancing and failover. So far the setup of the router has been pretty smooth, I've just got one problem that's really bugging me:

 

Setting up custom DNS servers doesn't seem to be working.

 

I'm using a Raspberry Pi with Pi-hole installed to filter ads, insecure domains, family-unfriendly-content, and so on.

Using the Fritzbox it was pretty easy: the pi-hole (192.168.2.30 in my case) was set up as its primary DNS server and successfully resolved DNS-queries, filtering all the stuff I don't want to see.

 

Setting up the pi-hole as the primary DNS on each WAN-port (currently only one is active) on the TL-ER6020 seems to be getting ignored by the router. The pi-hole doesn't get any DNS-request from it, and no content is filtered or blocked.

 

I hope someone can help me resolve this issue, thanks in advance! :-)

  0      
  0      
#1
Options
2 Reply
Re:TL-ER6020 - custom DNS server not working
2020-11-06 02:20:00 - last edited 2021-04-18 10:42:52

Dear @Turnspit,

 

I'm using a Raspberry Pi with Pi-hole installed to filter ads, insecure domains, family-unfriendly-content, and so on.

Setting up the pi-hole as the primary DNS on each WAN-port (currently only one is active) on the TL-ER6020 seems to be getting ignored by the router. The pi-hole doesn't get any DNS-request from it, and no content is filtered or blocked.

 

I think you may need to get DHCP Clients to use Pi-hole as their DNS server.

Please configure the DNS Server under the menu Network > LAN > DHCP Server instead of under the menu Network > WAN.

Happy New Year! Meet Us at CES 2023 | Featuring Wi-Fi 7, Omada Business Networking, VIGI Video Surveillance
  0  
  0  
#2
Options
Re:TL-ER6020 - custom DNS server not working
2020-11-13 09:19:24 - last edited 2021-04-18 10:42:52

@Fae 

 

Hi Fae, thanks for the reply!

 

Sadly, this led to other problems and some devices and being reachable in the LAN anymore.

 

Since the TL-ER6020 doesn't seem to work with internal DNS-Server configured on the WAN-Port, unlike the FritzBox used before, I've disabled the DHCP-Server on the router and set my Pi-hole to be DHCP and DNS for my internal network.

 

Not exactly the solution I wanted, but it works! :-)

  0  
  0  
#3
Options

Information

Helpful: 0

Views: 858

Replies: 2

Related Articles