Mail Server Settings, Why no STARTTLS

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Mail Server Settings, Why no STARTTLS

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Mail Server Settings, Why no STARTTLS
Mail Server Settings, Why no STARTTLS
2020-11-11 09:48:51

I am trying to set up email sending from the software controller (Version 4.1.5) and the settings for the mail serve allow you to tick SSL, but has no options for STARTTLS. My mail server requires TLS for authenticated connections, but expects a plain connection followed by STARTTLS to move to a secure connection.

 

This does not seem to be a supported configuration, so I am not able to send email at the moment, unless there is a workaround?

  0      
  0      
#1
Options
4 Reply
Re:Mail Server Settings, Why no STARTTLS
2020-11-12 06:41:12

Dear @Ben.Suffolk,

 

I am trying to set up email sending from the software controller (Version 4.1.5) and the settings for the mail serve allow you to tick SSL, but has no options for STARTTLS. My mail server requires TLS for authenticated connections, but expects a plain connection followed by STARTTLS to move to a secure connection.

 

Try upgrading to Controller V4.2.4, tick SSL, and specify the port you need, check if it works for you.

https://www.tp-link.com/en/support/download/omada-software-controller/#Controller_Software

2022 TP-Link Wi-Fi 7 Product Launch Event | Watch the Replay at https://www.tp-link.com/us/wifi7/event/.
  0  
  0  
#2
Options
Re:Mail Server Settings, Why no STARTTLS
2021-05-17 14:25:02

@Ben.Suffolk 

Having the same problem, with version 4.3.5.
Tried with several mail servers, with different configurations, but did not work at all. Also had same configuration as in my eMail-client, but same result. Anything else waht i can do, anyone elso has an idea?.
Best,
Patrick

  0  
  0  
#3
Options
Re:Mail Server Settings, Why no STARTTLS
2021-05-18 05:48:53 - last edited 2021-05-18 09:07:59

Dear @mallorcalounge,

 

mallorcalounge wrote
Tried with several mail servers, with different configurations, but did not work at all. Also had same configuration as in my eMail-client, but same result. Anything else waht i can do, anyone elso has an idea?.

 

The current SDN Controller doesn't support configuring Mail Server with STARTTLS, but there is a plan to support STARTTLS in v5.x.

 

At present, you may choose other mail servers instead, refer to this FAQ.

2022 TP-Link Wi-Fi 7 Product Launch Event | Watch the Replay at https://www.tp-link.com/us/wifi7/event/.
  0  
  0  
#4
Options
Re:Mail Server Settings, Why no STARTTLS, also not on 5.0.29
2022-01-09 20:21:50

In 5.0.29 it doesnt work for me:

 

DEBUG SMTP: trying to connect to host "smtp.*****.****", port 587, isSSL false
220 us2.outbound.mailhostbox.com ESMTP Postfix
DEBUG SMTP: connected to host "smtp.*****.****", port: 587
EHLO 493c9d0c68f2
250-us2.outbound.mailhostbox.com
250-PIPELINING
250-SIZE 41648128
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH PLAIN LOGIN
250-AUTH=PLAIN LOGIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
DEBUG SMTP: Found extension "PIPELINING", arg ""
DEBUG SMTP: Found extension "SIZE", arg "41648128"
DEBUG SMTP: Found extension "VRFY", arg ""
DEBUG SMTP: Found extension "ETRN", arg ""
DEBUG SMTP: Found extension "STARTTLS", arg ""
DEBUG SMTP: Found extension "AUTH", arg "PLAIN LOGIN"
DEBUG SMTP: Found extension "AUTH=PLAIN", arg "LOGIN"
DEBUG SMTP: Found extension "ENHANCEDSTATUSCODES", arg ""
DEBUG SMTP: Found extension "8BITMIME", arg ""
DEBUG SMTP: Found extension "DSN", arg ""
STARTTLS
220 us2.outbound.mailhostbox.com ESMTP Postfix
DEBUG SMTP: connected to host "smtp.*****.****", port: 587
EHLO 493c9d0c68f2
250-us2.outbound.mailhostbox.com
250-PIPELINING
250-SIZE 41648128
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH PLAIN LOGIN
250-AUTH=PLAIN LOGIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
DEBUG SMTP: Found extension "PIPELINING", arg ""
DEBUG SMTP: Found extension "SIZE", arg "41648128"
DEBUG SMTP: Found extension "VRFY", arg ""
DEBUG SMTP: Found extension "ETRN", arg ""
DEBUG SMTP: Found extension "STARTTLS", arg ""
DEBUG SMTP: Found extension "AUTH", arg "PLAIN LOGIN"
DEBUG SMTP: Found extension "AUTH=PLAIN", arg "LOGIN"
DEBUG SMTP: Found extension "ENHANCEDSTATUSCODES", arg ""
DEBUG SMTP: Found extension "8BITMIME", arg ""
DEBUG SMTP: Found extension "DSN", arg ""
STARTTLS
220 2.0.0 Ready to start TLS
01-09-2022 21:12:33.603 WARN [email-task-2] [] c.t.s.o.c.s.a(133): Send mail exception Could not convert socket to TLS
  0  
  0  
#5
Options

Information

Helpful: 0

Views: 568

Replies: 4

Related Articles