Harmony Hub not reliably staying connected (fast roaming issues)

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Harmony Hub not reliably staying connected (fast roaming issues)
Harmony Hub not reliably staying connected (fast roaming issues)
2020-11-15 20:27:25 - last edited 2020-11-16 12:21:38
Model: AP200
Hardware Version: V3
Firmware Version: 2.21.0

I have 2 Harmony Smart Hub's in my home. The goal of them is to interface with the universal remote control, but you can also control your TV devices from your phone via Wifi. There is also an API that my home integrations can use to see what devices have been started/stopped.  Since moving to the EAP devices (2x EAP245's and 1x EAP225-Outdoor), these devices haven't reliably stayed connected.  I have all of the "advanced features" enabled, fast roaming, band steering, Dual Band 11k Report, Force Disassociation and Airtime Fairness. These devices are connected as "11ng (2.4 GHz)" when they do connect.  I've tried creating separate 2.4ghz SSID's (forced 20MHz width as I noticed another post said not to do 20/40 for legacy devices) on each of my EAP's (placeholder SSID created under global wireless config and over-written with individual SSID's on each EAP config) and tried forcing the Harmony devices to use a single EAP with this overridden SSID.  When I do this, I still get the devices disconnecting on a regular basis. 

 

I'm attempting to turn off the "advanced features" to see if that fixes the problem. I'm assuming it will because that is the first thing support tells everyone. I assume these devices don't support the advanced features, but disabling the advanced features - which are global settings, impact the whole mesh.  What is the best way to get these devices to reliably stay connect, while also making use of the advanced features - which were the whole reason I bought these.  I didn't have the same issues with my previous Airport Extreme devices, however there was no seamless roaming or band steering. 

 

I've been testing and it appears that turning off fast roaming fixes the issue. That being said, I also have other systems that experience similar issues (loss of ping every few minutes) with fast roaming on - mainly raspberry pi devices. Any tips on how to take advantage of fast roaming while keeping all my devices online? I was hoping my over-written SSID that goes to specific EAP's would do the trick, but it doesn't. 

 

Here are the devices:  https://www.amazon.com/dp/B01M73XY24 

 

it also looks like other Tp-link products have had similar issues, but these appear to be related to the "mesh" products, and as a note, I have mesh disabled. https://community.tp-link.com/en/home/forum/topic/158559?page=2 

0
0
#1
Options
8 Reply
Re:Harmony Hub not reliably staying connected (fast roaming issues)
2020-11-16 13:20:27 - last edited 2020-11-16 13:38:41

Hello again :-) try and disable Airtime Fairness on 2.4GHz and 5GHz, this feature can cause a lot of problems on many devices. let it stand for a few days and watch.

 

Mybe not nessesary but restart access point after change.

 

0
0
#2
Options
Re:Harmony Hub not reliably staying connected (fast roaming issues)
2020-11-16 16:09:34 - last edited 2020-11-16 16:14:59

Thank you for the suggestion. Airtime Fairness is off - I saw this on the forums as another suggestion so it's been off.  I will reboot them all and my router tonight just to clear out any older settings.

0
0
#3
Options
Re:Harmony Hub not reliably staying connected (fast roaming issues)
2020-11-16 16:27:51 - last edited 2020-11-16 16:29:44

Hi @BubbaW,

 

Are all three of your AP's ethernet connected?  If so, you don't need "Mesh" enabled at all.  MESH is only for wirelessly connected AP's -- for example if your outdoor unit was not hardwired.  But leaving it enabled doesn't generally cause any problems either way.

 

If it were me, I would leave Fast Roaming on -- I've not seen any real issues with this.  But note that Fast Roaming only works at all if you leave the Omada SW running 24x7 (or use the OC-200).

 

Disable the following:

band steering, Dual Band 11k Report -- these are only needed if you are using band steering -- which I would not recommend.

Force Disassociation and Airtime Fairnes -- always turn these off.

 

This will mean that you should make separate SSID's for 2.4 & 5.8.  E.g. myssid_2GHz, and myssid_5GHz.  Join your devices to only ONE of these based on their capabilities / age, etc.

 

Finally, be sure your AP's are set for all different channels (1,6,11 for 2.4, 20MHz, only; and 36 & 149 for 5.8 using 80MHz or 20/40/80).  And change all of your transmit powers to Custom and start with 16 dBm.  You may need to adjust powers up and down sligtly dependng on the radio frequency and home construction.

 

Also, while there is a lot of buzz about Fast Roaming these days.  99% of the time it's not really needed.  But I use it and haven't seen any problems with it per se.  I have ~48 devices on my setup -- which is very similar to yours -- but I don't have the Harmony equipment.

 

-Jonathan

0
0
#4
Options
Re:Harmony Hub not reliably staying connected (fast roaming issues)
2020-11-16 17:16:53

 

JSchnee21 wrote

Hi @BubbaW,

 

Are all three of your AP's ethernet connected?  If so, you don't need "Mesh" enabled at all.  MESH is only for wirelessly connected AP's -- for example if your outdoor unit was not hardwired.  But leaving it enabled doesn't generally cause any problems either way.

 

Yes, all are Ethernet connected, so I've disabled Mesh.

 

 

If it were me, I would leave Fast Roaming on -- I've not seen any real issues with this.  But note that Fast Roaming only works at all if you leave the Omada SW running 24x7 (or use the OC-200).

 

I do have Omada software running 24/7. I have it in a docker container. 

 

Disable the following:

band steering, Dual Band 11k Report -- these are only needed if you are using band steering -- which I would not recommend.

Force Disassociation and Airtime Fairnes -- always turn these off.

 

This will mean that you should make separate SSID's for 2.4 & 5.8.  E.g. myssid_2GHz, and myssid_5GHz.  Join your devices to only ONE of these based on their capabilities / age, etc.

 

Interesting. I thought the whole point of this type of setup was to have a single SSID where your mobile devices (laptops, mobile, tablet) would pick whatever made the most sense (speed/5ghz if you have good 5ghz signal, or 2.4 if you're farther away from the AP).  For those devices, would you recommend joining them to both 2.4 and 5ghz and letting the device pick migrate over to a different SSID? I actually have 2.4 and 5ghz SSID's + one SSID that has them combined. 

 

Finally, be sure your AP's are set for all different channels (1,6,11 for 2.4, 20MHz, only; and 36 & 149 for 5.8 using 80MHz or 20/40/80).  And change all of your transmit powers to Custom and start with 16 dBm.  You may need to adjust powers up and down sligtly dependng on the radio frequency and home construction.

 

I think I'm good here.  I am forcing 80 for 5ghz, but only forcing 20 on the outdoor AP. I will try adjusting this to 20 on all AP's. First EAP below is in the middle of house downstairs, 2nd is in front of home upstairs, and 3rd is in back of house upstairs. I've decreased the speed considerably on the overlapping 5g space accordingly. 

 

 

Also, while there is a lot of buzz about Fast Roaming these days.  99% of the time it's not really needed.  But I use it and haven't seen any problems with it per se.  I have ~48 devices on my setup -- which is very similar to yours -- but I don't have the Harmony equipment.

 

-Jonathan

 

Appreciate your insight & tips.  My end goals are 1) Wifi calling to work throughout the house and not drop as someone is moving around to different areas in the house and 2) get consistent speeds on our endpoint devices for remote work/schooling. 3) leverage our 300 up/down fiber plan to deliver fast browsing to devices. 

0
0
#5
Options
Re:Harmony Hub not reliably staying connected (fast roaming issues)
2020-11-16 18:56:57

Hi @BubbaW,

 

"Interesting. I thought the whole point of this type of setup was to have a single SSID where your mobile devices (laptops, mobile, tablet) would pick whatever made the most sense (speed/5ghz if you have good 5ghz signal, or 2.4 if you're farther away from the AP).  For those devices, would you recommend joining them to both 2.4 and 5ghz and letting the device pick migrate over to a different SSID? I actually have 2.4 and 5ghz SSID's + one SSID that has them combined. "

 

Theoretically, yes.  But in practice some clients just don't work very well with band steering -- either choosing 2.4 all the time because the signal is stronger when they could be faster, or constanty bouncing back and forth between bands instead of simply reducing the negotiated airline rate properly.

 

Generally speaking, if you decide to use band steering, you'll need to significantly reduce the 2.4GHz RF power in comparison to the 5.8GHz power so that each has a roughly similar coverage area.  This tends to defeat the "goal" of most home users who were hoping to "fail over" to the better range of 2.4.

 

You can have multiple SSID's.  So, for example, you could have a 2.4 only, a 5.8 only, and a 2.4 & 5.8 combined (with band steering).  You can then experiment with your different device types to see which SSID  works best for that device type in the locations it's being used in.

 

Generally speaking, I put all of my newer devices on 5.8 (phones, tablets, laptops, etc.) and only use 2.4 for older devices, IoT, and devices which have poor antennas/signal on 5.8 (like my Nest Doorbell).  I typically have ~48 STA's, and they are split roughly 50/50 between 2.4 and 5.8 (by my manual assignement / capability).

 

I'd recommend only joining each device to one SSID at a time.  If you join multiple SSID's with overlapping coverage some devices bounce band and forth from SSID1 to SSID2 all the time (kind of like they would have done with poorly supported band steering).

 

-Jonathan

0
0
#6
Options
Re:Harmony Hub not reliably staying connected (fast roaming issues)
2020-11-16 18:59:07

@BubbaW 

 

In my own experience testing with Verizon and AT&T Wifi calling, I've not had calls "drop" with Fast Roaming disabled (aka basic roaming).  But voice quality can be a little glitchy during the handover from one AP to another.  If someone is speaking during the handover you will lose a second or two of audio.

 

-Jonathan

0
0
#7
Options
Re:Harmony Hub not reliably staying connected (fast roaming issues)
2020-11-16 19:11:47

 

JSchnee21 wrote

You can have multiple SSID's.  So, for example, you could have a 2.4 only, a 5.8 only, and a 2.4 & 5.8 combined (with band steering).  You can then experiment with your different device types to see which SSID  works best for that device type in the locations it's being used in.

@JSchnee21 

 

I don't see a way to disable band steering as it's at the site level. Are you suggesting that if I got to the 2.4 only SSID, then it's essentially bypassing band steering?  

 

I'll give your suggestions a shot when nobody is using the Wifi :). Thanks again for your thoughts. 

0
0
#8
Options
Re:Harmony Hub not reliably staying connected (fast roaming issues)
2020-11-16 21:05:54

Hi @BubbaW,

 

That's correct, enabling/disabling band steering is a global setting.  But, when you define your SSID's in the WLAN configuration settings, you specify per SSID which radios each SSID can use.  So even if you have band steering enabled globally, if the SSID you're on is only enabled on a single radio type (e.g. 2.4GHz) the global setting won't have any effect.

 

When I was experimenting with Band Steering, I had the global setting enabled, as well as that other setting you mentioned (re: roaming report).  And them I made three SSID's, one for 2.4, one for 5, and one with both so I could test each by joining my device to one at a time.

 

-Jonathan

1
1
#9
Options