Can't get IP address from a VLan enabled EAP225-Outdoor Access Point

Can't get IP address from a VLan enabled EAP225-Outdoor Access Point
Can't get IP address from a VLan enabled EAP225-Outdoor Access Point
2021-01-02 08:11:04 - last edited 2021-01-06 10:09:12
Hardware Version: V1
Firmware Version: 1.7.0 Build 20200113 Rel. 35383(5553)

I have the following hardware setup (Router > Switch > Access Point) on my network

Netgear: WNDR3700v3  >>  TP-Link: TL-SG1016DE  >>  TP-Link: EAP-225Outdoor

I have created 3 Vlans on the Switch and configured the ports as shown below:

Port 1, 3, 9 on switch to be connected to Smart TVs, Blu-Ray players & DSTV Decoder

Port 8 on the switch connects to my management computer

Port 13 on the switch is reserved for a future Access Point

Port 14 on the Switch connects to the Access Point {EAP-225Outdoor}

Port 15 on the Switch connects to an unmanaged TP-Link PoE switch {TL-SG1005P V2}. 2 POE Cameras are currently connected to 2 ports on the PoE Switch

Port 16 on Switch connects to the Router

On the Access Point I created 3 SSID’s, enabled VLan and linked the respective VLans as shown below:

The Problem:

Wifi devices are failing to connect to the access point on any of the 3 SSIDs and are returning the error message “Couldn’t get IP Address”.

Is there a step I have missed here?

0
0
#1
Options
4 Reply
Re:Can't get IP address from a VLan enabled EAP225-Outdoor Access Point
2021-01-06 10:11:55 - last edited 2021-01-06 10:13:03

Dear @RonNaija,

 

The Problem:

Wifi devices are failing to connect to the access point on any of the 3 SSIDs and are returning the error message “Couldn’t get IP Address”.

Is there a step I have missed here?

 

The router should be VLAN-aware and the router port needs to be tagged with the corresponding VLAN (Port16 on the switch should be tagged as well). Otherwise, the wireless clients are unable to talk to the router for a network connection.

Best Regards!
0
0
#2
Options
Re:Can't get IP address from a VLan enabled EAP225-Outdoor Access Point
2021-01-06 21:13:29 - last edited 2021-01-06 21:15:13

You should have only 1 untagged VLAN per port. Otherwise the switch doesn't know which VLAN an incoming untagged frame belongs to. Also, the EAP tags the packets. So, at port 14 all VLANs including VLAN 1 should be tagged. Kind regards Martin

 

 

0
0
#3
Options
Re:Can't get IP address from a VLan enabled EAP225-Outdoor Access Point
2021-02-05 14:03:04 - last edited 2021-02-05 14:14:11

 I am back to give you all update on this. It took some time to acquire all the network gears needed to upgrade my Home Network to a 1Gbps throughput.

 

The problem I had back in January was that Wifi devices were failing to connect to the access point on any of the 3 SSIDs linked to the 3 Vlans I had created, and they were all returning the error message “Couldn’t get IP Address”. I suspected after some research that this was due to my Router not being Vlan aware.

 

Since then I have acquired 2 more EAP245 access points in addition to the EAP225-Outdoor access points I had. An Omada Hardware Controller OC200 as well as a Router TL-R605.

 

I now have an IoT Vlan created through the Omada controller in addition to the default Vlan 1. Also created are 2 SSID for wireless access, one for the default vlan and the other for the IoT Vlan. Devices connected to these different Vlans (wired & wireless) are now assigned correct IP addresses from the right Subnet i.e 192.168.0.x for the default Vlan and 192.168.20.x for the IoT Vlans.

 

Observation: I noticed that without the Omada Controller you cannot create Vlans with different IP Subnets as the router’s Web GUI has no menu for assigning different IP Subnets to the different Vlans! Quite strange or is it intentional to get users to buy the controller?

 

I have not been able to achieve Vlan isolation. I can ping devices in a different IP Subnet from devices in another Subnet. Does this imply that broadcast from one Vlan is being transmitted to devices on the other Vlan which defeats the purpose of setting up a Vlan to isolate network traffic and improve throughput? From research it seems I need to configure the Switch ACL to grant and deny permissions between the different Vlans. Unfortunately, my Easy Smart Switch  (TL-SG1016DE) isn’t Omada compatible and it’s built in Web GUI doesn’t seem to have a menu option for Switch ACL configuration? Has anyone been able to solve this problem?

0
0
#4
Options
Re:Can't get IP address from a VLan enabled EAP225-Outdoor Access Point
2021-02-10 13:36:05

@RonNaija I solved the  VLAN Isolation problem partially by configuring EAP ACL in OMADA, as my switch doesn't have ACL functions. Any wireless device connected to my IOT Vlan no longer has access (can't ping) to devices on other vlans. However this isolation is ineffective for wired connections through ethernet cable to any of the designated IOT port on the switch. Unless I change my switch to one with ACL features I would have to live with this partial solution/

0
0
#5
Options