TL-R605 - Omada Integration LAN/AP Connection Status Bug

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
12
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
TL-R605 - Omada Integration LAN/AP Connection Status Bug
TL-R605 - Omada Integration LAN/AP Connection Status Bug
2021-01-12 17:35:01 - last edited 2021-04-16 10:32:26
Hardware Version: V1
Firmware Version: 1.0.0 Build 20200930 Rel.36519

I received the new TL-R605 router and adopted into my OC200 network.  After setting everything up, I am noticing a huge bug/potential issue.

 

I have about ~80 wireless devices, and about ~10 wired devices. I have 1 TL-R605, 3 EAP245, and 1 EAP225 Outdoor, and 1 OC200 controller. It would appear that all of the devices that would normally show as connected to a specifc AP often switch over as showing connected to LAN (the router) and then switch back, hundreds of times a day, usually every min or so.  The Event logs have over 10000 entries just for today, showcasing this movement from AP to LAN.  It appears like this,

 

Game Table Speaker is connected to EAP245_Main with SSID "Novigrad" on channel 157.
Jan 12, 2021 11:50:37  am
Game Table Speaker was disconnected from network "LAN" on TL-R605 Router(connected time:26s connected, traffic: 2.85KB).
Jan 12, 2021 11:50:37  am
Game Table Speaker is connected to TL-R605 Router on LAN network.
Jan 12, 2021 11:50:36  am
Game Table Speaker is disconnected from SSID "Novigrad" on EAP245_Main (7h54m connected, 139.77MB).
Jan 12, 2021 11:50:36  am
Game Table Speaker is connected to EAP245_Main with SSID "Novigrad" on channel 157.
Jan 12, 2021 11:47:35  am
Game Table Speaker was disconnected from network "LAN" on TL-R605 Router(connected time:29s connected, traffic: 2.80KB).
Jan 12, 2021 11:47:35  am

 

This seemingly goes on forever, every few mins for all devices that are wirelessly connected.

 

The above example is for a stationary device, and based on what AP it is connecting to, it isnt roaming.  All wireless devices will eventually do this, so more often than not, it shows in the omada console that i have over 90 devices Wired, then it will eventually show less, than the proper amount.  

 

This is altering the uptime of clients, clogging up the event logs, as well as me no longer being able to see what specific AP a device is connected to, as when I check it could just show LAN at that time.

 

Any Ideas?

1
1
#1
Options
1 Accepted Solution
Re:TL-R605 - Omada Integration LAN/AP Connection Status Bug-Solution
2021-03-08 18:29:36 - last edited 2021-04-16 10:32:26

@rodegg 

My issue, as I originally reported it for this thread, has been resolved with the latest OC200 firmware v4.2.11, specifically...

 

6. Fixed the bug that the wireless client will be displayed as a wired client (LAN) on the controller. Discussed HERE.

 

【Update 3/4/2021】Latest firmware released for Omada SDN Controller v4.2.11

 

 

 

Recommended Solution
0
0
#13
Options
11 Reply
Re:TL-R605 - Omada Integration LAN/AP Connection Swapping Bug
2021-01-12 17:39:49 - last edited 2021-04-16 10:32:26

Another exmaple.

 

FireTV_GT is connected to TL-R605 Router on LAN network.

Jan 12, 2021 12:38:32  pm

FireTV_GT is disconnected from SSID "Novigrad" on EAP245_Main (13h33m connected, 71.68MB).

Jan 12, 2021 12:38:32  pm

FireTV_GT is connected to EAP245_Main with SSID "Novigrad" on channel 157.

Jan 12, 2021 12:38:27  pm

FireTV_GT was disconnected from network "LAN" on TL-R605 Router(connected time:28s connected, traffic: 576Bytes).

Jan 12, 2021 12:38:27  pm

FireTV_GT is connected to TL-R605 Router on LAN network.

Jan 12, 2021 12:38:02  pm

FireTV_GT is disconnected from SSID "Novigrad" on EAP245_Main (13h32m connected, 71.66MB).

Jan 12, 2021 12:38:02  pm

FireTV_GT is connected to EAP245_Main with SSID "Novigrad" on channel 157.

Jan 12, 2021 12:37:57  pm

FireTV_GT was disconnected from network "LAN" on TL-R605 Router(connected time:57s connected, traffic: 222Bytes).

Jan 12, 2021 12:37:57  pm

FireTV_GT is connected to TL-R605 Router on LAN network.

Jan 12, 2021 12:37:31  pm

FireTV_GT is disconnected from SSID "Novigrad" on EAP245_Main (13h32m connected, 71.64MB).

Jan 12, 2021 12:37:31  pm

FireTV_GT is connected to EAP245_Main with SSID "Novigrad" on channel 157.

Jan 12, 2021 12:37:27  pm

FireTV_GT was disconnected from network "LAN" on TL-R605 Router(connected time:26s connected, traffic: 768Bytes).

Jan 12, 2021 12:37:27  pm

FireTV_GT is connected to TL-R605 Router on LAN network.

Jan 12, 2021 12:37:01  pm

0
0
#2
Options
Re:TL-R605 - Omada Integration LAN/AP Connection Swapping Bug
2021-01-12 21:15:14 - last edited 2021-04-16 10:32:26

I reached out to TP Link support and they are escalating it to engineering.

 

I followed TPLink SMB support techs troubleshooting paths in chat, including disabling advanced features, testing on a seperate SSID without authentication, restarting, etc.  Nothing worked.

 

Just from 4pm EST, to 4:06pm EST, there are 3186 log entries of this happening. 

 

 

 

 

 

Device page counts for LAN wired connected devices when its showing properly.  Keep in mind, 9 is about th enumber of wired devices I have connected and is correct.

 

 

Checking at any given time it could look like this (disregard the device uptimes, rebooted devices during tplink support testing)

 

 

or this..making it near impossible to pinpoint at any given time what W/L device is connected to what AP.  You have to either wait until it updates, or look through the logs.

 

 

 

0
0
#3
Options
Re:TL-R605 - Omada Integration LAN/AP Connection Swapping Bug
2021-01-13 21:19:47 - last edited 2021-04-16 10:32:26

Looks like this is being worked over in a seperate thread and is a known issue in vs 4.2.8 of the controller, with v4.2.9 having fixed the issue but is not yet released.

 

https://community.tp-link.com/en/business/forum/topic/246448?replyId=547952

 

 

0
0
#6
Options
Re:TL-R605 - Omada Integration LAN/AP Connection Status Bug
2021-02-17 03:32:28 - last edited 2021-04-16 10:32:26

This issue has nothing to do with the "Wireless Clients showing as wired". That bug is already fixed in the released 4.2.11.

 

Many others including myself are experiencing the frequent false disconnect reports and I am on 4.2.11.Clients keep disappearing and reappearing from the Clients tab. I have reported it in reply to two other forum posts as well.

For me it happens only for wired clients which is an indication that it's likely a bug in the TL-R605 router firmware itself. TP-Link seems to be completely silent about this. 

1
1
#7
Options
Re:TL-R605 - Omada Integration LAN/AP Connection Status Bug
2021-03-03 19:20:45 - last edited 2021-04-16 10:32:26
It appears there are two seperate issues at play here. The one i reported, and the one where the TL-R605 stops displaying clients and requires a manual restart to resolve. The issue I reported is targeted for resolution with the just now released OC200 firmware v1.7.4 Build 20210118 Rel. 72627. I havent tested it yet, but it should resolve. However, I agree with you that the Tl-R605 issue with wired clients no longer showing at all, is an issue and I remember seeing a post or two about it elsewhere (whether this forum or reddit), where a a person mentioned its a known issue and manual restart of the router is the current "fix". I did have the issue as well with the router, and restarting it manually did fix it...but only temporarily for a week or so, now they are gone again. Havent restarted it again. Holding out for a new firmware update to fix.
0
0
#8
Options
Re:TL-R605 - Omada Integration LAN/AP Connection Status Bug
2021-03-03 22:22:43 - last edited 2021-04-16 10:32:26

I just read @yourownhero message and for some reason I thought there is a new firmware for TL-R605, which lead me to the many places to find it which I failed, but to my surprise, on the Devices page of the controller, there was a notification of a new release! So, we officially have version 1.0.1 Build 20210113 Rel.35074 and I could upgrade right from the controller.

 

The release note showes that it in fact fixes all the problems I personally had with the router, devices disconnecting, death ping notifications, alerting incompatiple devices, and online detection mechanism. I installed it and right off the bat, I don't see two of the managed switches listed in the Clients tab. Not sure if they show up, but at least I do not see any stupid dropped/connected notifications like I saw before, and what is shown in the list, has remained in the list for the past few minutes it was running.

I will update with my final verdict in few days.


Here's the release notes since since seems it's not available anywhere else:

New Feature/Enhancement:
1. Support to configure the L2TP VPN Server and IPsec site on the same WAN port.
2. Change the detection mechanism of the "Block Ping of Death" function in the firewall, remove the packet limit of fewer than 64 Bytes.
3. Optimize the Online Detection and DNS proxy mechanisms to improve the network stability for scenarios where the front-end device has a Disconnection Alert function.
4. Optimize for scenarios where the Omada SDN Controller is accessed via the cloud when Portal is enabled.
5. Improve the compatibility of IKEv2 VPN, and the stability of L2TP over IPsec VPN.
6. Improve the network stability when the static IP address is changed in multi-WAN mode.

Bug Fixed:
1. Fix the bug that the DHCP Server may down under special circumstances.
2. Fix the bug that the WAN connection may down when multi-network and VPN are configured.
3. Fix the bug that the router doesn't forward data for up to 2 minutes when the L2TP VPN Client is connected.
4. Fix the bug that the Omada SDN Controller alerts incompatible devices.
5. Fix the bug that CPU and memory usage data are not correctly displayed in the Statistics functions of the Omada SDN Controller.
6. Fix the bug that the router occasionally generates the wrong routing table for the DNS server.
Notes:
1. For ER605(TL-R605) v1 only.
2. Your device's configuration won't be lost after upgrading.
3. This firmware is applied to the Omada APP of version 3.0.x or above.

0
0
#10
Options
Re:TL-R605 - Omada Integration LAN/AP Connection Status Bug
2021-03-05 20:21:23 - last edited 2021-04-16 10:32:26

OK, It's clear that the wired connection status bug still exists in the latest firmware I posted before. 

As a side note, the firmware can now be downloaded in support page. They made it available yesterday.

1
1
#11
Options
Re:TL-R605 - Omada Integration LAN/AP Connection Status Bug
2021-03-08 17:53:35 - last edited 2021-04-16 10:32:26

@Fae Any word on a fix for this issue?

 

 

0
0
#12
Options
Re:TL-R605 - Omada Integration LAN/AP Connection Status Bug-Solution
2021-03-08 18:29:36 - last edited 2021-04-16 10:32:26

@rodegg 

My issue, as I originally reported it for this thread, has been resolved with the latest OC200 firmware v4.2.11, specifically...

 

6. Fixed the bug that the wireless client will be displayed as a wired client (LAN) on the controller. Discussed HERE.

 

【Update 3/4/2021】Latest firmware released for Omada SDN Controller v4.2.11

 

 

 

Recommended Solution
0
0
#13
Options
Re:TL-R605 - Omada Integration LAN/AP Connection Status Bug
2021-03-09 17:54:31 - last edited 2021-04-16 10:32:26

@yourownhero Yes, that is resolved for me too. Now the log shows  random (false) disconnects/connects from wired clients several times a day

1
1
#14
Options