TL R480+ VS TL-R605

TL R480+ VS TL-R605
TL R480+ VS TL-R605
2021-02-22 12:08:21
Hardware Version: V1
Firmware Version:

Hi all, 

As many other and due to the pandemic I created a home office and work from home. 

I faced internet instability with outages that lasted hours, so I was forced to combine more than one internet connections through the use of the TL R480+. 

However I am not satisfied with the performance of the router. The main reason being that when ever a connection fails and then comes back up again the connection in the router remains disconnected. 

I tried (what seemed as) everything but with no success, in order for the connection to come back on I need to do it manually, which brings me to my other issue. When ever I reactivate a connection my overall routing is messed up for a few seconds (5 to 10) which makes skype call hang. 

The same applies when I have a skype call and one of the two connection fails, I would expect that the other would take over immediately however the call hangs. Maybe it is due to the high utilization I don't know. 

 

Which brings me to the main reason for creating the thread, due to the attractive price of the TL-605 I am thinking of buying it with the home that the issues I face with r480+ will be resolved.

It seems that it can due pretty much everything the r480+ can due and then some, furhtermore it has gigabit connections and therefore I can utilize more than one connection in combination. (with the r480+ there is no point doing it since one of my connections is 100mb and the other 24mb but due to the 100mb cap from the router there is no point in combine it). 

 

Any help either with the r480+ or experience with r605 would be greatly .... greatly appreciated. 

0
0
#1
Options
8 Replies
Re:TL R480+ VS TL-R605
2021-02-24 18:29:06

Hi again, any feedback will be much appreciated 

0
0
#2
Options
Re:TL R480+ VS TL-R605
2021-02-25 09:37:40

Dear @cTsitouridis,

 

The main reason being that when ever a connection fails and then comes back up again the connection in the router remains disconnected. 

I tried (what seemed as) everything but with no success, in order for the connection to come back on I need to do it manually, which brings me to my other issue. When ever I reactivate a connection my overall routing is messed up for a few seconds (5 to 10) which makes skype call hang. 

The same applies when I have a skype call and one of the two connection fails, I would expect that the other would take over immediately however the call hangs. Maybe it is due to the high utilization I don't know. 

 

May I confirm your network requirement in detail? Do you have multiple WAN connections connected with the TL-R480T+ router?

When one WAN connection fails, do you mean that you need to click Connect from the web interface to get the Internet back?

What settings have you configured on the TL-R480T+? Did you configure Load Balancing feature such as Link Backup, Policy Routing?

What's the hardware and firmware version of your TL-R480T+ router?

Best Regards!
0
0
#3
Options
Re:TL R480+ VS TL-R605
2021-02-25 11:27:45 - last edited 2021-02-25 11:29:00

@Fae 

Thank you for your reply.

To answer your questions please note the following:

  • First of I have the TL-R480T+ v9.0
  • Connected to the tl-r480 router are two wan connections from different internet providers. 
  • Wan2 is the primary link, Wan1 is the back up link
  • When either of the wan connections fails I have to manually reconnect it. 
  • Once I connect again either of the Wan connections that is down (and while the other is up which means I have internet access) there is a disruption momentarily in the internet connection of the connected wan (this happens despite of the fact that the back up wan fails which is the most frequent). e.g. just now the wan1 is not connected because during the night the modem restarted and now that I pressed connect the internet (although connected through the primary line) has been disrupted 
  • Load Balancing is enabled
  • Link backup setup is as follows:
    • Primary Wan: Wan2
    • Backup Wan: Wan1
    • Mode: Failover(Enable backup link when any primary WAN fails)
    • Status: Enable (selected)
  • Policy Routing: I have not parametrized (I am novice at this so since it worked I didn't do anything) 
  • Firmware version: 9.0.3 Build 20200313 Rel.38262 

My understanding when I bought the router was that that in case of a wan failure the transition would be seamless. In my case if I have a webex or a skype call the connection is dropped and I have to call again. This happens even when I reconnect one wan while the other is already connected. (as mentioned in the 5th bullet above). 

Lastly the average utilization of the router is Memory (average) 16%-20% while CPU 54%-85%, thus I was asking that maybe the TL-R605 would have better performance, provided that is can do similar things as the r480+.

 

 

0
0
#4
Options
Re:TL R480+ VS TL-R605
2021-03-08 16:01:22

@cTsitouridis 

 

Any feedback would be appreciated since the behavior of r480+ continues to be the same irrespective of the changes I do in parameterization

0
0
#5
Options
Re:TL R480+ VS TL-R605
3 weeks ago

@cTsitouridis 

 

I've just moved from a 470to a 605.  The gains are worth the upgrade.  I tihnk the 480 is slightly faster, but pretty similar.

 

First, the throughput is better.  The old device was limited by the 100mb/s fast ethernet ports, and worse than that, the max throughput of the device was actually around 90mb/s.  The 605 has gigabit ports, and significantly faster throughput.  Even without hardware acceleration/cpu offload, the box seems capable of 300ish mbits/second.

 

It's got a 4 core cpu, and my box runs at 2 - 4% cpu most of the time, compared to 40-75% on the 470.

 

On my 470, it took an AGE to be ready to work again after the WAN state had changed.  The 'upcheck' seemed to hog all the CPU, and stopped the box from routing packets, even if other WANS were up.  This is less of a problem on the 605, as the CPU is MUCH faster.  The faster CPU means that it detects and recovers from WAN state changes much more quickly.

 

The 605 has incorrect looking stats, and support told me this was due to cpu offloading/hardware acceleration.  On the 605, the CPU doesn't shift the packets between interfaces.  This makes it faster, but does mean the OS can't track them.  Support gave me some settings which affectively disable hardware acceleration, and the stats work great.

 

For a 40quid odd device, just buy one.

1
1
#6
Options
Re:TL R480+ VS TL-R605
3 weeks ago

Dear @cTsitouridis,

 

My understanding when I bought the router was that that in case of a wan failure the transition would be seamless.

 

The Link Backup function may not suit your situation as it cannot be seamless.

 

For your case, it's suggested to disable the Link Backup function and what you need is to simply enable the Load Balancing feature.

Best Regards!
1
1
#7
Options
Re:TL R480+ VS TL-R605
2 weeks ago

@Fae 

 

Thank you for the response. I have already checked the Load Balancing but also the link back up. 

The issue I have is that once the secondary line drops and comes back the R480+ does not connect. 

I have change the parameter in :

Transmission-> Load Balancing -> Online Detection to always online but I don't think it will do much good.

The last think I will do is change the router of the back up line incase there is something going on with that. I have a spear Tp Link so I will use that one. 

 

0
0
#8
Options
Re:TL R480+ VS TL-R605
2 weeks ago

@Portal 

 

Did support give you a way of disabling the hardware offloading when in standalone mode? Would really appreciate the option to do so!

 

 

0
0
#9
Options