Failure to adopt TL-R605 after firmware upgrade

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Failure to adopt TL-R605 after firmware upgrade

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Failure to adopt TL-R605 after firmware upgrade
Failure to adopt TL-R605 after firmware upgrade
2021-05-31 14:32:19 - last edited 2021-06-02 08:30:57
Model: ER605 (TL-R605)  
Hardware Version: V1
Firmware Version: 1.0.0, 1.0.1

Hi,

 

this is the second time this happens. I have a setup consisting of a few switches, a few EAPs and a TL-R605 router. When I upgrade the firmware on my core switch or the router itself, Omada controller (software based) complains about the router failing to adopt; specifically, it shows the router as "Adopt Failed" and it cannot be managed. If I press the "retry" button, it's asking about the username/password of the device, as if it was managed by some other instance of Omada SDN.

 

Has anyone faced this issue before? Is there some fix?

 

Thank you

  0      
  0      
#1
Options
1 Accepted Solution
Re:Failure to adopt TL-R605 after firmware upgrade-Solution
2021-06-02 05:03:16 - last edited 2021-06-02 08:30:57

Hi all,

 

indeed, after rebooting the router, it got adopted again. Actually, what happened was the following:

 

  1. I upgraded one of my switches (not "between" my controller and router): no problems
  2. I upgraded my "core" switch (which is "between" my controller and router): this is what caused the router to show up as "adopt failed"; I assumed that I had pressed by mistake the upgrade button on the router, hence triggering this situation, but that was not the case actually, it was upgrading the core switch that caused it
  3. When I actually upgraded the router itself, it got readopted automatically without any problems
Recommended Solution
  0  
  0  
#6
Options
5 Reply
Re:Failure to adopt TL-R605 after firmware upgrade
2021-05-31 15:09:38

@lexam Hello,

I had the same problem: https://community.tp-link.com/en/business/forum/topic/265924

  0  
  0  
#2
Options
Re:Failure to adopt TL-R605 after firmware upgrade
2021-05-31 22:57:09

@lexam Same problem after upgrade. Frankly - each time router/switch is upgraded there is a problem with adopting it. Usually I make several factory resets on all devices (router, switch, EAPs), for TL-R605 v1.0.1 I had to reset ALL DEVICES and connect OC200 directly to router - this helped, but is seems like random problem with upgrade process.

  0  
  0  
#3
Options
Re:Failure to adopt TL-R605 after firmware upgrade
2021-06-01 00:20:56

@PavelV 

Same with me tonight as well.

Hoping things like this smooth out. 

  0  
  0  
#4
Options
Re:Failure to adopt TL-R605 after firmware upgrade
2021-06-02 03:14:56

@lexam 

How about reboot the device and then try to adopt the device? After upgrade the firmware version, the controller software needs some time to send the adopt command and file to the router. Maybe that is the point.

  0  
  0  
#5
Options
Re:Failure to adopt TL-R605 after firmware upgrade-Solution
2021-06-02 05:03:16 - last edited 2021-06-02 08:30:57

Hi all,

 

indeed, after rebooting the router, it got adopted again. Actually, what happened was the following:

 

  1. I upgraded one of my switches (not "between" my controller and router): no problems
  2. I upgraded my "core" switch (which is "between" my controller and router): this is what caused the router to show up as "adopt failed"; I assumed that I had pressed by mistake the upgrade button on the router, hence triggering this situation, but that was not the case actually, it was upgrading the core switch that caused it
  3. When I actually upgraded the router itself, it got readopted automatically without any problems
Recommended Solution
  0  
  0  
#6
Options

Information

Helpful: 0

Views: 1277

Replies: 5

Related Articles