Hotspot Voucher Authentication Codes won't work after migrate from EAP Controller 3.2.10 to 4.4.6

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Hotspot Voucher Authentication Codes won't work after migrate from EAP Controller 3.2.10 to 4.4.6
Hotspot Voucher Authentication Codes won't work after migrate from EAP Controller 3.2.10 to 4.4.6
2022-02-16 16:30:59 - last edited 2022-02-22 06:09:58
Model: EAP225  
Hardware Version: V3
Firmware Version: 5.0.5

Hi at all,

 

we are currently using the old EAP Controller 3.2.10 with enabled Hotspot Authentication. We provide a guest-network with Hotspot-Portal using voucher-codes.

Now we are trying to migrate to the newest EAP Controller (currently we prepared 4.4.6 on our server).

 

We followed the migration guide on https://www.tp-link.com/de/omada-sdn/controller-upgrade/#content-1

which says that the the Hotspot Portal needs to be setup up again after migration. Under "Settings > Authentication" we created a new Portal with the same Portal-Name and settings as on the old controller.

 

After migration opening the hotspot managers shows that all existing voucher-codes have been copied. Looks good.

 

But connecting a device with the the network using the migrated voucher-codes don't work. The portal says that the code is invalid.

Trying to find out why, we created a new voucher-code which works out of the box. So there must some difference with migrated voucher-codes and new ones.

 

The only difference I can see is that the new one now has an entry in the column "portal".

 

I think there must be something missing during the migration. Does anybody have an idea how to fix that?

I find it interesting, that the "created time" is not really migrated, too. The old controller already got that column.

 

0
0
#1
Options
2 Accepted Solutions
Re:Hotspot Voucher Authentication Codes won't work after migrate from EAP Controller 3.2.10 to 4.4.6-Solution
2022-02-18 07:39:39 - last edited 2022-02-22 06:09:58

Dear @indigo,

 

indigo wrote

we are currently using the old EAP Controller 3.2.10 with enabled Hotspot Authentication. We provide a guest-network with Hotspot-Portal using voucher-codes.

Now we are trying to migrate to the newest EAP Controller (currently we prepared 4.4.6 on our server).

 

We followed the migration guide on https://www.tp-link.com/de/omada-sdn/controller-upgrade/#content-1

which says that the the Hotspot Portal needs to be setup up again after migration. Under "Settings > Authentication" we created a new Portal with the same Portal-Name and settings as on the old controller.

 

After migration opening the hotspot managers shows that all existing voucher-codes have been copied. Looks good.

 

But connecting a device with the the network using the migrated voucher-codes don't work. The portal says that the code is invalid.

Trying to find out why, we created a new voucher-code which works out of the box. So there must some difference with migrated voucher-codes and new ones.

 

The only difference I can see is that the new one now has an entry in the column "portal".

 

I think there must be something missing during the migration. Does anybody have an idea how to fix that?

 

Thank you for posting the problem on the TP-Link Community!

 

Regarding the issue that the migrated voucher codes are invalid, I'm afraid that it's designed like this.

 

After we migrate from Controller v3.2.10 to Controller v4.4.6, the previous Portal will be removed since it's incompatible, while the old voucher codes are not deleted but kept there without binding to a Portal (it's because TP-Link team try to keep the user's configuration as much as possible and leave this option for the user).

 

However, starting with Controller v4.3.5 and later version, it's required to bind the voucher code to a Portal before it can be used. So the old voucher codes are invalid, and you would need to create new voucher codes binding to a Portal to use them.

 

P.S. With the Controller v4.3.5 and later version, creating vouchers without selecting a portal is not allowed, otherwise, we'll see the error occurs like the image below.

 

Get Started Here: https://community.tp-link.com/en/business/forum/topic/551684 https://community.tp-link.com/en/business/forum/topic/552406
Recommended Solution
0
0
#4
Options
Re:Hotspot Voucher Authentication Codes won't work after migrate from EAP Controller 3.2.10 to 4.4.6-Solution
2022-02-21 08:19:19 - last edited 2022-02-22 06:10:03

Dear @indigo,

 

indigo wrote

thanks for your answer. Yes I tried to import the config from 3.x to 5.x and as stated it didn't work. But I did it just to try out if I could migrate the voucher-codes properly.

The best way to migrate an keep the voucher-codes is going from 3.2.10 to 4.2.x and then to 5.x. That way seems to work.

 

Thank you for your valued feedback.

 

To benefit others from this post, here are the two main steps to migrate and keep the voucher codes when upgrade from Controller v3 to Controller v5.

 

  1. Backup the config file of Controller v3.x, then upgrade to Controller v4.2.11.
  2. Create a Portal on the Controller v4.2.11, then upgrade to Controller v5.x.

 

The "only" thing that is still not working is https://community.tp-link.com/en/business/forum/topic/533962

 

This issue has been reported to the developer team for investigation, and it would be fixed in the Controller v5.2 (probably release in April, only for your reference).

Get Started Here: https://community.tp-link.com/en/business/forum/topic/551684 https://community.tp-link.com/en/business/forum/topic/552406
Recommended Solution
0
0
#7
Options
6 Reply
Re:Hotspot Voucher Authentication Codes won't work after migrate from EAP Controller 3.2.10 to 4.4.6
2022-02-16 20:50:15

Hey again,

 

I tried with different versions of Omada Controller to find out if its a bug.

 

First I installed the newest 5.0.3.0 on the target server. With that version I even cannot import the old backup. So 3.2.10 to 5.0.3.0 directly seems not possible:

 

 

OK, next try with the oldest version I could find on the TP-Link Download page: 4.1.5:

Importing the backup works but the voucher-codes seem to be wrong. My codes (type) are set up as unlimited logins with 1 user at a time. But the codes got migrated as 1 single use.

 

 

What about the next one: 4.2.8:

Hey, that looks better. The type seems to be correct now. So going from 3.2.10 to 4.2.8 looks good.

 

Now did an upgrade from 4.2.8 to 4.4.6:

Wow, the portal column gets magically filled with some valid stuff :-)

 

Ok, thats an interesting upgrade journey! Tomorrow I will try to log in with some of the codes.

 

0
0
#2
Options
Re:Hotspot Voucher Authentication Codes won't work after migrate from EAP Controller 3.2.10 to 4.4.6
2022-02-18 01:27:58

  @indigo 

Migrate does not always work as expected. Since V3, SDN was introduced and Router can be managed by Controller.

Since then, some config from V3 does not apply to the V4. 

V3 to V5 leaps many versions. Last year was V4, many updates and mods have been made. Could be some trouble with that. I think it is normal. 

Suggest you re-configure that from the scratch. I did not use Voucher code, but I remember that is not hard to config. When I tweaked my controller, I went there and tried that. 

0
0
#3
Options
Re:Hotspot Voucher Authentication Codes won't work after migrate from EAP Controller 3.2.10 to 4.4.6-Solution
2022-02-18 07:39:39 - last edited 2022-02-22 06:09:58

Dear @indigo,

 

indigo wrote

we are currently using the old EAP Controller 3.2.10 with enabled Hotspot Authentication. We provide a guest-network with Hotspot-Portal using voucher-codes.

Now we are trying to migrate to the newest EAP Controller (currently we prepared 4.4.6 on our server).

 

We followed the migration guide on https://www.tp-link.com/de/omada-sdn/controller-upgrade/#content-1

which says that the the Hotspot Portal needs to be setup up again after migration. Under "Settings > Authentication" we created a new Portal with the same Portal-Name and settings as on the old controller.

 

After migration opening the hotspot managers shows that all existing voucher-codes have been copied. Looks good.

 

But connecting a device with the the network using the migrated voucher-codes don't work. The portal says that the code is invalid.

Trying to find out why, we created a new voucher-code which works out of the box. So there must some difference with migrated voucher-codes and new ones.

 

The only difference I can see is that the new one now has an entry in the column "portal".

 

I think there must be something missing during the migration. Does anybody have an idea how to fix that?

 

Thank you for posting the problem on the TP-Link Community!

 

Regarding the issue that the migrated voucher codes are invalid, I'm afraid that it's designed like this.

 

After we migrate from Controller v3.2.10 to Controller v4.4.6, the previous Portal will be removed since it's incompatible, while the old voucher codes are not deleted but kept there without binding to a Portal (it's because TP-Link team try to keep the user's configuration as much as possible and leave this option for the user).

 

However, starting with Controller v4.3.5 and later version, it's required to bind the voucher code to a Portal before it can be used. So the old voucher codes are invalid, and you would need to create new voucher codes binding to a Portal to use them.

 

P.S. With the Controller v4.3.5 and later version, creating vouchers without selecting a portal is not allowed, otherwise, we'll see the error occurs like the image below.

 

Get Started Here: https://community.tp-link.com/en/business/forum/topic/551684 https://community.tp-link.com/en/business/forum/topic/552406
Recommended Solution
0
0
#4
Options
Re:Hotspot Voucher Authentication Codes won't work after migrate from EAP Controller 3.2.10 to 4.4.6
2022-02-18 07:45:53 - last edited 2022-02-18 08:22:57

Dear @indigo,

 

indigo wrote

First I installed the newest 5.0.3.0 on the target server. With that version I even cannot import the old backup.

 

As for this issue, did you import the backup file exported from the Controller v3.2.10 to the V5.0.30?

 

To figure out the issue, I'd like to escalate to the TP-Link support team for investigation.

They will reach you via your registered email address shortly, please pay attention to your email box later.

 

Sorry that I was not aware of the note that "Only the configuration file of controller v4.1.5 or above is supported".

So it's normal if you failed to restore the backup file of controller v3.x to the controller v5.x. 

Please ignore the support email. Thank you for your valued feedback!

Get Started Here: https://community.tp-link.com/en/business/forum/topic/551684 https://community.tp-link.com/en/business/forum/topic/552406
0
0
#5
Options
Re:Hotspot Voucher Authentication Codes won't work after migrate from EAP Controller 3.2.10 to 4.4.6
2022-02-18 13:42:51

Dear  @Fae,

 

thanks for your answer. Yes I tried to import the config from 3.x to 5.x and as stated it didn't work. But I did it just to try out if I could migrate the voucher-codes properly.

 

The best way to migrate an keep the voucher-codes is going from 3.2.10 to 4.2.x and then to 5.x. That way seems to work.

 

For us it is important to keep the voucher codes since our vouchers are normally valid 15 to 30 days and we have currently users actively using the codes. There is no adequate way for us to change all currently running codes.

 

The "only" thing that is still not working is https://community.tp-link.com/en/business/forum/topic/533962

 

Thanks!

0
0
#6
Options
Re:Hotspot Voucher Authentication Codes won't work after migrate from EAP Controller 3.2.10 to 4.4.6-Solution
2022-02-21 08:19:19 - last edited 2022-02-22 06:10:03

Dear @indigo,

 

indigo wrote

thanks for your answer. Yes I tried to import the config from 3.x to 5.x and as stated it didn't work. But I did it just to try out if I could migrate the voucher-codes properly.

The best way to migrate an keep the voucher-codes is going from 3.2.10 to 4.2.x and then to 5.x. That way seems to work.

 

Thank you for your valued feedback.

 

To benefit others from this post, here are the two main steps to migrate and keep the voucher codes when upgrade from Controller v3 to Controller v5.

 

  1. Backup the config file of Controller v3.x, then upgrade to Controller v4.2.11.
  2. Create a Portal on the Controller v4.2.11, then upgrade to Controller v5.x.

 

The "only" thing that is still not working is https://community.tp-link.com/en/business/forum/topic/533962

 

This issue has been reported to the developer team for investigation, and it would be fixed in the Controller v5.2 (probably release in April, only for your reference).

Get Started Here: https://community.tp-link.com/en/business/forum/topic/551684 https://community.tp-link.com/en/business/forum/topic/552406
Recommended Solution
0
0
#7
Options