MDNS not working on ER605 v2?

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

MDNS not working on ER605 v2?

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
MDNS not working on ER605 v2?
MDNS not working on ER605 v2?
2023-03-11 07:25:19 - last edited 2023-03-11 07:27:31
Model: ER605 (TL-R605)  
Hardware Version: V2
Firmware Version: 2.1.2

I just revived my TP Link hardware since mDNS was added. However I'm not sure if I'm doing something wrong or if it's just not working, I'm not educated on networking outside of watching many YT videos on setting up home network/vlans so please bear w/ me. Here is what I'm trying to do. My phone is connected to my main wifi 192.168.0.X and my Nvidia Shield is on a guest wifi network w/ VLAN 192.168.10.x. I'm simply trying to cast a youtube video from my phone to my nvidia shield. At one point I could see the device name to cast to and tried to cast and it would not work. Then that device just went away from the list of available items to cast to. I also tried to ping a device on vlan 10 from my main lan. No luck.

 

I'm using OC200 controller(5.7.6), ER605 V2(2.1.2) router and TL-SG2210P switch w/ my ATT router in passthrough mode.

 

Is this all there is to setting this up?

  0      
  0      
#1
Options
7 Reply
Re:MDNS not working on ER605 v2?
2023-03-13 06:12:47 - last edited 2023-03-13 06:14:55

 Hi @Chad711 

 

If you connect your phone to the same wifi network as Nvidia Shield, can they work properly?

 

Also make sure there is no Access Controller rules. 

 

 

Best Regards! >> Omada EAP Firmware Trial Available Here << >> Get the Latest Omada SDN Controller Releases Here << *Try filtering posts on each forum by Label of [Early Access]*
  0  
  0  
#2
Options
Re:MDNS not working on ER605 v2?
2023-03-13 06:56:54

  @Hank21 

 

Hi, yes when on same wifi it works fine. I will check ACL rules next time. I was having some strange wifi issues with this setup, constantly dropping during a teamviewer session, so I removed the hardware for now.

  0  
  0  
#3
Options
Re:MDNS not working on ER605 v2?
2023-03-13 17:28:34 - last edited 2023-03-13 17:28:51

  @Chad711 i couldnt get mDNS working properly either, tried using the gateway for my home app cameras and also chromecast but needed also airprint to work which didnt allow me to add a AP mDNS instance when you already have a gateway instance. 

 

Ended up just going back to using Avahi on a ubuntu vm. Hoping dev's can update the mDNS settings so it is easier to setup and also allows better integration with apple protocols. 

  0  
  0  
#4
Options
Re:MDNS not working on ER605 v2?
2023-03-13 20:07:10
Thanks for the feedback. I guess I am doing the settings right and it just isn't working correctly. Too bad this has been such a big hurdle. I would like to use this equipment I bought but it's just collecting dust!
  0  
  0  
#5
Options
Re:MDNS not working on ER605 v2?
2023-03-13 21:01:34 - last edited 2023-03-13 21:02:01

  @Chad711 funny you say that cuz I had a er605 v1 sitting in the closet collecting dust. I saw that v2 had mdns so I just bought another er605 last week, swapped out my sophos for er605 only to find out mdns is bit half baked lol. I'm at a point of no return to switch back to sophos as I had to make significant changes in my environment so way too lazy to swap back lol.

 

so far seems to be pretty solid, had couple odd issues here and there, fw acl seems to very buggy. Like switching around priority of the rules doesn't seem to stick unless you refresh and drag and drop the rules again. 
 

had bit of a headache doing shieldsup test which was showing majority of my ports closed instead of stealth which really bothered me from a security perspective, especially moving away from a ngfw, but finally got that sorted. Was one of the attach defence setting. Had to turn off "Block TCP scan with RST". Now finally my environment is stealth!!

 

im gonna continue using the er605 for now and maybe when I have time, introduce the sophos inline for some additinal security. 

  0  
  0  
#6
Options
Re:MDNS not working on ER605 v2?
2023-03-13 21:31:53

  @j0np So does your mdns some what work or it doesn't work at all? My wife goes into work once a month so that week she is out I will try to do this all again but each time I have tried this I ran into wifi issues. Maybe a DHCP issue. I can't seem to find a solid guide on proper AT&T router passthrough. If I find a video there is replies from ppl stating they have issues or they say you should do this/that. Hopefully I can get it all setup and working right one day!

  0  
  0  
#7
Options
Re:MDNS not working on ER605 v2?
2023-03-13 22:25:15

  @Chad711 mdns was not reliable at all. When I setup the mdns gateway, some of my Chromecast and cameras worked (iOS home app), however randomly would drop. For iOS AirPrint, couldn't get that working at all using the AP mdns instance. Seems very convoluted for such a simple configuration so I gave up lol. Avahi so easy to setup and bam working beautifully
 

For gateway, I haven't been using the ISP provided router since day one, I originally used sophos instead and now er605.

 

funny you say that you may be having dhcp issue, i noticed today one iOS device and one of my VM's couldn't renew it's ip and dropped connection. Had to forcefully renew again and worked. So another issue to add to the list :(

  0  
  0  
#8
Options

Information

Helpful: 0

Views: 1102

Replies: 7

Related Articles