TL-SX3008F doesn't auto negotiate link speed

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

TL-SX3008F doesn't auto negotiate link speed

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
TL-SX3008F doesn't auto negotiate link speed
TL-SX3008F doesn't auto negotiate link speed
2023-04-26 10:45:31
Model: TL-SX3008F  
Hardware Version: V1
Firmware Version: 1.0.4

Reading in the now locked thread about the SX3008F not being able to negotiate 1Gbit link speed, I was happy to see that FW 1.0.1 should have fixed this issue. Obviously there is the "disclaimer" to use TP-Link SFP modules, which I don't have.

 

Now that thread is locked so I have to start a new one, since no matter what modules I use, the switch just shows a pop up error message saying "Invalid link speed and duplex setting". 

 

I have been testing with DACs connecting to other TP-Link switches. I have tested Cisco RJ45 modules capable of 1, 2.5. 5 and 10G and I have tested with Icomera and QSFPTEK fiber modules. Nothing works, and the same is true on my recently purchased TL-SX2306PP v1.0 with FW 1.0.3. 

Am I doing it all wrong, or is TP-Link is not capable of getting autonegotiate to work in their switches. The same modules used in Intel X520 cards will autonegotiate perfectly fine, regardless of endpoint used. 

  0      
  0      
#1
Options
2 Reply
Re:TL-SX3008F doesn't auto negotiate link speed
2023-04-27 03:37:05

  @Gblenn 

 

Hi, have you tried a short Ethernet cable to test?

This kind of problem is usually caused by the quality and length of the Ethernet cable.

 

And a reboot /reset may also solve the issue.

Just striving to develop myself while helping others.
  0  
  0  
#2
Options
Re:TL-SX3008F doesn't auto negotiate link speed
2023-04-27 11:46:03 - last edited 2023-04-27 11:52:54

@Virgo The issue is not so much about "negotiating" the speed, which is anyway only supported over BaseT. It is that it will not accept setting 'Link Speed - Auto' in Profile Overrides! The only way to get it to work is to manually set the port link speed to 1Gig (and 10 is default)... 

 

According to this thread, firmware 1.0.1 should have fixed this, but apparently not... TL-SX3008F doesn't auto negotiate to 1G with SFP

 

If it doesn't recognize the module, which I doubt would be the case with Cisco modules, I don't see why it couldn't anyway try setting a different link speed until it works... All it needs to know is that there is a module in the cage... And if it's a DAC cable (passive copper), again all it would need to do is to test at 1 Gig if 10 Gig doesn't work... 

 

And just so you know, the 3008F has SFP cages only, meaning that you can't connect an Ethernet cable unless you plug in an RJ45-module. And, as I wrote, I have tested with various SFP modules including different Fiber and DAC models. The only Ethernet modules I tested were Cisco SFP+ which will auto negotiate normally and are capable of both 1 and 10Gig. The fiber modules are obviously 1Gig versions, and the idea is that the switch would set itself to 1Gig when such a module is detected. It's not negotiating a speed with the other party... 

Anyway, all my testing is between switches in-rack (less than 50cm) and to the SFP port of a TL-SG2428P, or to a 1 Gbit Eth port on that switch in the case of the Cisco module.

 

  0  
  0  
#3
Options

Information

Helpful: 0

Views: 532

Replies: 2

Related Articles