Deleted EAP not discovered from controller

Deleted EAP not discovered from controller

Deleted EAP not discovered from controller
Deleted EAP not discovered from controller
2024-06-07 09:35:04 - last edited 2024-06-08 08:25:01
Hardware Version:
Firmware Version: 5.13.30.8

Hi,

 

I've installed an Omada Controller via docker in a complete new network. I use the following hardware:

 

  • 1 x SG3218XP-M2 v1.0 (1.0.2)
  • 1 x SG3428XPP-M2 v1.20 (1.20.2)
  • 2 x EAP673(EU) v1.0 (1.0.3)

 

After the first installation all works well. Then I moved the hardware to our buero and there one of the EAP673 couldn't adopted. No restart, no factory reset of the eap helped. So I deleted/forgot the eap in the controller.

 

Since then the eap wouldn't discovered by the controller anymore. I can't adopt it, because the eap wouldn't listed in the device list.

 

The Interface on the switch is the same VLAN, where the controller is in. With pluggedin cable and factory reset on the eap the following lines comes in the server.log:

 

06-07-2024 10:16:27.236 INFO [monitor-topology-pool-3] [] c.t.s.o.c.u.e.a(): list local interface macs: [02-42-5F-A3-33-31, BC-24-11-2F-C8-A6]
06-07-2024 10:16:30.902 INFO [discovery-work-group-1] [] c.t.s.o.m.d.d.m.d.a(): NO_MANAGED Device 98-25-4A-60-20-D2 on omadac 85c9fd003879076e6386eeee40e983ad is discovered.
06-07-2024 10:17:49.347 INFO [server-comm-pool-3] [] c.t.s.e.s.c.h.EcspV2DeviceContextHelper(): pending device 98-25-4A-60-20-D2 time out, remove device context
06-07-2024 10:17:49.534 INFO [device-timeout-workgroup-0] [] c.t.s.o.m.d.d.m.j.b(): timeoutWiredPending, OmadacId OmadacId(85c9fd003879076e6386eeee40e983ad) Device DeviceMac(98-25-4A-60-20-D2).

 

The eap get's an ip address and I can ping him. But it wouldn't discovered.

 

How can I readopt it again?

 

Thanks

Ulf

 


   

  0      
  0      
#1
Options
1 Accepted Solution
Re:Deleted EAP not discovered from controller-Solution
2024-06-08 08:24:56 - last edited 2024-06-08 08:25:01

  @MR.S 

I think I figured out my configuration error. My firewall hasn't registred the DHCP entries in the dns server. So the name omada was not reachable. After setting this option the access point was listed for adoption.

 

Thank you for listening and support.

Recommended Solution
  1  
  1  
#8
Options
9 Reply
Re:Deleted EAP not discovered from controller
2024-06-08 06:50:23

  @Business-Tux 

 

check if show pending device is enabled in global view, controller settings.

  0  
  0  
#2
Options
Re:Deleted EAP not discovered from controller
2024-06-08 07:02:44

  @MR.S 

 

Yes it's enabled:

  0  
  0  
#3
Options
Re:Deleted EAP not discovered from controller
2024-06-08 07:09:03

  @BusinessTux 

 

ok, if you haven't deleted the access point from the controller, delete , then reset the access point, press the reset button for 15-20 sec

 

make sure that the access point is connected to the same IP network as the controller.

  0  
  0  
#4
Options
Re:Deleted EAP not discovered from controller
2024-06-08 07:11:48

  @BusinessTux 

 

since you are running the controller in a docker you need to make sure that these ports are opened in the docker firewall

UDP 29810
TCP 29811-29816

 

  0  
  0  
#5
Options
Re:Deleted EAP not discovered from controller
2024-06-08 07:13:00

  @MR.S 

Thanks. The accesspoint is deleted already. And yes it is connected to the same network/vlan like the controller. From the controller I can ping the ap. But my reset actions where only <10 seconds. I will test it with 20 seconds next time. The next planned tour to the office is planned for next friday.

 

Thanks for you support.

  0  
  0  
#6
Options
Re:Deleted EAP not discovered from controller
2024-06-08 08:07:09

  @MR.S 

Yes, the ports are open. Here a list from the host system, which ports are listening:

 

The complete hardware construct where working on my home lab. I set everything up from scratch in my home lab. There adoption/discovery was functionally. The controller is a vm on a Proxmox host.

 

OPNsense Firewall

  • management vlan
    • omada
    • switches
    • access points
    • software distribution
    • proxmox host
  • office vlan
    • app server
    • workstations

 

I moved the complete hardware to the office. So only the internet access has changed. The two switches and the one accesspoint are online. The second accesspoint not. I suspect that it has something to do with the fact that I deleted the access point from the controller. Before the deletion the controller couldn't adopt the accesspoint. After deletion and factory reset (10 sec) the accesspoint wasn't discovered anymore.

 

 

  0  
  0  
#7
Options
Re:Deleted EAP not discovered from controller-Solution
2024-06-08 08:24:56 - last edited 2024-06-08 08:25:01

  @MR.S 

I think I figured out my configuration error. My firewall hasn't registred the DHCP entries in the dns server. So the name omada was not reachable. After setting this option the access point was listed for adoption.

 

Thank you for listening and support.

Recommended Solution
  1  
  1  
#8
Options
Re:Deleted EAP not discovered from controller
2024-06-08 08:34:18

  @BusinessTux 

 

even if you get the port list with lsdof, it does not mean that the firewall is not blocking the ports. but since you have other working devices adopted on the controller it should be fine.

you can try a hard reset when you are onsite, the lamp should flash and then go off, I usually hold the reset button until the light goes out

 

  0  
  0  
#9
Options
Re:Deleted EAP not discovered from controller
2024-06-08 08:38:50 - last edited 2024-06-08 08:39:09

  @BusinessTux 

 

strange that everything worked except for one access point when dns was the problem :-) but nice that you figured it out

 

  0  
  0  
#10
Options

Information

Helpful: 0

Views: 294

Replies: 9

Related Articles