KRACK attack: last firmware is from 2015

KRACK attack: last firmware is from 2015
KRACK attack: last firmware is from 2015
2017-10-17 08:08:27
Model : TL-WR741ND

Hardware Version :

Firmware Version : 3.12.11 Build 120320 Rel.50684n

ISP : Videotron

Hi

I have a TL-WR741ND, a solid one that never left me behind after all those years. But now with the new WPA2 vulnerability, I wanted to upgrade the firmware. But I can only find firmware V5 from 2015 as the last update, so I guess my only way to protect my Wifi is to buy a new router? (disabling wifi is not an option)
0
0
#1
Options
5 Reply
Re:KRACK attack: last firmware is from 2015
2017-10-17 23:51:07
Came here for the same thing. Could we get some kind of official response? Will there be a firmware patch coming soon? Even just a "no" would be useful so we know to look for alternatives (such as DD-WRT, perhaps).
0
0
#2
Options
Re:KRACK attack: last firmware is from 2015
2017-10-18 16:52:24
0
0
#3
Options
Re:KRACK attack: last firmware is from 2015
2017-10-21 03:05:35
TL-WR740N user here. I'd like to know as well.
0
0
#4
Options
Re:KRACK attack: last firmware is from 2015
2017-11-24 23:40:36
It's a weakness in WPA2 protocol so unless TP-Link released the patch for devices we can't avoid it. But, being affected by it is remote because attacker needs to be in the close proximity.
0
0
#5
Options
Re:KRACK attack: last firmware is from 2015
2017-11-27 15:31:36
Hey, I saw http://www.tp-link.com/en/faq-1970.html it is said that Routers and gateways working in their default mode (Router Mode) and AP Mode belong to unaffected TP-Link products.
So maybe we need not to worry about the wireless security of our router.
0
0
#6
Options