Archer C7 V4.0 OpenVPN not working on restart, need to disable/enable

Archer C7 V4.0 OpenVPN not working on restart, need to disable/enable
Archer C7 V4.0 OpenVPN not working on restart, need to disable/enable
2017-11-15 22:04:20
Model : Archer C7

Hardware Version :

Firmware Version : Archer C7(EU)_V4_170901

ISP : KPN (Netherlands)

Hi all,

Since this week i got an Archer C7 V4.0. Seems to work fine except for 1 thing:

I setup OpenVPN on the C7, opened the pors on the modem, and everything was running fine! Then i just got a power outage, and i could no longer connect to the OpenVPN from outside.

I thought it was a network issue, but when i disabled en re-enabled OpenVPN on the C7, immediately the OpenVPN started working again. I can 100% reproduce this by rebooting the C7.
[*]I reboot the device,
[*]Wait for it to be completely up and running again.
[*]Try to connect to OpenVPN from outside network.
[*]OpenVPN client will hang indefinately... -> FAIL
[*]While the client is still trying to connect, disable and re-enable OpenVPN on the C7
[*]Client immediately gets a response from the C7 and it works -> SUCCESS
The fact that you see the immediate response from the client says that this is a router issue, and not a modem/network issue in between. Is this a known firmware bug?

Grtz, Johnny
0
0
#1
Options
8 Replies
Re:Archer C7 V4.0 OpenVPN not working on restart, need to disable/enable
2017-11-18 18:47:01
That's strange, have you tried hard reset the router to factory settings and re-configure it?
0
0
#2
Options
Re:Archer C7 V4.0 OpenVPN not working on restart, need to disable/enable
2017-11-20 02:26:50
Yup:
- Reset and restore backup -> same result
- Reset and manually setup everything again -> same result
0
0
#3
Options
Re:Archer C7 V4.0 OpenVPN not working on restart, need to disable/enable
2017-11-21 19:04:17
It's suggested to contact the tp-link support at support@tp-link.com, and attach your config file to let them do a test.

rtbravo wrote

Yup:
- Reset and restore backup -> same result
- Reset and manually setup everything again -> same result
0
0
#4
Options
Re:Archer C7 V4.0 OpenVPN not working on restart, need to disable/enable
2018-03-25 03:15:34
I have the exact same issue on Archer C1200 V2.
0
0
#5
Options
Re:Archer C7 V4.0 OpenVPN not working on restart, need to disable/enable
2018-03-25 21:05:39
artikel bagus
0
0
#6
Options
Re:Archer C7 V4.0 OpenVPN not working on restart, need to disable/enable
2018-03-26 02:02:11
I contacted TP-Link EU and got a quick reply from them, confirming the bug was inside the firmware. Some days later i got sent a beta firmware in which it was fixed! I asked when this would be released in an official firmware. They said asap, but up to now, no release has been done (half a year already). So i decided to switch to LEDE (OpenWRT), which doesn't have this issue and allows lots and lots more features.
0
0
#7
Options
Re:Archer C7 V4.0 OpenVPN not working on restart, need to disable/enable
2019-04-05 01:54:42

Yes I have this or a similar issue with Archer C1200's v1 and v3.  They are at client sites so I am not sure if they are rebooting or not. But The OpenVPN just stopps working once or twice per week.. The only way to fix it is to unenable and then reenable the OpenVPN server and click save.. This gets them back up and going..

 

If this is a firmware bug, then it seems to be on multi devices and versions.. I.e. C1200 V1 and V3 that I am using.

 

Has there been any update to this issue or do I need to change to another brand for simple vpn access?

0
0
#8
Options
Re:Archer C7 V4.0 OpenVPN not working on restart, need to disable/enable
2020-02-21 07:42:28

 

Fix for me (using a C2300):

 

Log into router, click on "Advanced", choose the "System Tools" section, and "Time Settings" under that. Set both NTP servers to "pool.ntp.org" and reboot the router. Any existing OpenVPN configuration should now work again.

 

Explanation:

 

I was having a similar problem on the C2300 -- an exceptionally good router except for this bug. After some hard research and experimentation, I figured out my specific issue: the router's time.

 

Like most encrypted communication protocols on the internet, OpenVPN's protocols require the two communicating parties (VPN client and VPN server) have time that's roughly calibrated. The router calibrates its own time via NTP through nist.gov's servers. For some reason, the C2300's firmware dislikes these NTP servers, and so for me its time was perpetually stuck in the past leading to the VPN issues.

 

Luckily, pool.ntp.org works -- I set both time servers to this, problem solved. It pulls the right time after booting up, and OpenVPN works fine after reboot now, even with the latest firmware.

0
0
#9
Options