Chromecast not working with Deco M5 as router

Chromecast not working with Deco M5 as router
Chromecast not working with Deco M5 as router
2017-12-02 14:24:58 - last edited 2021-06-10 03:37:21
Model :

Hardware Version :

Firmware Version :

ISP :

Hello!

Any other experience problems with connecting Chromecast to Deco M5 when having the first M5 as router?

I have the first M5 as a router and is planning to connect a gigabitswitch to that one for the wired network in my home (and connect the remaining 2 M5 to this).
Now, when trying to configurate my Chromecast, it finds it but when performing the configuration, it states "not possible to connect the Chromecast to [myNetwork-name], check WiFi network-name". (translated from Swedish...)
It seems the complete network goes down when configurating the Chromecast (expected behavior is that the phone or computer goes of of Wi-Fi).

I am still able to use my old router (Thomson TG789n) but the speed in this router will limit me

I have tried to access the router (192.169.0.1) through a web-browser but with refused response so the only way to configurate the Deco M5 system seems to be through the app?!

The Wi-Fi works splendid and no problem connecting my Sonos-system, except this problem.

Any ideas or if someone is experience the same?
0
0
#1
Options
1 Accepted Solution
Re:Chromecast not working with Deco M5 as router-Solution
2021-06-09 17:57:27 - last edited 2021-06-10 03:37:21

@ado good grief, i was losing my mind with this issue. I rebooted, messed with settings, everything that ive seen in forums. the chromecast audio finally connected almost instantly when i turned off "Fast Roaming" from within the advanced settings.  

Recommended Solution
2
2
#12
Options
11 Reply
Re:Chromecast not working with Deco M5 as router
2017-12-04 16:53:57
1, Remove any out of the ordinary characters from the SSID of the Deco, or just give your Deco a simple name consists of only letters and numbers.
2, Seems like the Deco only supports APP management at the moment, but I hear they are making a web-interface for management too.
3, Really the whole network goes down when you try to connect the chromecast, how wried? connect the chromecast to your old router, perform a firmware update then try again.
0
0
#2
Options
Re:Chromecast not working with Deco M5 as router
2017-12-06 22:25:09
Hi matt and thanks for the reply

1. SSID is just letters, nothing strange
2. Looking forward to the web-interface
3. This I probably misinterpreted when goofing around. Nothing confirmed.

I also tested with Chromecast Audio with no success

I have posted a support-email to TP-Link, waiting on their response.

Meanwhile I have an intermediate solution, I use my old router to create a sub-network, I connect to this network and then I can use my Chromecast....
0
0
#3
Options
Me too
2017-12-09 22:01:33
Hi,

I have the same issue. Since I installed the Deco M5 set of three APs and made it my only WiFi I've had continuous issues with WiFi. Most of time all go well, but it seems when I cast something on Chromecast OR just play something on Netflix client of my TV it has issues. For example the bitrate seems to lower (results in bad picture quality), then it breaks the connection and e.g. Netflix will buffer for sometime. This might often lead to total crash of the whole WiFi that is noticeable then on the other clients like phone or tablet stopping to refresh Facebook etc.

My all three Decos are connected with cable to the fibre modem. Now I changed the operation mode to AP to see if that helps.
0
0
#4
Options
Re:Chromecast not working with Deco M5 as router
2017-12-10 03:34:49
It is solved!

After latest app-update (1.4.9) this issue became clear.
The first M5, acting as router, was blocking the Chromecast from network traffic.
With the updated app, the blocking could be unblocked and now everything works like a charm.
I didn't check the blacklist in the old app so I am not sure if that could be a solution for the old app.
0
0
#5
Options
Re:Chromecast not working with Deco M5 as router
2017-12-27 19:35:20
was this a double NAT issue with Chromecast
I am having the same issue with my SONOS and ATT MCell
Trying to figure out how to get DECO in Router mode and not lose my SONOS and MCell which won't work through a double NAT.

Any ideas?
0
0
#6
Options
Re:Chromecast not working with Deco M5 as router
2020-03-01 05:18:12

@sanch Did anybody ever figure this out... I really struggle connecting smart devices (IFFF, chromecast, doorbells, smart home, etc) through my deco network... 

 

Did we ever get aweb based Management tool.. The app is for noobs... 🙂 

0
0
#7
Options
Re:Chromecast not working with Deco M5 as router
2020-03-23 20:24:08

@ado 

Try to disable the 5 GHz band when configuring the Chromecast 2 device. After successfully connecting the Chromecast device, the 5 GHz band can be activated again.

1
1
#8
Options
Re:Chromecast not working with Deco M5 as router
2020-07-12 08:46:02

@HenrikNilsson 

 

What worked for me was turning off all but one deco. Switching to 2.4g band.  This is for Chromecast 2. My Chromecast 3 had no issues. After connection. I switched everything back to what it was and it's still connected

0
0
#9
Options
Re:Chromecast not working with Deco M5 as router
2020-07-19 07:43:48

@ado After few days traying to connect my Chromecast to the connection created in router mode by my 2 M4s, I managed to do it using my Android phone (iPhone was giving me issues) and by switching ON both 2.4 and  5 GHz connections. Previously I had only 5Ghz ON.

After that, I switched off the 2.4 again and had no issues.

0
0
#10
Options
Re:Chromecast not working with Deco M5 as router
2020-10-02 09:53:09

It's the Intrusion Prevention System that blocks access to the Chromecast, ture that off and it works. 

0
0
#11
Options
Related Articles