Archer C7 router 2.4GHz WLAN regularly loses connection to internet, 5GHz ok

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Archer C7 router 2.4GHz WLAN regularly loses connection to internet, 5GHz ok
Archer C7 router 2.4GHz WLAN regularly loses connection to internet, 5GHz ok
2018-01-01 06:37:03
Model : C7

Hardware Version : v2.0

Firmware Version : 3.14.3 Build 150427 Rel.36706n

ISP : [UPC]

I have an Archer C7 router with both 2.4GHz and 5GHz WLANs configured. Both WLANs work and end devices are connected across the WLAN. However while the devices on the 5GHz WLAN have high reliability access to the internet, the devices on the 2.4GHz have very intermittent access to the internet even though the WLAN connection is maintained. That is, they seem to be able to get to the access point fine, but not out across the WAN interface. Has anyone else experienced this problem and/or have any suggestions about where to look to find the problem?
0
0
#1
Options
2 Reply
Re:Archer C7 router 2.4GHz WLAN regularly loses connection to internet, 5GHz ok
2018-01-09 17:58:35
Did it start behaving poorly after working correctly for a while, or has it always been like this? Is the connection bad everywhere, or does it get better if the device is closer to the router? 2.4GHz is a very common frequency, other devices might be causing interference (other routers from neighbors, wireless home entertainment headphones, wireless keyboard/mouse/headset, microwave oven). Usually the router is smart enough to detect interference, you might try restarting it if you haven't yet.

I think the simplest test would be to stand right next to the router with 2 different devices (phone, laptop) and see if the connection is still bad. If it is, it's most likely the router, otherwise you'll need to look somewhere else.
0
0
#2
Options
Re:Archer C7 router 2.4GHz WLAN regularly loses connection to internet, 5GHz ok
2018-01-16 08:25:16
I'm having a similar issue. Within the last month the 2.4 GHz wireless started behaving intermittently. 5.0 GHz has been solid since the firmware upgrade I performed in August (to 3.15.2 Build 170525 Rel.37571n). It doesn't matter how close my device is to the router.
0
0
#3
Options