Archer C9 stops forwarding multicast requests to nodes in group after 5 minutes

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Archer C9 stops forwarding multicast requests to nodes in group after 5 minutes
Archer C9 stops forwarding multicast requests to nodes in group after 5 minutes
2018-03-29 21:55:38
Model :

Hardware Version :

Firmware Version :

ISP :

Hi.

I work for a software company, implementing a software solution using multicast protocol for network discovery within a home network.

We see the following behavior with Archer C9:
A "server" joins an IPv4 multicast group (this is done using C-level APIs)
[*]Client and server "nodes" are connected over the WiFi to the router
[*]The server responds to the client requests within 5 minutes
[*]After 5 minutes, it stops responding, and there is no indication in Wireshark logs that any packet had reached it.
[*]There is no indication of any malfunctioning in the node software
[*]At the same time, other nodes (i.e. those that have lifetime of less than 5 minutes) receive the client multicast requests, and respond (via the same router)
So it appears like the router does not forward the requests to the node, for some reason.

Additional information:
This does not happen with IPv6.
[*]The server nodes can be either Android or Linux - exactly the same behavior. So it's not a specific issue of a server node operating system.
[*]This does not happen when a server node is conected using LAN (Ethernet)
[*]AC7500 router seems to work fine in this scenario.
Is it a known issue? Any way to debug it further? Resolve?

Thanks for any hint,

Max.
0
0
#1
Options
2 Reply
Re:Archer C9 stops forwarding multicast requests to nodes in group after 5 minutes
2018-03-30 09:58:50
as far as i know, C9 is a igmp proxy only. so it can't be the server for igmp client. did you create server in the network?
sorry, i am not professional on this. maybe you can contact tp-link emai support directly.
0
0
#2
Options
Re:Archer C9 stops forwarding multicast requests to nodes in group after 5 minutes
2018-03-30 18:06:26

Kevin SG wrote

as far as i know, C9 is a igmp proxy only. so it can't be the server for igmp client. did you create server in the network?
sorry, i am not professional on this. maybe you can contact tp-link emai support directly.


Yes, we have a server software (actually, based on a 3rd party component) that has a "server" function (i.e. joins the multicast group) and also the client function (i.e. discover servers over the network)
0
0
#3
Options