TP-Link RE500 Performance Issues and Updated Firmware (Personal Experience and Wirecutter Review)

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

TP-Link RE500 Performance Issues and Updated Firmware (Personal Experience and Wirecutter Review)

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
TP-Link RE500 Performance Issues and Updated Firmware (Personal Experience and Wirecutter Review)
TP-Link RE500 Performance Issues and Updated Firmware (Personal Experience and Wirecutter Review)
2018-06-17 21:18:25
Model :

Hardware Version :

Firmware Version :

ISP :

I recently purchased the TP-Link RE500 range extender after using it for a few days I found that the performance (speed) to drop significantly, I am running 3 devices on the extender, and I have to reset the router at lease once a day to get the speed back to normal. Having looked online for answers I came across the wirecutter review ( https://thewirecutter.com/reviews/best-wi-fi-extender/) , which suggests there is an issue with extenders firmware. I am currently running on the latest firmware To quote the review:

[FONT=arial]P-Link RE500[/FONT]
[FONT=arial]TP-Link’s RE500 was at the very top of the chart for simple single-client throughput, but it significantly decreased the quality of the test laptop’s connection with the whole network active. It’s possible that TP-Link will find some bugs to fix in future firmware revisions, but for right now, avoid the RE500.[/FONT]


Does anyone know if there is a fix to the issue I am having? And when an updated firmware fix will be released?
  0      
  0      
#1
Options
2 Reply
Re:TP-Link RE500 Performance Issues and Updated Firmware (Personal Experience and Wirecutter Review)
2018-06-20 06:52:10
You should try resetting the modem once and try installing the latest firmware of your router. If still your issue is not resolved then you should buy a new one. It might be some hardware issue. If you need more help contact Microsoft Tech Support UK.
  0  
  0  
#2
Options
Re:TP-Link RE500 Performance Issues and Updated Firmware (Personal Experience and Wirecutter Review)
2018-06-20 17:31:32

david1223 wrote

You should try resetting the modem once and try installing the latest firmware of your router. If still your issue is not resolved then you should buy a new one. It might be some hardware issue. If you need more help contact Microsoft Tech Support UK.


I am running the latest firmware and I just got a replacement with the same issue. If you read the review that I posted it seems this extender has inherent performance issues when connecting multiple devices. Its not an isolated incident which I am experiencing.
  0  
  0  
#3
Options

Information

Helpful: 0

Views: 813

Replies: 2