TL-WR740N loses wireless connectivity

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
TL-WR740N loses wireless connectivity
TL-WR740N loses wireless connectivity
2012-11-28 20:07:41
Region : Others

Model : TL-WR740N

Hardware Version : V4

Firmware Version : 120320

ISP : Local PPPoE


Hello forum.

I'm using this router for connecting 2 PCs, one lap top and few mobiles.

The LAN network is always stable and never loses connection, but I'm having problems with the wireless connection. My lap top runs on wireless, and 3 Android mobiles, an xperia mini pro (problematic), xperia Tipo and Alcatel OT-908F.

Almost always when I login to facebook on any of the mobiles, pictures won't show, and also youtube videos thumbnails won't show.
On the xperia mini pro after 2-3 minutes of surfing, or doing anything else the connection drops, and then the mobiles can't see the wireless connection.

My lap top can see it, but it cannot connect. After restarting the router everything is back to normal.

Note: my Xperia Mini Pro doesn't "kill" wireless connection anywhere except in my home on the WR740N.

Wireless settings on my router:
Channel : 11 (there aren't routers anywhere close to me)
Mode: 11bgn mixed
Channel width: Auto
Enabled Wireless Router Radio
Enabled SSID Broadcast
Disabled WDS Bridging


Wireless Advanced settings on my router:
Beacon Interval : 100
RTS Threshold: 2346
Fragmentation Threshold: 2346
DTIM Interval:1
Enabled WMM
Enabled Short GI
Disabled AP Isolation

If someone knows what can I do about this, please help!

Regards, Mite.
0
0
#1
Options
41 Reply
Re:TL-WR740N loses wireless connectivity
2012-11-29 10:44:51
Wireless settings:
Mode: 11 bg mixed

Advanced:
Beacon Interval :50
RTS Threshold: 2304
Fragmentation Threshold: 2306
DTIM Interval: 1

Enabled WMM
Disabled Short GI
Disabed AP Isolation

DHCP:
Address Lease Time: 2880

This is my fix. Had to post to a official(?) TP-Link forum to find the answer myself :)
1
1
#2
Options
Re:TL-WR740N loses wireless connectivity
2012-11-30 09:21:08
I searched Google and finally find this forum to discuss the problems. This is new to me and I am willing to learn something from this.:D
It seems that your TP-LINK router is working in 11bg mode but not 11bgn mixed mode. 11bg is more stable than 11bgn mixed mode? Sounds unbelievable but a really a good try! Will the speed slower than before? DHCP also effects the Wireless as mentioned wired connection without problem? Can anyone explain?
0
0
#3
Options
Re:TL-WR740N loses wireless connectivity
2012-12-02 02:18:34

mynetwork wrote

I searched Google and finally find this forum to discuss the problems. This is new to me and I am willing to learn something from this.:D
It seems that your TP-LINK router is working in 11bg mode but not 11bgn mixed mode. 11bg is more stable than 11bgn mixed mode? Sounds unbelievable but a really a good try! Will the speed slower than before? DHCP also effects the Wireless as mentioned wired connection without problem? Can anyone explain?


To be honest with you, I don't know if switching to 11bg mode fixed my problem.
From what I know, "n" mode is consider as a very new at least in mobile wireless technology, and almost all laptops up to 2010/11. So no changes in connection speed, either locally (transfering files from comp to comp with WiFi) nor on the ethernet.
In "g" mode the channel width is only 20Mhz but I didn't notice anything different. My xperia mini pro is always connected to the router now, for testing. And since I wrote the above post, no problems at all!

I changed the DHCP lease time because of a post on a different forum about not getting wifi connection AT ALL. The value for the other settings was changed because I found them on the net (lazy to search for the link)

Everything I changed was for other problems with TP-LINK routers, and some settings are for all routers out there.

I didn't try them one by one, but changed everything and then restarted the router. :D Maybe only one change was enough but I don't know which one. If you find it let me(us) know!

Cheers! Glad you found this helpfull.
0
0
#4
Options
Re:TL-WR740N loses wireless connectivity
2012-12-06 11:58:56
I have the same problem like you braincrasher. What i cant figure out is: My 740N used to operating normally. However, I cant connect my laptop to internet via wireless for the last 3 month. Whenever i want to use it, i have to turn off then turn on the 740N. And now, i cant even do that to connect via wireless. I tried reset and reinstall using the cd but i doesnt work. What should i do now??
0
0
#5
Options
Re:TL-WR740N loses wireless connectivity
2012-12-06 15:45:31
Have you tried to change MTU size? By changing it to smaller number.
0
0
#6
Options
Re:TL-WR740N loses wireless connectivity
2013-02-07 14:20:38
Does turning the wifi adapter in your laptop off and on fix the problem too? (as does turning the router on and off).

Read my post here for more details:
http://forum.tp-link.com/showthread.php?1535-Router-Wireless-stops-working-randomly-and-requires-power-recycle&p=5623#post5623
0
0
#7
Options
Re:TL-WR740N loses wireless connectivity
2013-02-10 19:04:34
hmmm, another thread on this issue.....
I guess I will give your settings a try then.

EDIT: I've only changed the wireless mode to 11bg mixed and the address lease time to 2880... This was done on 10/02/2013, it is now 14/02/2013 and I haven't been disconnected from WiFi yet (granted I haven't been home during most of the day).
0
0
#8
Options
Re:TL-WR740N loses wireless connectivity
2013-04-06 22:46:54
I have these problems since I've bought these routher, and i tried the solution that braincrasher suggested but problem remains, and it drives me crazy. Also i trieds to reduse MTU size, but it didn't worked. Help please, is these that hard, that even the support people from the company cannot help me ???????
0
0
#9
Options
Re:TL-WR740N loses wireless connectivity
2013-04-08 19:54:31
I have spoken with the support team, and changing primary and secondary DNS settings to 8.8.8.8 and 8.8.4.4 respectively, had resolved my problem. The settings are in the: DHCP-DHCPsettings and there are primari, secondary DNS.
0
0
#10
Options
Re:TL-WR740N loses wireless connectivity
2013-04-09 10:03:30
I got the same problem on my wireless router. I emailed TPLINK technical support and they suggested me to try different wireless channels, change the wireless mode from 11bgn mixed to 11bg, and change the channel width to 20Mhz. This fixed my problem. You may give a try like this.
BTW, thanks you guy Pozitron:D. I learned a new solution by changing the DNS settings on the router.
0
0
#11
Options