Samsung SmartTV refuses to accept connection in client mode

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Samsung SmartTV refuses to accept connection in client mode
Samsung SmartTV refuses to accept connection in client mode
2012-12-07 06:32:03
Region : Argentina

Model : TL-WR740N

Hardware Version : V1

Firmware Version :

ISP :


Region : UnitedKingdom

Model : TL-WR740N

Hardware Version : V1

Firmware Version :

ISP :


Hello,

Am trying to use a TP-Link TL-WR702N to connect my Samsung SmartTV to a wireless network, using "client mode". For some reason, the TV refuses to accept it is connected, or even connected to a router. Enabling DHCP on the TP-Link does seem to convince the TV that it is connected to a router, but still not to the internet. Strangely though, I can control the TV via the Android app operating on the local network, so clearly it is connected. I assume the SmartTV is trying to get a response on the local network that the TP-Link is filtering out for some reason, but no idea why. Any thoughts ?

(TV plugged into broadband router via ethernet cable works perfectly well, so not an broadband problem)

thanks,

Richard
0
0
#1
Options
36 Reply
Re:Samsung SmartTV refuses to accept connection in client mode
2012-12-07 10:01:41
Richard, you can plug the 702N to your computer and have a test.
If it doesn't work, i think it may be not configured correctly.
0
0
#2
Options
Re:Samsung SmartTV refuses to accept connection in client mode
2012-12-07 18:08:03
Hi Will,

Good idea, have just done that with computer I am typing this on and all works, picks up IP (via DHCP on tp-link) and gets net access.

I think the SmartTV is doing a network test of some sort that the 702N is accidently blocking or altering somehow, perhaps because of the wired->wireless conversion. So even though it is connected, it doesn't think it is.

Will try looking at network traffic to see if I can find out what it is testing.

regards,

Richard
0
0
#3
Options
Re:Samsung SmartTV refuses to accept connection in client mode
2012-12-07 19:25:04
Tried to listen in on network traffic with and without Tp-Link connected to SmartTV. In both cases the TV seems to do some local network discovery (arp queries,
then SSDP stuff), and then to make a http connection to www.samsung.com. For some reason it fails at this point when the tp-link is in use.

Not sure if relevant but the ping & traceroute tools on the TP702N don't work with domain names, seems not to be configured properly to use broadband router for DNS.
But can't see anywhere to configure a DNS server except for DHCP settings.
0
0
#4
Options
Re:Samsung SmartTV refuses to accept connection in client mode
2012-12-09 16:38:51
When tl-wr702N works in client mode, go to Network-->LAN, put in your root router;s LAN ip address as the default gateway. Then try if you can ping with domain name. Because once a time, I experience the same. After I put a the router‘s Ip address, I can ping by use the domain name.
0
0
#5
Options
Re:Samsung SmartTV refuses to accept connection in client mode
2012-12-10 04:20:30
Hi gmail,

gmail wrote

When tl-wr702N works in client mode, go to Network-->LAN, put in your root router;s LAN ip address as the default gateway. Then try if you can ping with domain name. Because once a time, I experience the same. After I put a the router‘s Ip address, I can ping by use the domain name.


Hmm, don't see any option for changing gateway in Network->LAN, only can set IP for the tl-wr702N or change the subnet. Tried setting IP to root router IP address but that just led to the routers fighting over the IP address. Although the SmartTV did at least think it
was now connected to a gateway, but still not on the internet.
0
0
#6
Options
Re:Samsung SmartTV refuses to accept connection in client mode
2012-12-14 08:48:18
Hi, Rdp123, Sorry...I found I got different model with your after you mentioned that you can not change it. I double checked that mine is TL-WA701N.My mistake. How about go to DHCP-->Then put in the gateway and DNS from your router? Not quite sure whether it will work or not. Ummm, this is my only idea.
0
0
#7
Options
Re:Samsung SmartTV refuses to accept connection in client mode
2013-02-10 00:47:40
Hello,

I have the same problem. I'm trying to connect my Samsung TV via tl-wr702N and it doesnt work. Problem appeared only with Samsdung TV and TP-link APC. I've tried to connect samsung via other client and everything was fine with the same configuration. In the other way I've tried to connect tv from other manufacturer via TP-link and again everything was fine.
Can somebody from tech support may answer for this topic? It is common problem and in my opinion it shouldnt happened.
0
0
#8
Options
Re:Samsung SmartTV refuses to accept connection in client mode
2013-03-28 11:09:39
I have the exact same problem with the same configuration, diferent Samsung smart TV model tho.
were you able to solve it?
if so, please share!
Thanks!
0
0
#9
Options
Re:Samsung SmartTV refuses to accept connection in client mode
2013-04-03 16:51:32
Richard, i am interested in your case..i have one suggestion here:
Disable the DHCP on TL-WR702N. since your broadband router has DHCP enabled, it seems necessary to disable DHCP on the client.
Then see if you still are able to control the TV via the Android app operating on the local network..
Or check if you can automatically obtain IP address from your broadband router through the client.
0
0
#10
Options
Re:Samsung SmartTV refuses to accept connection in client mode
2013-04-10 21:05:24
I have the same problem with access point model no TL-WA701ND, my Samsung Smart TV refuse to accept the connection,,, please help
0
0
#11
Options