TL-WR842ND can not install printer server

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
TL-WR842ND can not install printer server
TL-WR842ND can not install printer server
2012-12-09 13:47:50
Region : Vietnam

Model : TL-WR842ND

Hardware Version : V1

Firmware Version :

ISP :


Everything seems so good until I setting up the printer server. Resources CD contains the "USB Print Service Client Setup" but the User Guide said that I have to install "TP-LINK USB Printer Controller Setup".
First, I tried to install "USB Print Service Client Setup", nothing change but a small icon in taskbar allow me to start and stop service, no dialog box said me how to install printer driver.
I look in tp-link website and get "TP-LINK USB Printer Controller Setup", install it but it can not detect my printer. What should I do now because I cannot uninstall "USB Print Service Client Setup"?
0
0
#1
Options
4 Reply
Re:TL-WR842ND can not install printer server
2012-12-09 16:11:12
1. Is your printer in the compatible list of the router? The compatible issue may leads the software not recognize your printer
2. Go to add or remove programmes and then remove the TP-LINK.
3. Hope this link can help U http://www.tp-link.com/en/article/?faqid=415
Wish you good luck.
0
0
#2
Options
Re:TL-WR842ND can not install printer server
2012-12-09 18:09:52
Thanks for your help!
It seems that the software can not detect and connect to the server (or router), when I run it, everything is grey, nothing can do. You can see it in the picture below:
0
0
#3
Options
problem solved
2012-12-10 10:59:35
I got help from local Tp-link support: upgrade firmware and the problem solved.
Thanks all!
0
0
#4
Options
Re:TL-WR842ND can not install printer server
2012-12-11 07:56:43
Wow, I thought that the problem was caused by the antivirus software or the firewall that block the TP-LINK or the software. Updating the firmware solved the problem. Um.... interesting.
0
0
#5
Options