TL-WA901ND forces WPA2-Enterprise mode when using it in AP + WDS Bridge mode

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
TL-WA901ND forces WPA2-Enterprise mode when using it in AP + WDS Bridge mode
TL-WA901ND forces WPA2-Enterprise mode when using it in AP + WDS Bridge mode
2012-12-12 06:32:46
Region : Others

Model : TL-WA901ND

Hardware Version : V2

Firmware Version : 3.12.16 Build 120224 Rel.61005n

ISP :


Dear TP-Link Support and Users,


I have a problem with my new TL-WA901ND when I try to extend my wireless range.

Here's the scenario:
I have a TL-WR941ND router which has Wireless Security set to WPA2-PSK and got a fixed channel.
I set the TL-WA901ND to: Access Point mode, enable WDS/Bridge option, and set everything correctly. It associates to the router and traffic flows fine.

Now I want the AP to have it's own SSID with WPA2-PSK security key (same as the router [or root AP])
When I set Wireless Security mode from Disabled to WPA2-PSK and reboot the AP, all my wireless clients report that the AP is in WPA2-Enterprise mode! (2 laptops, 1 iphone and 1 ipad). So they ask me a username and a password.
I made some screen shots for easier explanation. Please see the attachments.

I believe it's a firmware issue, please fix if you can!


I need to connect to the AP wired and wirelessly also. Repeatering is not an option because bandwidth is important for me.
As a workaround I could use "Bride with AP" mode, but I lose WPA2 encoding functionality.
I could leave encryption disabled and use a MAC filter but that's way unsecure!

(I also have a TL-WR841ND router in the same network which I use for the same purpose as I intend with this new AP. It works just fine with WDS Bridging, but this time I could afford to buy the TL-WA901ND I thought it would be faster and have no issues to set up.)


I hope You can help with this.
Yours,
-Csaba





0
0
#1
Options
5 Reply
Re:TL-WA901ND forces WPA2-Enterprise mode when using it in AP + WDS Bridge mode
2012-12-12 21:49:11
:confused:Not so sure why it acts like that...But I'm a little curious why don't you use the Repeater mode instead of WDS/Bridge to extend the wireless range?
0
0
#2
Options
Re:TL-WA901ND forces WPA2-Enterprise mode when using it in AP + WDS Bridge mode
2012-12-12 22:09:20
It shouldn't act like that because almost the same setup works excellent with my TL-WR841ND. It's weird..this is what a dedicated AP is meant to do.

The main reason is the wireless performance I'm afraid of that makes me not to use it as a repeater. I think it's slower in some cases than using it as a Wireless Bridge. (AP with WDS/Bridge enabled). (Anyway at the moment I'm using it in repeater mode until the problem gets solved)

The second important reason is that I want to have it's own SSID. And the possibility of changing it's Security Key without modifying the Root AP's. This way the network can be segmented a bit and can be more secure.

The third reason is: if anything happens with the Root AP the Repeater can't serve wireless clients anymore, like an AP should. I have a home server connected to the AP so it's services will stop for all the wireless clients connected thru the AP until the Root AP goes online again.


Joy wrote

:confused:Not so sure why it acts like that...But I'm a little curious why don't you use the Repeater mode instead of WDS/Bridge to extend the wireless range?
0
0
#3
Options
Re:TL-WA901ND forces WPA2-Enterprise mode when using it in AP + WDS Bridge mode
2012-12-13 21:42:50
As you said, all my wireless clients report that the AP is in WPA2-Enterprise mode! (2 laptops, 1 iphone and 1 ipad). So they ask me a username and a password.
When it happens, how about wireless security settings, changed or your previous configuration?
0
0
#4
Options
Re:TL-WA901ND forces WPA2-Enterprise mode when using it in AP + WDS Bridge mode
2012-12-14 06:59:43
Hi Mavis,

I tried changing Wireless Security settings, even I reseted the AP, upgraded it's firmware to the same recent version. Tried one older firmware. No use. (I'll try the oldest one in a few minutes, and will see about that)

"No security" and "WEP" key settings work fine, the AP does as set.
But If I choose "WPA-PSK" (no matter if it's WPA1 or WPA2) it goes into WPA-Enterprise mode. If I select WPA-Enterprise by hand it stays WPA-Enterprise.
(Have a look on the 2nd screenshot)

I even tried to configure the connection on the laptops by hand -> couldn't connect. Of course I haven't leave any old settings in the clients.
0
0
#5
Options
Re:TL-WA901ND forces WPA2-Enterprise mode when using it in AP + WDS Bridge mode
2012-12-14 07:11:58
Hey!

I downgraded to wa901nv2_en_3_12_3_up(100723) and now it works!

Thanks Mavis! Without your question I wouldn't think about this.

For the TP-Link developers: this issue still should be fixed!
0
0
#6
Options