UB400 shows as CSR_BTPORT_01 in device manager

UB400 shows as CSR_BTPORT_01 in device manager
UB400 shows as CSR_BTPORT_01 in device manager
2019-11-17 05:05:21

Hi

 

I bought the TP-LINK UB400 Bluetooth 4.0 Nano USB Adapter yesterday got it working perfectly, today I decided to stupidly download the driver for it 

https://www.tp-link.com/au/support/download/ub400/#Driver which was the CSR Harmony Wireless Software Stack.  Then once installed it lost my phone and dongle in bluetooth under windows 10 in Bluetooth and other devices settings, saying Dongle driver is unavailable and Galaxy s9+ Bluetooth is turned off.

In device manager it is under Other Devices as CSR_BTPORT_01, I tried reinstalling using CSR Harmony Wireless Software Stack but it says the CSR Harmony Wireless Software Stack.msi is missing, and search for it but it cannot be found. I have tried letting windows update search for updated drivers through update driver in Device Manager but Windows cannot find drivers for your device. Also I have tried setting CSR_BTPORT_01 as generic bluetooth adapter but gives This Device Cannot Start (Code 10).

 

So I just want to return to before I installed CSR Harmony Wireless Software Stack, I'm thinking I have to do restore point on windows 10 to earlier date.

 

Any help is most welcome.

 

Thanks

0
0
#1
Options
3 Replies
Re:UB400 shows as CSR_BTPORT_01 in device manager
2019-11-26 14:36:31

@kenshin Found it.

 

When manually downloading and isntalling the driver from the TP Link website, some app or service installs called "CSR Harmony" something. This effectively is now the prioritized way of trying to load the UB400 (that's why it loads it under "Other devices" with a CSR_ name, and that all fails. Don't ask me why but basically it gets in the way of plug and play. You have to remove this app/service manually ("Add or remove program" > CSR Harmony) and plug and play will work fine again.

 

0
0
#2
Options
Re:UB400 shows as CSR_BTPORT_01 in device manager
2020-06-06 20:16:47

@kenshin Had the same issue solution was to reinstall/install the driver for the ub400 for windows 7 regardless that i am using windows 10 and then search up the program in add or remove programs to uninstall it and it automatically reinstalled the plug and play drivers that seemed to be missing.(Just putting this here incase anyone else needs it took me a day of troubleshooting to solve)

0
0
#3
Options
Re:UB400 shows as CSR_BTPORT_01 in device manager
3 weeks ago

@Lo averigué contanos de que forma lo resolviste. Estoy teniendo el mismo problemas que comentaron al principio. Dado que el adaptador se empareja al mando de la PS4 y funciono 3 dias no se que ocurrio si fue una actualizacion de Windows 10 que dejo de conectarse y ademas los drivers migraron queda con un triangulito amarillo en el Administrador de Dispositivos y al actualizar controladores no existe....intente bajar el Harmony y no aparece mas la palabra DONGLE y el dibujo del adaptador aparece un auricular y dice error de controlador....como puede pasar esto?

0
0
#4
Options