Deco P9 keeps disconnecting from internet (Red light) but router still has internet

Deco P9 keeps disconnecting from internet (Red light) but router still has internet
Deco P9 keeps disconnecting from internet (Red light) but router still has internet
2019-12-16 17:48:33
Model: Deco P9
Hardware Version:
Firmware Version: 1.0.1

Hi,

 

I recently purchased he Deco P9 system.

 

I first tried to set it up as router mode with my ISP device acting as a modem but I had issues with this as it repeatedly disconnected from the internet.

I decided to instead use the deco system as access points and switch the ISP device to router mode and turn off the wifi on the router.

This worked better than the full mesh system mode however again it is disconnecting from the internet and giving a red light on all deco P9 devices.

However when testing my router it is still working and has internet when connecting via ethernet but the deco does not.

 

Set up:

I currently have a Virgin Hub 3.0 acting as router which is connected to the base P9 deco via ethernet cable. The main deco has an ethernet switch device attached by ethernet to its 2nd ethernet port which has 3 wired devices attached.

The 2 slave P9s are connected via wifi to the main deco.

 

Although the router is still providing interent it seems that turning that off and on get the Deco back up until it disconnects again.

Any help would be appreciated!

1
1
#1
Options
27 Replies
Re:Deco P9 keeps disconnecting from internet (Red light) but router still has internet
2019-12-16 20:14:18

@MBahary I've had the same issues with my Deco P9 in access point mode. My conclusion is that AP mode on the P9s is just broken. You'll need to switch your virgin device to modem/bridge mode and use the Deco P9 in router mode to get it to work.

0
0
#2
Options
Re:Deco P9 keeps disconnecting from internet (Red light) but router still has internet
2019-12-16 20:17:53

@BozMoz 

Hi, I had the same issue if not worse using router mode! That's why I'm struggling with what to do.

0
0
#3
Options
Re:Deco P9 keeps disconnecting from internet (Red light) but router still has internet
2020-03-19 11:21:19

@MBahary 

 

hi. Did you find a solution to this because I am in the EXACT situation as you? I have a virgin superhub 3 also, P9's are setup the same way also. Restart my router and it all works for a very short while and then drops out again.

 

0
0
#4
Options
Re:Deco P9 keeps disconnecting from internet (Red light) but router still has internet
2020-04-13 23:34:21

@MBahary have you figured out?  Having the exact same issue

 

0
0
#5
Options
Re:Deco P9 keeps disconnecting from internet (Red light) but router still has internet
2020-04-18 18:19:06

There is no sollution. Everyone has the same issue and Tp-Link can't fix it. Might be better after a firmware update but if you can return it still i would and get something that's at least stable. 

0
0
#6
Options
Re:Deco P9 keeps disconnecting from internet (Red light) but router still has internet
2020-04-19 11:20:22

@Scoredo just set up the P9 x6 nodes via wired switch and LAN, and as you say the P9 router turns red but the virgin media hub (modem mode) still has internet. Have to reboot the P9 to get it all going again. Don't even need to reboot the virgin hub.  

 

Hoping TP-LINK can assist rather than returning equipment.  The internet speeds and distances have been really good compared to google mesh WiFi and Linksys Velop which I tried out.
 

 

0
0
#7
Options
Re:Deco P9 keeps disconnecting from internet (Red light) but router still has internet
2020-04-19 11:30:57

Hi all,

 

Sorry for the late replies to everyone asking if i fixed it.

So initially as decribed it was in router mode.

After issues i switched to Access Point more witht eh Virgin hub as a router but with wifi off.

I still had issues.

These are the following suggestions TP made which I tried but did NOT work for me, but feel free to try it as it may work:

Try a different ethernet cable - could be faulty cable

Switch the main deco with another to see if it is the individual deco device that is faulty.

 

After doing both of these I still had plenty of issues, I talking cut outs probably at least once a day if not more.

 

Finally they suggested I switch BACK to ROUTER mode.

Seemed pointless to me as that was the first issue that started.

But since then I have had significantly less interent problems (as far as i'm aware, i'm not home all the time). I do still get occasional cut outs but nothing a quick off and on hasn't sorted.

Hope this would be the same for others. essentially try changing to AP mode then back to router mode.

Some additional pionts: My virign hub constantly has a RED light on the bar, don't know why but I do still have internet, only way I know there's no interent other than the obvious is red light on the P9s.

Most my devices are now connected via wifi rather than ethernet as previous (don't know if the ethernet switch device could be an issue that lead to the problems to begin with). I do still have one or two connected via switch though.

 

Hope this helps anyone else especially during lockdown.

0
0
#8
Options
Re:Deco P9 keeps disconnecting from internet (Red light) but router still has internet
2020-05-15 13:49:28 - last edited 2020-05-15 13:49:57

I have the M9 deco system and getting the same also. Ran in AP Mode for a while so Sonos could work! But then had issues still, so run it now in modem mode in my virgin media hub 3 I now get a much better WiFi speed!! But every now and again get no WiFi on certain devices, mainly iPad / iPhones and Sonos! Xbox’s seem solid. I will give it another week of seeing how it goes, and if no good I will be returning this unit and buying the Eero system which seems to be leading the reviews and most important they seem to do regular updates on customer feedback.

0
0
#9
Options
Re:Deco P9 keeps disconnecting from internet (Red light) but router still has internet
2020-06-15 10:09:53

Hi there. Similar issues to everyone above, but thought the recent firmware fix might sort it. No improvement.  Close to sending it all back

0
0
#10
Options
Re:Deco P9 keeps disconnecting from internet (Red light) but router still has internet
2020-06-15 11:25:17

@Stricko I moved to Eero Pro (3 of them) and not had a single problem since !!! getting full speeds all around the house and everything working like a dream.

0
0
#11
Options