TL-WN881ND not working properly on Windows 10.

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

TL-WN881ND not working properly on Windows 10.

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
TL-WN881ND not working properly on Windows 10.
TL-WN881ND not working properly on Windows 10.
2020-03-18 04:09:40 - last edited 2020-03-19 07:58:59
Model: TL-WN881ND  
Hardware Version: V2
Firmware Version: Unsure

I bought the TL-WN881ND so that I could get WiFi to my PC. I have installed the drivers and it does not detect my WiFi network. It does detect a few others at one bar such as the neighbour's network but not mine. This issue is occuring on Windows 10. I booted a live USB of Manjaro Linux to see if it would work there. Manjaro Linux detected it immediately and I was able to visit some websites and use it as intended. Why is it not working on Windows 10?

  0      
  0      
#1
Options
1 Accepted Solution
Re:TL-WN881ND not working properly on Windows 10.-Solution
2020-03-19 07:32:03 - last edited 2020-03-19 07:58:59

@Stella.Q 

 

Hello! You are an ABSOLUTE LEGEND. I changed the channel to 6 and now I can connect to WiFi! Have an amazing morning/day/night.

 

You've made my week.

Recommended Solution
  0  
  0  
#5
Options
6 Reply
Re:TL-WN881ND not working properly on Windows 10.
2020-03-18 06:12:37

@NZgamer 

 

You can adjust some settings on the router, such as change the channel to 1, 6 or 11, the channel with to 40Mhz, then restart the wireless adapter on Windows 10. 

 

If it still not working, try to use the adapter on other slots and reinstall the driver with the link below. 

https://www.tp-link.com/support/download/tl-wn881nd/#Driver

  0  
  0  
#2
Options
Re:TL-WN881ND not working properly on Windows 10.
2020-03-19 02:27:10

@Stella.Q 

 

Changing the WiFi channel will not effect connected devices, right?

  1  
  1  
#3
Options
Re:TL-WN881ND not working properly on Windows 10.
2020-03-19 04:22:18

@NZgamer 

Yes, the connected devices will still be connecting to the wifi.

  0  
  0  
#4
Options
Re:TL-WN881ND not working properly on Windows 10.-Solution
2020-03-19 07:32:03 - last edited 2020-03-19 07:58:59

@Stella.Q 

 

Hello! You are an ABSOLUTE LEGEND. I changed the channel to 6 and now I can connect to WiFi! Have an amazing morning/day/night.

 

You've made my week.

Recommended Solution
  0  
  0  
#5
Options
Re:TL-WN881ND not working properly on Windows 10.
2020-03-19 08:00:33

@NZgamer 

Wow, that's cool~

Glad to hear that it works, congrats.^_^

If need any further help, just let us know.

 

Good day

  0  
  0  
#6
Options
Re:TL-WN881ND not working properly on Windows 10.
2021-12-18 13:49:04 - last edited 2021-12-18 14:21:33

@NZgamer 

 

Hey there, I am an IT tech in Australia and I have found that TP-Link have been distributing US version TL-WN881ND cards in Australia over the last few years (first noticed in 2019 and I have seen more US version cards when I purchased some in the last couple of weeks in the hope they stopped distributing the US ones but frustratingly and obviously haven't).

 

This has caused major headaches for me and a number of my clients that I have supplied these TL-WN881ND US version cards to as the US cards have frequency restrictions in line with US regulations, they can only use and are restricted to channels 1-11 as when used in the United States that is their regulation for use of wireless frequencies.

 

After spending a considerable amount of time investigating wireless issues for a client in 2019 and then concluding that the US version WiFI adapters were the cause of the issue when modems/ gateways/ access points were using channel 12 or 13, I have been forced to spend a considerable amount of time replacing all the US adapters in my client's systems which has seen me lose thousands of dollars in labour and travel costs along with lost revenue to resolve an issue that TP-Link have created.

 

TP-Link have been very uninterested in discussing this US version adapter issue with me and uninterested in substantiating their choice to distribute US version cards in Australia (and clearly haven't stopped distributing the US version adapters at the time of this post), these US version cards are clearly unsuitable for use in Australia and any other countries that allow use of channels 12 and 13.


So I am wondering if you have a US version adapter (US will be on the sticker/ label on the adapter itself) and if so was your WiFi previously set to or was automatically using channel 12 or 13 to minimise interference and therefore the card could not see it due to it's channel restrictions (card can see Channel 1-11 only)? Therefore changing the channel to use channel 6 as you have mentioned worked around the issue?

 

Look forward to hearing from you.

  1  
  1  
#7
Options

Information

Helpful: 0

Views: 8979

Replies: 6

Related Articles