Can't connect when WMM is turned on - TL-WR1403ND

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Can't connect when WMM is turned on - TL-WR1403ND

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Can't connect when WMM is turned on - TL-WR1403ND
Can't connect when WMM is turned on - TL-WR1403ND
2013-01-18 09:17:19
Region : Australia

Model : TL-WR1043ND

Hardware Version : V1

Firmware Version :

ISP :


Hi... YesterdayI got a new TP-Link TL-WR1403ND Wireless N router. And after trying for ages to try to connect my Galaxy Nexus and iPad (both Wireless N devices), I finally called the TP-Link Support.

Both devices could see the wireless, but would never let me join.

Anyway, support told me to try connect a laptop if I had one, which I did (a very old one) and it also could not connect. The first thing the tech got me to do was set the mode from mixed-b/g/n to mixed-b/g. This got it to work, and the tech basically said – there you go, works. But the main reason I got this router was to use wireless n.

Anyway, I told her that was not acceptable, she then told me to set it back and change the security to WPA-PSK (it was WPA2-PSK). I did this and she also told me to disable WMM (had no idea what that was).

Anyway that worked, so I was happy. I then went and change the security back to WPA2, and it still worked. So the main issue stopping me from connecting to the WiFi from my devices was WMM.

So after all that... I looked up WMM, and can see it basically a QoS feature. So why does it not work with my phone, ipad and laptop? I have searched the net, and from what I can see, it is a very Important thing to have WMM turned on. So why won't it work with my devices? All three of them can see the wireless network, I can put the password in, but then they don't connect.

I am on the latest firmware (can't check the actual name and version as I am not at home), so is there something wrong with this particular router? Is it a known problem? Do I have a faulty unit?

Thanks for any responses.
  0      
  0      
#1
Options
6 Reply
Re:Can't connect when WMM is turned on - TL-WR1403ND
2013-01-18 16:20:05
I do not know why, that seems to be quite professional... But I have heard that disable WMM may solve the wireless connection issue between the router and Apple device as well as some smart phone.
  0  
  0  
#2
Options
Re:Can't connect when WMM is turned on - TL-WR1403ND
2013-01-18 16:47:12
Hi Again... I can't read the first reply... now showing up in any characters my computer or phone can recognise... have tried multiple browsers...

Anyway... as far as the iPad not working, I have searched the net, and I have seen a lot of posts in forums etc that suggest iPads require WMM to be enabled for them to work... mine is clearly the opposite... Also, it was not only my iPad and Phone... but my laptop as well...

I'd like to get to the bottom of it... there is nothing on the net anywhere I have seen that suggests the iPad doesn't support it... and I've seen and heard from friends that having it on it highly recommended for Multimedia...

This is the first piece of network hardware I have had that is not a billion product... so I took a jump at using these products since I had no real issues with the Billion products I had used... so far, this issues doesn't fill me with confidence that I have made the right choice...

I'm happy to be corrected and shown otherwise, because I've seen nothing but good reviews about these products. They look good and seem well built. I will be buying some other switches etc when I get my house wired, and the TP-Link switches also look good... but I won't be rushing to get one unless I can either be reassured that this is not something I should be concerned about, or it can be fixed..

Thanks for the replies...
  0  
  0  
#3
Options
Re:Can't connect when WMM is turned on - TL-WR1403ND
2013-01-18 17:07:08
How about enable the WMM and then change the channel on the router? Change the channel to 11 and the channel width to 20mhz to give a try. Form Internet forums, it mentioned that disable wmm can let the ipad keep stable and connect. https://discussions.apple.com/thread/2780293?start=1455&tstart=0
  0  
  0  
#4
Options
Re:Can't connect when WMM is turned on - TL-WR1403ND
2013-01-18 17:15:02
I have already tried numerous channels, as well as dropping the width to 20 MHz... Neither worked...
  0  
  0  
#5
Options
Re:Can't connect when WMM is turned on - TL-WR1403ND
2013-01-21 05:18:08
So does anyone have any idea what the next step is? Do I have a faulty device? I don't really want to call support again, cause they wuill probably just tell me to disable the setting. Should I send back to where I got it from and request that it be replaced? Or exchange it for another brand?
  0  
  0  
#6
Options
Re:Can't connect when WMM is turned on - TL-WR1403ND
2013-02-03 02:42:16
replace another brand.
  0  
  0  
#7
Options

Information

Helpful: 0

Views: 1281

Replies: 6

Related Articles