It is time you TP-Link fix the bugs

It is time you TP-Link fix the bugs
It is time you TP-Link fix the bugs
2020-04-14 11:14:34 - last edited 2020-04-17 13:47:14
Model: RE450
Hardware Version: V3
Firmware Version: RE450(EU)_V3_190124

Do you want to sell your stuff in the EU?    -   Wake up and start fixing your firmware.

 

Literally, i have a RE450. The speed is all over the place, starts with 150 Mbit in high speed mode (ISP 300/15), degrades over time down to 50 Mbit then 20 Mbit.

 

The extender is somehow "nuking" the router. The connected frequency (2.4G / 5G) becomes useless after two weeks and requires router to be restarted. No, this is not "brand xyz issue, they need to fix it". I have tried 3 routers, bougth a brand new 1 Ghz dual core 128 MB ram router. It is more than enough in performance, yet your sweet little extender is able to make it choke and 5G wifi stops working.

 

Yes, I am on latest firmware,  Yes my router is on latest firmware. I have been debugging and trying to fix this myself since i have bought the device. 

 

I can help with debugging or whatver, just please start fixing your bugs. I do not care about your "tested in our lab environment - it is working" excuse, do you even use your orwn products at your own home?    We consumers do not have your "fancy little lab environment" in our houses, so the real world use is different from what you guys are "testing".

 

If you do not care, at least make it open source so good people at OpenWRT or tomato forks can make use of it.

 

EDIT:  And it took just 4 hours to degrade down to 60 Mbit. Nice...

1
1
#1
Options
4 Reply
Re:It is time you TP-Link fix the bugs
2020-04-15 13:28:35

Adding one other bug. Repeater does not use its own MAC adress for 5GHz connection, but clones the first connected device.

 

I have reserved the repeater MAC-s in DHCP Server, 50:6C to .100 and 56:6D to .101

I reboot the router and plug in the extender, at first, it lists up with correct IP in attached devices (.100), but after the first device connects to the repeater, it "clones" its IP and MAC adress in the list of connected devices.

 

List of devices in access control to view them all. DC:1B is the first connected device to the extender, router DHCP assigns it a correct IP, but repeater clones its IP adress regardless defining it to use .101 in DHCP reservation. 

 

Router log shows that the repeater connects with MAC 50:6C, then DC:1B connects. Which looks good, but then you can see the repater MAC 56:6D never connecting, but using the IP for DC:1B.  My setup is that repeater connects with 5G and boardcasts 2G, hence, it should be 56:6D connecting. 

 

Down the line, this causes two devices on the DHCP Server with shared IP and different MAC-s. This is not how it is supposed to be I hope?   

Every DHCP lease renewal starts to call multiple times on DHCP for IP adress, and causing it to choke after a week or two. Please attend to this issue.

1
1
#2
Options
Re:It is time to add some function
2021-05-22 17:02:51

@TheHaso please add Sleeping mode in my router firewall (wr845n) un version. In tenda router it is available. It is important for save our family from wifi rendition at night. 

 

0
0
#3
Options
Re:It is time you TP-Link fix the bugs
2021-06-08 20:02:51
Excellent investigation job! What a pitty TP-Link didn't care to reply or fix
0
0
#4
Options
Re:It is time you TP-Link fix the bugs
2021-06-11 08:13:08 - last edited 2021-06-11 08:34:23

@Matu.ar 

 

RE450 V3 has released some new firmware since thread was created. If your device also has similar issue, make sure your RE is on the latest firmware: 
https://www.tp-link.com/support/download/re450/

 

0
0
#5
Options