Help needed restoring stock firmware of Archer C60 V3 using TFTP

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Help needed restoring stock firmware of Archer C60 V3 using TFTP

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Help needed restoring stock firmware of Archer C60 V3 using TFTP
Help needed restoring stock firmware of Archer C60 V3 using TFTP
2020-05-10 17:50:37
Model: Archer C60  
Hardware Version: V3
Firmware Version: 190115

I've tried using OpenWrt and when I wanted to go back to stock it didn't go so well ;)

 

I've setup a TFTP server and downloaded the firwmare for my EU Archer C60 V3 from https://www.tp-link.com/no/support/download/archer-c60/v3/#Firmware and extracted and renamed the bin to tp_recovery.bin. In the serial log it complains about the firmware version. I'm clueless what to do since that IS the correct version for my router. Please see log dump below. Any help really appreciated!

 

Using eth1 device
TFTP from server 192.168.0.66; our IP address is 192.168.0.86
Filename 'tp_recovery.bin'.
Load address: 0x80800000
Loading: #################################################################
     #################################################################
     #################################################################
     #################################################################
     #################################################################
     #################################################################
     #################################################################
     #################################################################
     #################################################################
     #################################################################
     #################################################################
     #################################################################
     #################################################################
     #################################################################
     #################################################################
     #################################################################
     #################################################################
     #################################################################
     #################################################################
     #################################################################
     #################################################################
     #################################################################
     #################################################################
     #################################################################
done
Bytes transferred = 7982768 (79ceb0 hex)
Firmware recovery: FLASH_SIZE = 8 filesize = 0x79ceb0.
Reading Partition Table from NVRAM ... OK

Parsing Partition Table ... OK

File Length:7982768
fw type name : Cloud.
Firmware process common.

Image verify OK!

Firmware file Verify ok!

[Error]sysmgr_proinfo_buildStruct():  647 @ unknown id(device_name), skip it.
[Error]sysmgr_proinfo_buildStruct():  540 @ should be 2 args (1).
[Error]sysmgr_cfg_checkSupportList():  971 @ 00000000 NOT Match.

Firmwave supports, check OK.

 (curFw_ver, newFw_ver) == (3.0, 1.0)

[NM_Error](nm_checkSoftVer) 00960: Firmwave not supports, check failed.

[NM_Error](nm_checkUpdateContent) 01182: the firmware software version dismatched

[NM_Error](nm_buildUpgradeStruct) 01274: checkUpdateContent failed.

Firmware Invalid!

U-Boot 1.1.4-gd490e1c1-dirty (Aug 21 2019 - 18:44:04)

ap151 - Dragonfly 1.0

DRAM:  64 MB
Top of RAM usable for U-Boot at: 84000000
Reserving 402k for U-Boot at: 83f98000
Reserving 32832k for malloc() at: 81f88000
Reserving 44 Bytes for Board Info at: 81f87fd4
Reserving 36 Bytes for Global Data at: 81f87fb0
Reserving 128k for boot params() at: 81f67fb0
Stack Pointer at: 81f67f98
Now running in RAM - U-Boot at: 83f98000
Flash Manuf Id 0xef, DeviceId0 0x40, DeviceId1 0x17
flash size 8MB, sector count = 128
Flash:  8 MB
Using default environment

In:    serial
Out:   serial
Err:   serial
Net:   ath_gmac_enet_initialize...
No valid address in Flash. Using fixed address
No valid address in Flash. Using fixed address
ath_gmac_enet_initialize: reset mask:c02200
Dragonfly----> S27 PHY *
: cfg1 0x80000000 cfg2 0x7114
eth0: 00:03:7f:09:0b:ad
athrs27_phy_setup ATHR_PHY_CONTROL 4 :1000
athrs27_phy_setup ATHR_PHY_SPEC_STAUS 4 :10
eth0 up
ATHRS27: resetting s27
ATHRS27: s27 reset done
: cfg1 0x800c0000 cfg2 0x7214
eth1: 00:03:7f:09:0b:ad
athrs27_phy_setup ATHR_PHY_CONTROL 0 :1000
athrs27_phy_setup ATHR_PHY_SPEC_STAUS 0 :50
athrs27_phy_setup ATHR_PHY_CONTROL 1 :1000
athrs27_phy_setup ATHR_PHY_SPEC_STAUS 1 :50
athrs27_phy_setup ATHR_PHY_CONTROL 2 :1000
athrs27_phy_setup ATHR_PHY_SPEC_STAUS 2 :50
athrs27_phy_setup ATHR_PHY_CONTROL 3 :1000
athrs27_phy_setup ATHR_PHY_SPEC_STAUS 3 :50
eth1 up
eth0, eth1
Setting 0x181162c0 to 0x82
Reading Partition Table from NVRAM ... OK

Parsing Partition Table ... OK

factory boot check integer ok.

load fs uboot at 0x10000.
Autobooting in 1 seconds
## Starting application at 0x80010000 ...

U-Boot 1.1.4-gd490e1c1-dirty (Aug 21 2019 - 18:43:52)

ap151 - Dragonfly 1.0

DRAM:  64 MB
Top of RAM usable for U-Boot at: 84000000
Reserving 120k for U-Boot at: 83fe0000
Reserving 32832k for malloc() at: 81fd0000
Reserving 44 Bytes for Board Info at: 81fcffd4
Reserving 36 Bytes for Global Data at: 81fcffb0
Reserving 128k for boot params() at: 81faffb0
Stack Pointer at: 81faff98
Now running in RAM - U-Boot at: 83fe0000
Flash Manuf Id 0xef, DeviceId0 0x40, DeviceId1 0x17
flash size 8MB, sector count = 128
Flash:  8 MB
Using default environment

In:    serial
Out:   serial
Err:   serial
Net:   ath_gmac_enet_initialize...
No valid address in Flash. Using fixed address
No valid address in Flash. Using fixed address
ath_gmac_enet_initialize: reset mask:c02200
Dragonfly----> S27 PHY *
: cfg1 0x80000000 cfg2 0x7114
eth0: 00:03:7f:09:0b:ad
athrs27_phy_setup ATHR_PHY_CONTROL 4 :1000
athrs27_phy_setup ATHR_PHY_SPEC_STAUS 4 :10
eth0 up
ATHRS27: resetting s27
ATHRS27: s27 reset done
: cfg1 0x800c0000 cfg2 0x7214
eth1: 00:03:7f:09:0b:ad
athrs27_phy_setup ATHR_PHY_CONTROL 0 :1000
athrs27_phy_setup ATHR_PHY_SPEC_STAUS 0 :10
athrs27_phy_setup ATHR_PHY_CONTROL 1 :1000
athrs27_phy_setup ATHR_PHY_SPEC_STAUS 1 :10
athrs27_phy_setup ATHR_PHY_CONTROL 2 :1000
athrs27_phy_setup ATHR_PHY_SPEC_STAUS 2 :50
athrs27_phy_setup ATHR_PHY_CONTROL 3 :1000
athrs27_phy_setup ATHR_PHY_SPEC_STAUS 3 :10
eth1 up
eth0, eth1
Setting 0x181162c0 to 0x82
Hit any key to stop autoboot:  0
## Booting image at 9f030000 ...
Bad Magic Number
ath>
  0      
  0      
#1
Options
5 Reply
Re:Help needed restoring stock firmware of Archer C60 V3 using TFTP
2020-05-29 05:34:31

@HeinDuPlessis how did you make it boot from tftp?! I cann't do this .

  0  
  0  
#2
Options
Re:Help needed restoring stock firmware of Archer C60 V3 using TFTP
2020-05-29 06:35:09

@omar1 I turned it off, held down the reset button at the back, then switched on, kept the reset button in for about 3 seconds until I see it starts to load on the serial output and the tftp app.

  0  
  0  
#3
Options
Re:Help needed restoring stock firmware of Archer C60 V3 using TFTP
2020-05-29 07:17:56

@HeinDuPlessis 

HeinDuPlessis wrote

@omar1 until I see it starts to load on the serial output and the tftp app. 

 that means  I must use serial port?

is there is way to use  netowrk port?

  0  
  0  
#4
Options
Re:Help needed restoring stock firmware of Archer C60 V3 using TFTP
2020-07-17 18:52:49

@HeinDuPlessis any success??

  0  
  0  
#5
Options
Re:Help needed restoring stock firmware of Archer C60 V3 using TFTP
2020-07-17 19:13:19
Unfortunately not
  0  
  0  
#6
Options

Information

Helpful: 0

Views: 3434

Replies: 5