Deco M4 on Deutsche Telekom fibre optic modem connection (FTTH) - PPPoE and VLAN settings

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Deco M4 on Deutsche Telekom fibre optic modem connection (FTTH) - PPPoE and VLAN settings
Deco M4 on Deutsche Telekom fibre optic modem connection (FTTH) - PPPoE and VLAN settings
2020-07-30 08:58:12 - last edited 2020-07-30 09:25:09
Model: Deco M4
Hardware Version: V2
Firmware Version: 1.4.0

Hi community, 

 

we are trying to get our new Deco M4 working on our Deutsche Telekom fibre optic connection (Telekom fibre modem is installed an working) in Germany. 

For this, I have attached the M4 directly to the fibre modem, I tried both M4 LAN ports 1/2. 
 
For Internet access I have configured PPPoE with typical username combination for Deutsche Telekom (AnschlusskennungZugangsnummer#Mitbenutzernummer@t-online.de and password). I tried different combinations for the username, all to no avail (e.g. some forums say leave out @t-online.de at the end) -it just doesn't connect. 

What am I missing? Do I have to set Deutsche Telekom specific ´VLAN ID 7' on the M4 LAN ports, which some forums suggest? How do I do that on the M4? 

In the Deco M4 logs I can see that VLAN IDs are set to 1 and 2: 
Sun Jun 28 07:30:31 2020 user.info root: whc (repacd): do __repacd_del_vlan_interfaces network:lan vlan id:1 backhual_iface:plc
....
Sun Jun 28 07:30:31 2020 user.info root: whc (repacd): do __repacd_del_vlan_interfaces network:lan vlan id:2 backhual_iface:plc

....


On PPPoE connection attempt, I can see this: 

Sun Jun 28 07:31:40 2020 user.debug ppp: start pppd,user (aus Datenschutzgründen entfernt)@t-online.de password 12345678 mtu 1480 mru 1480
Sun Jun 28 07:31:40 2020 user.debug netifd: ubus  call network.interface notify_proto { "action": 1, "command": [ "\/usr\/sbin\/pppd", "nodetach", "ifname", "pppoe-internet", "ipparam", "internet", "lcp-echo-interval", "10", "lcp-echo-failure", "5", "nodefaultroute", "noaccomp", "nopcomp", "usepeerdns", "maxfail", "1", "user", "(aus Datenschutzgründen entfernt)@t-online.de", "password", "12345678", "ip-up-script", "\/lib\/netifd\/ppp-up", "ipv6-up-script", "\/lib\/netifd\/ppp-up", "ip-down-script", "\/lib\/netiSun Jun 28 07:31:40 2020 daemon.info pppd[7750]: pppoe_init() success
Sun Jun 28 07:31:40 2020 daemon.notice netifd: internet (7750): pppoe_init() success
Sun Jun 28 07:31:40 2020 daemon.notice pppd[7750]: PPPoE DevName Hook, the name is nic-br-wan 
Sun Jun 28 07:31:40 2020 daemon.notice netifd: internet (7750): PPPoE DevName Hook, the name is nic-br-wan
Sun Jun 28 07:31:40 2020 daemon.notice pppd[7750]: make the channel with pppoe_channel
Sun Jun 28 07:31:40 2020 daemon.notice netifd: internet (7750): make the channel with pppoe_channel
Sun Jun 28 07:31:40 2020 daemon.notice pppd[7750]: PPPoE DevName Hook, the name is nic-br-wan
Sun Jun 28 07:31:40 2020 daemon.notice netifd: internet (7750): PPPoE DevName Hook, the name is nic-br-wan
Sun Jun 28 07:31:40 2020 daemon.notice netifd: internet (7750): Command failed: Not found
Sun Jun 28 07:31:40 2020 daemon.info pppd[7750]: Using interface ppp0
Sun Jun 28 07:31:40 2020 daemon.info pppd[7750]: main 480 ipv4 = 0 ipv6 = 0
Sun Jun 28 07:31:40 2020 daemon.notice pppd[7750]: pppd 2.4.3 started by root, uid 0
Sun Jun 28 07:31:40 2020 daemon.notice netifd: internet (7750): Using interface ppp0
Sun Jun 28 07:31:40 2020 daemon.notice netifd: internet (7750): main 480 ipv4 = 0 ipv6 = 0
Sun Jun 28 07:31:40 2020 daemon.notice netifd: internet (7750): Command failed: Not found
Sun Jun 28 07:31:40 2020 daemon.notice pppd[7750]: PPPoE Connect Device
Sun Jun 28 07:31:40 2020 daemon.info pppd[7750]: Sent PADT
Sun Jun 28 07:31:40 2020 daemon.notice netifd: internet (7750): PPPoE Connect Device
Sun Jun 28 07:32:01 2020 cron.info crond[6784]: crond: USER root pid 7902 cmd /sbin/pctl_log_update
Sun Jun 28 07:32:01 2020 cron.info crond[6784]: crond: USER root pid 7903 cmd /usr/sbin/smart_home_schedule
Sun Jun 28 07:32:05 2020 daemon.info udhcpd[4994]: fscanf_num:3 device_mac:(aus Datenschutzgründen entfernt) device_ip:(aus Datenschutzgründen entfernt) device_hostname:handy
Sun Jun 28 07:32:05 2020 daemon.err udhcpd[4994]: Sending ACK to (aus Datenschutzgründen entfernt)
Sun Jun 28 07:32:05 2020 daemon.err udhcpd[4994]: clear ip c0a84464
Sun Jun 28 07:32:15 2020 daemon.notice netifd: internet (7750): Command failed: Not found
Sun Jun 28 07:32:16 2020 daemon.err pppd[7750]: Unable to complete PPPoE Discovery

.... 

 

Many thanks - this is a repost of my original post in German today. 

0
0
#1
Options
2 Reply
Re:Deco M4 on Deutsche Telekom fibre optic modem connection (FTTH) - PPPoE and VLAN settings
2020-07-31 20:28:09

I fixed it - had to set VLAN ID 7 for Internet VLAN as follows on Advanced settings - worked flawlessly after: 

 

 

 

1
1
#2
Options
Re:Deco M4 on Deutsche Telekom fibre optic modem connection (FTTH) - PPPoE and VLAN settings
2020-08-09 10:07:38
Worked for me, too. Dank3
0
0
#3
Options