Devices disconnecting from deco M9

Devices disconnecting from deco M9
Devices disconnecting from deco M9
2020-08-11 14:14:45
Hardware Version: V1
Firmware Version: 1.4.0

Hello, for like 2 or 3 months, some of my wifi devices from Xiaomi, after they updated their firmwares, starting to have trouble connecting to my network, they connect but after few seconds disconnect, then after half a minute reconnect and so on.

By that time i think there was some deco firmware update. Xiaomi for at least 2 devices already updated the firmware maybe 3 times but still having same problem.

Any idea of what i can try? I think Deco lacks a lot of options in settings like other routers have. It would be really bad if i had to change my routers again ....

Any ideas i can try?

0
0
#1
Options
18 Replies
Re:Devices disconnecting from deco M9
2020-08-11 19:36:32
Disable Fast Roaming under the Advanced tab in the DECO APP
0
0
#2
Options
Re:Devices disconnecting from deco M9
2020-08-12 00:25:09

@Saurabh_S 

Thank you i will try that again.

I think i tried before but for a short time.

 

thanks

0
0
#3
Options
Re:Devices disconnecting from deco M9
2020-08-12 15:45:21

@Saurabh_S 

i tried disabling gast roaming, reset the device and setup again, same thing happening 😞

0
0
#4
Options
Re:Devices disconnecting from deco M9
2020-08-12 22:10:58

@Artur88Macau 

Try disabling the 5 Ghz network and see if the xiaomi devices connect to 2.4. Once you disable 5 Ghz band, reboot all the routers and Mi devices. 

0
0
#5
Options
Re:Devices disconnecting from deco M9
2020-08-13 00:59:39

@Saurabh_S 

Thank you again for your help.

I believe i tried that before, will give it another try. The devices connect to 2.4 even if the 5 is on, but will disconnect after few seconds and will keep on connecting and disconnecting.

 

Tonight I'll try again and report here the results.

 

thank uou

0
0
#6
Options
Re:Devices disconnecting from deco M9
2020-08-14 04:53:09

@Saurabh_S 

hello again, last night i tried disabling the 5ghz, same thing happens.

even tried disabling bean forming, and fast roaming, always reset the devices and in thw end always get the same res

0
0
#7
Options
Re:Devices disconnecting from deco M9
2020-08-14 06:00:34

@Artur88Macau 

I'm having the same problem on the M4. Installed about a week ago and was working fine, then did a firmware update and the Internet kept intermittently cutting out and cutting back in every couple of minutes. I did a full system reset which fixed the problem. Did another firmware update last night though and the problem has come back again. Any ideas on how to permanently fix? 

0
0
#8
Options
Re:Devices disconnecting from deco M9
2020-08-14 08:22:03

@jonny174 

what did you install a week ago? 
and when u say u did a full system reset, are you talking about the M4 or your other devices?

0
0
#9
Options
Re:Devices disconnecting from deco M9
2020-08-14 08:26:50

@Artur88Macau 

 

OK.. Let's try this. 

Create a Hotspot on your mobile with the same name as your wifi. 

Forget the WiFi password in the Xiaomi devices. 

Switch off all the decos and connect the xiaomi devices to your Hotspot. 

Check and see if the device still connects and disconnects. 

 

If the device still connects/disconnects even with the Hotspot, problem lies with your xiaomi device. 

If not, then we have at least isolated the issue with the router. 

 

Reset the entire deco network and create a new network with new SSID and then try again. 

 If still your problem persists, then request Tp-Link to address the issue directly. 

0
0
#10
Options
Re:Devices disconnecting from deco M9
2020-08-14 08:28:30

firmware 1.4.2 was released few days ago for M9.

per TP-Link release notes - "Improved stability, security and performance"

 

try to upgrade and see if it helps.

0
0
#11
Options