Archer C6 V2.0 2.4Ghz Wi-Fi problems after latest firmware update

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Archer C6 V2.0 2.4Ghz Wi-Fi problems after latest firmware update

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Archer C6 V2.0 2.4Ghz Wi-Fi problems after latest firmware update
Archer C6 V2.0 2.4Ghz Wi-Fi problems after latest firmware update
2020-08-30 08:02:42 - last edited 2020-08-30 15:23:53
Model: Archer C6  
Hardware Version: V2
Firmware Version: 1.3.5 Build 20200630 rel.57406(4555)

Hello,

 

I created a thread to bring this issue to the light. I received a firmware update a week or so ago on my Archer C6 V2.0 and since then the 2.4Ghz band is broken. It drops sometimes, it doesn't connect, gives password incorrect error to all devices. 

 

It is also causing my WDS bridged device to drop connection and/or causes IP configuration failure whenever the 2.4Ghz band stops working for no reason. 

 

Is there a fix to this? Is anyone with the same router facing a similar issue with the 2.4Ghz band? 

 

The 5Ghz band and LAN internet are all fine BTW.

  1      
  1      
#1
Options
1 Accepted Solution
Re:Archer C6 V2.0 2.4Ghz Wi-Fi problems after latest firmware update-Solution
2020-08-30 15:17:36 - last edited 2020-08-30 15:23:53

@RedIndianRobin 

 

You are not alone with this issue.

Here is all you want know:

 

TP-Link Forum

 

 

 

Archer AX73(EU)V1 in Router Mode to use OneMesh with RE300 (used as AP only)
Recommended Solution
  0  
  0  
#2
Options
2 Reply
Re:Archer C6 V2.0 2.4Ghz Wi-Fi problems after latest firmware update-Solution
2020-08-30 15:17:36 - last edited 2020-08-30 15:23:53

@RedIndianRobin 

 

You are not alone with this issue.

Here is all you want know:

 

TP-Link Forum

 

 

 

Archer AX73(EU)V1 in Router Mode to use OneMesh with RE300 (used as AP only)
Recommended Solution
  0  
  0  
#2
Options
Re:Archer C6 V2.0 2.4Ghz Wi-Fi problems after latest firmware update
2020-08-30 15:23:46

@aTOMic1971 

 

Oh wow! 6 weeks since this issue surfaced? Guess we all wait for a firmware update from TP-Link then. Glad to know that they're atleast aware of it.

  0  
  0  
#3
Options

Information

Helpful: 1

Views: 2122

Replies: 2