Archer AC1300 T4U - new device instability, ping spikes, device unusable.

Archer AC1300 T4U - new device instability, ping spikes, device unusable.
Archer AC1300 T4U - new device instability, ping spikes, device unusable.
2020-09-20 13:25:53 - last edited 2020-09-20 17:21:10
Model: Archer T4U
Hardware Version: V3
Firmware Version: 1030.22.202.2018

Hi,

 

I bought this device to replace old WN422G that was great, but disconnects when overheated/full speed download. Since it is 10+ years old it it had to go. So I bought T4U that was marked as "Successor" of good old reliable WN422G. 

 

And then dissaster happened. 

http://prntscr.com/ukjbdz

 

Look at that ping, look at that performance disaster. Stick is 2 meters from router. Tried installing older drivers as well, it did not help. Works just fine with WN422G when not overheated.

 

Advise please and fix as soon as possible!

 

 

0
0
#1
Options
4 Replies
Re:Archer AC1300 T4U - new device instability,ping spikes, device unusable.
2020-09-20 13:32:04 - last edited 2020-09-20 13:32:58

Little update, I detected this device is Realtek RTL8812AU, so I found old realtek drivers (Realtek_WindowsDriver_1030.25.0701.2017Realtek_WindowsDriver_1030.25.0701.2017) for it and it is little better: 

 

http://prntscr.com/ukjqda 

 

It is still not good as I have 13% packet loss, but it is a little better. TP-link please provide me with WORKING drivers. 

0
0
#2
Options
Re:Archer AC1300 T4U - new device instability,ping spikes, device unusable.
2020-09-23 01:33:48

@Vulisha 

Good day.

Sorry for the delay.

Please try to install the following driver to have a look:

For USB Wireless Adapter:

https://static.tp-link.com/2020/202006/20200608/1160648_0521_RTLWlanU_WindowsDriver_41_RegFastDMSWPeriod.zip

 

Note, before installing, the customer needs to disable the driver sign as below link:

https://community.tp-link.com/en/home/stories/detail/383

 

Thank you very much.

0
0
#3
Options
Re:Archer AC1300 T4U - new device instability,ping spikes, device unusable.
2020-09-23 13:27:27 - last edited 2020-09-23 13:49:52

@Kathy_Z 

 

Thank you for your help. I have the same device with the same issues and I've tried that driver you've posted; however, it has the same problem that the official one does where Windows will continuously play the 'device disconnected' sound and the device will not work. I tried unplugging and replugging it a couple of times (that sometimes works with the official driver) but after 8 attempts it still continued to not work and Windows was yelling at me to restart so I did.

 

Restarting the computer made Windows go back to the Microsoft generic drivers but after unplugging and replugging the dongle the new drivers were loaded and Windows didn't freak out. Unfortunately it seems like the driver doesn't work at all anyways: The adapter will simply show as disabled in Windows and when enabled it will just remain disabled. If it's any help the lights on the adapter also don't work when using that driver. Windows detects the device and it shows on Device Manager but otherwise its completely dead.

0
0
#4
Options
Re:Archer AC1300 T4U - new device instability,ping spikes, device unusable.
2020-09-24 10:36:38

@Kathy_Z I installed this drivers importunately it did not help, actually it made things worse a bit :( 

http://prntscr.com/un06ja

 

Are there any other drivers that I could try out?

0
0
#5
Options