MIMO for Archer c60 v2

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

MIMO for Archer c60 v2

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
MIMO for Archer c60 v2
MIMO for Archer c60 v2
2020-09-27 14:07:44 - last edited 2020-09-30 16:27:30
Model: Archer C60  
Hardware Version: V2
Firmware Version: 2.0.0 Build 20161206 rel.60287

I have been using c60 v2 for past two years without any issue. The new v3 version has MU-MIMO in it. Since MU-MIMO is a protocol and not a hardware feature, can I flash v3 firmware on my v2 router? Or is there any development in progress for an updated firmware of v2 having MU-MIMO option enabled?

  0      
  0      
#1
Options
1 Accepted Solution
Re:MIMO for Archer c60 v2-Solution
2020-09-30 10:20:58 - last edited 2020-09-30 16:27:30

@Dib 

 

"TP-Link Archer C60 v3 is a dual-band AC1350 router, based on Qualcomm/Atheros QCA9561 + QCA9886.

It seems to be identical to the v2 revision, except that it lacks a WPS LED and has different GPIO for amber WAN LED."

 

"

In contrast to earlier revisions (v2), the v3 contains the (same)
MAC address twice, once in 0x1fa08 and again in 0x1fb08.
While the partition-table on the device refers to the latter, the
firmware image contains a different partition-table for that region:

name           device            firmware
factory-boot   0x00000-0x1fb00   0x00000-0x1fa00
default-mac    0x1fb00-0x1fd00   0x1fa00-0x1fc00
pin            0x1fd00-0x1fe00   0x1fc00-0x1fd00
product-info   0x1fe00-0x1ff00   0x1fd00-0x1ff00
device-id      0x1ff00-0x20000   0x1ff00-0x20000.

"

 

Flashing FW for different HW version may brick your device so I wouldn't recommend doing that unless you decide to experiment at your responsibility.

If this was helpful click once on the arrow pointing upward. If this solves your issue, click once the star to mark it as a "Recommended Solution".
Recommended Solution
  1  
  1  
#2
Options
2 Reply
Re:MIMO for Archer c60 v2-Solution
2020-09-30 10:20:58 - last edited 2020-09-30 16:27:30

@Dib 

 

"TP-Link Archer C60 v3 is a dual-band AC1350 router, based on Qualcomm/Atheros QCA9561 + QCA9886.

It seems to be identical to the v2 revision, except that it lacks a WPS LED and has different GPIO for amber WAN LED."

 

"

In contrast to earlier revisions (v2), the v3 contains the (same)
MAC address twice, once in 0x1fa08 and again in 0x1fb08.
While the partition-table on the device refers to the latter, the
firmware image contains a different partition-table for that region:

name           device            firmware
factory-boot   0x00000-0x1fb00   0x00000-0x1fa00
default-mac    0x1fb00-0x1fd00   0x1fa00-0x1fc00
pin            0x1fd00-0x1fe00   0x1fc00-0x1fd00
product-info   0x1fe00-0x1ff00   0x1fd00-0x1ff00
device-id      0x1ff00-0x20000   0x1ff00-0x20000.

"

 

Flashing FW for different HW version may brick your device so I wouldn't recommend doing that unless you decide to experiment at your responsibility.

If this was helpful click once on the arrow pointing upward. If this solves your issue, click once the star to mark it as a "Recommended Solution".
Recommended Solution
  1  
  1  
#2
Options
Re:MIMO for Archer c60 v2
2020-09-30 16:28:41
Thanks a lot @Ivaylo for your detailed analysis.
  0  
  0  
#3
Options

Information

Helpful: 0

Views: 925

Replies: 2

Related Articles