Deco M5 - Very Poor performance when an M5 does not connect directly to the 'Main Deco'.

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Deco M5 - Very Poor performance when an M5 does not connect directly to the 'Main Deco'.
Deco M5 - Very Poor performance when an M5 does not connect directly to the 'Main Deco'.
2020-10-27 10:41:53
Model: Deco M5
Hardware Version: V3
Firmware Version: 1.4.9 Build 20200924 Rel. 60170

Hi. I started with 3 M5's. These seemed to work very well and I was really impressed by them. My house is an odd layout and is very long. I purchased another 3 so have 6 M5's in total. In the past couple of weeks or so, performance has been terrible\un-useable. I have spent ages resetting them and starting from scratch. When the performance is terrible, If I disconnect the M5 from my Sky Router, and test my ISP directly (either cabled or Wifi) then performance is normal (I only get about 10MB down, 0.5 up and a ping of around 30ms normally). When I have the issues (connected to the M5's) the ping goes up anywhere between 600-900ms and the download can be less than 1 MB.

 

I am a bit suspicious of the recent firmware update that was released on (2020-10-09) and would like to have tested downgrading. Even if I download the previous version (Deco M5(EU)_V3_200725), when I attempt to apply it via the Web interface, it says successful but does not downgrade. I guess tp-link have stopped the ability for users to downgrade firmware.

 

Also one other interesting thing I have noticed is performance is very very poor if one of my M5's is connected to Another M5 and that is then connected to the 'Main Deco'. If I turn off the 'middle' M5' and so forcing the M5 to connect directly to the 'Main Deco' performance generally feels a lot better then. But I wanted to cover the whole house and as soon as I power  any 'middle' ones back on, the furthest ones connect via them and performance plummets.

 

Any help is appreciated. I have spent hours on them now and am on the verge of just sending them back and going back to power-lines. I only have 1 day left to return them to Amazon.

 

Thanks

Tony

0
0
#1
Options