UE330(UN) Version 2.0 USB to Ethernet Adapter not being recognized all the time

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
UE330(UN) Version 2.0 USB to Ethernet Adapter not being recognized all the time
UE330(UN) Version 2.0 USB to Ethernet Adapter not being recognized all the time
2020-11-02 20:08:10 - last edited 2020-11-02 20:24:02
Model: UE330
Hardware Version: V2
Firmware Version: unknown

Hello World.

 

I have the UE330(UN) Version 2.0 USB to Ethernet Adapter and it is not being recognized all the time. The adapter is not being recognized as an ethernet adapter, but the usb ports are working fine. On Windows 10 I have downloaded and installed the driver using the file:

 

Win10 Auto Installation Program (SId:1152921505691704020) 10.39.20 2020/10/13

10 MB

 

 located at Tp Link Supports download page.

 

The adapter is recognized sometimes after a long wait after plugging it in.

I have tried removing the adapter and unplugging the ethernet cable, then plugging in the adapter, then plugging in the ethernet cable, every once in a while it will start working suddenly, usually after running the installation software as administrator and fiddling with it, plugging in and out more.

I have also tried rebooting the computer, and again, the adapter is not recognized.

Also this happens after the computer wakes from sleep mode.

 

In the Windows 10 Device Manager the adapter does not show up under Network Adapters until some fiddling with the adapter as described above makes it show up.

 

Please advise. Thank you.

 

 

2
2
#1
Options
1 Reply
Re:UE330(UN) Version 2.0 USB to Ethernet Adapter not being recognized all the time
2020-11-04 03:38:59
0
0
#3
Options