Deco M5 ethernet backhaul limited to 100mps

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Deco M5 ethernet backhaul limited to 100mps
Deco M5 ethernet backhaul limited to 100mps
2020-11-23 12:46:38 - last edited 2020-11-26 11:12:54
Model: Deco M5
Hardware Version: V3
Firmware Version: 1.5.1

So I just set up my 3 deco m5 mesh points.

I have 1Gbps fibre and am getting 400+ over wifi from the main deco which connects to the modem. 

 

I then connected the second deco upstairs via a Cat 6 ethernet cable (for ethernet backhaul). 

 

The last deco is on wireless backhaul, also upstairs. 

 

It seems the deco that is using the ethernet backhaul is limited to 100mbps, both any devices connected by wifi, or directly via ethernet. 

 

I am even getting higher speeds from the deco running on wireless backhaul.

 

Is there some kind of limitation on the ethernet backhaul? I was under the impression that all ports are gigabit ethernet. 

 

 

PS. It's not the cable, I was using the exact same cable previously with my PC and getting 850+ mbps. I only use Cat 6 cables. 

0
0
#1
Options
1 Accepted Solution
Re:Deco M5 ethernet backhaul limited to 100mps-Solution
2020-11-25 16:11:56 - last edited 2020-11-26 11:12:54

@Alexandre. 
 

In the end it was indeed the cable. Even though it was working at 1gbls for every other device, the deco couldn't negotiate at 1gbps on it. 

Went out and got a new high quality Cat5e cable and now the backhaul is working at 1gbps. 

Recommended Solution
1
1
#6
Options
5 Reply
Re:Deco M5 ethernet backhaul limited to 100mps
2020-11-23 14:19:06

@Solja 

 

Deco M5 has 1Gbps Ethernet ports and can do much better than 100Mbps with Ethernet backhaul. I have Satellite Deco M5 wired directly to ISP Gateway, I am getting 300Mbps download speed on smartphone connected to it on 5GHz. My Internet connection is 300Mbps download/20Mbps upload.

 

If you can tell how do you run your Deco mesh, in Router mode or Access Point mode, and if you wired your Satellite Deco to modem or to Main Deco, I may offer troubleshooting steps for you.

 

Also, please run "Test Internet Speed" from inside Deco app on smartphone, it is under More section. This will run speedtest between yor Main Deco and Internet. Are you getting numbers close to 1Gbps?

0
0
#2
Options
Re:Deco M5 ethernet backhaul limited to 100mps
2020-11-23 16:09:40

@Alexandre. 

 

I'm using the deco in router mode. In the tp link app speed test I'm getting close to 800mbps. 

 

What's strange is that when using the following setup, I am able to get just over 200mbps.

 

Main deco --> wireless backhaul --> deco 2 --> cat 6 cable --> laptop. 

 

I tried this with both ports on the deco 2. 

So both ports on the deco 2 are able to go over 100mbps. 

Both ports on the main deco are able to go over 100mbps. 

As soon as they are connected in wired backhaul, they seem to remain at 100mbps.

0
0
#3
Options
Re:Deco M5 ethernet backhaul limited to 100mps
2020-11-23 16:24:16 - last edited 2020-11-23 16:31:32

@Solja 

 

I am almost inclined to say you have 100Mbit switch somewhere between Main Deco and Satellite Deco.

 

Now that you confirmed your Main Deco is getting 800Mbit from the Internet, you could test your wiring. You proved that Main Deco can get good download speed.

 

1. Power off all Decos.

2. Bring Main Deco to where your wired Satellite Deco is, disconnect Satellite Deco from backhaul Ethernet cable and connect Main Deco to it.

3. Make sure that other side of that backhaul is now connected to modem.

4. Turn on Main Deco and wait till it gets green light.

5. Run speedtest from Deco app.

 

If you'll be getting 100Mbit in that setup, it is definitely wiring.

 

If you are still getting 800Mbit, see this TP-Link FAQ article: Using QoS feature of Deco

0
0
#4
Options
Re:Deco M5 ethernet backhaul limited to 100mps
2020-11-24 06:26:55

@Alexandre. 
 

Okay I tried your suggestion and something really weird is going on.

See image below. 
In this setup, cable 1 is connecting the main deco to the modem. 
Cable 2 is connecting main deco to deco-2.
Cable 3 is connecting deco-2 to laptop. 
 

I am getting full gigabit speed. This (to me) implies that all 3 cables are operating effectively.
 

HOWEVER: When using cable 1 between main deco and deco-2, I then get limited to 100mbps on deco-2. Main deco still functions at 1gbps (implying the cable between modem and main deco still functioning correctly. 

 


 

 

So I'm a bit baffled why the same cable can support gigabit speeds between modem and main deco, but not between main deco and deco-2. 
 

Note: I tried swapping around the ports and this made no difference. 

2
2
#5
Options
Re:Deco M5 ethernet backhaul limited to 100mps-Solution
2020-11-25 16:11:56 - last edited 2020-11-26 11:12:54

@Alexandre. 
 

In the end it was indeed the cable. Even though it was working at 1gbls for every other device, the deco couldn't negotiate at 1gbps on it. 

Went out and got a new high quality Cat5e cable and now the backhaul is working at 1gbps. 

Recommended Solution
1
1
#6
Options