Archer C60 brick after flashing a firmware

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Archer C60 brick after flashing a firmware

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Archer C60 brick after flashing a firmware
Archer C60 brick after flashing a firmware
2020-12-06 07:55:05
Model: Archer C60  
Hardware Version: V3
Firmware Version:

Hi there, I have a C60 and I did a flash with the OpenWRT firmware. It was successful and I can use the LuCI etc.

 

However, when I tried to flash the OEM firmware again and the router just went bricked. Now, only the power LED is ON and I have tried many things and none of them work:

- 30-30-30 rule

- Entering Recovery mode

- Normal reset process

 

No matter I connect any device to LAN or ETHERNET, the ip or router address stays still at 0.0.0.0. This is the most weird that I didn't see from others'.

 

Since I don't have a computer with a ETHERNET port, I could not try the TFTP method. Does any know if TFTP method could work for my case? Otherwise, I really need to find such a computer with the port.

 

Did anyone have a similar experience with me? How should I do to debrick the router? 

 

Thanks all in advance!

  0      
  0      
#1
Options
3 Reply
Re:Archer C60 brick after flashing a firmware
2020-12-07 01:53:10

@peter_jai 

 

Usually the TFTP method works for reverting back to the OEM FW from OpenWRT.

If you tried everything else so far, that's the way to go.

If this was helpful click once on the arrow pointing upward. If this solves your issue, click once the star to mark it as a "Recommended Solution".
  2  
  2  
#2
Options
Re:Archer C60 brick after flashing a firmware
2020-12-08 20:21:39

@peter_jai At the end I managed to unbrick the OpenWRT firmware but not OEM firmware.

 

My environment:

- macOS 10.15.7

- Macbook pro mid 2019

- TFTP server app (https://www.macupdate.com/app/mac/11116/tftpserver)

- Wireshark

 

Setup:

--- Macbook pro ---

--- USB C adapter --> 

--- Ethernet cable -->

--- Rouer LAN 1 ---

 

Instruction:

  1. Connect everything
  2. Turn off Wifi
  3. Setup the IP to 192.168.0.66
  4. Start the TFTP server
  5. Put the firmware file in the TFTP folder and rename it to "tp_recovery.bin"
    1. I got this name as I checked with Wireshark
  6. Start Wireshark and listen to the ethernet interface
  7. Turn off the router
  8. While pressing the reset button, turn the router ON
  9. Keep looking at the Wireshark capture
  10. Once there are entries logged, release the reset button
  11. Look at the Wireshark capture and examine the status
    1. If everything goes right, you should see the router with IP 192.168.0.86 requesting the "tp_recovery.bin"

 

Note:

However, I could not flash the OEM firmware with neither TFTP nor Web UI.

 

 

 

  0  
  0  
#3
Options
Re:Archer C60 brick after flashing a firmware
2020-12-09 03:24:04 - last edited 2020-12-09 03:40:53

@peter_jai 

 

You can add a common ethernet switch in your setup and try again - both laptop and router (LAN port) connected to the switch, nothing else.

You might be able to install firmware to the Archer C60 without an ethernet switch, but the network device of your laptop may be too slow to set up a working ethernet connection to the Archer C60 after the router is switched on. The Archer C60 seems to look only a few seconds for a tftp server and if nothing is found, it simply boots the current installed firmware. So use an ethernet switch to keep the ethernet connection of your laptop alive all the time. This way, the Archer C60 should be able to load the firmware from the tftp server.

If this was helpful click once on the arrow pointing upward. If this solves your issue, click once the star to mark it as a "Recommended Solution".
  0  
  0  
#4
Options

Information

Helpful: 0

Views: 3158

Replies: 3