Extender not really working and cant connect 5G network

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Extender not really working and cant connect 5G network
Extender not really working and cant connect 5G network
2021-04-20 13:42:03
Model: RE300
Hardware Version: V1
Firmware Version:

I have tp link wifi repeater/extender model RE300..I had use it for 1 year. The device was normal working previously. Suddenly it disconnected and I reset to factory default.. i setup again to connect back to main router. Unfortunately the internet speed not so well and cant connect 5G network. When I try my phone direct to router it working well. Please help me to figure out to settle this problem. Thanks

0
0
#1
Options
1 Reply
Re:Extender not really working and cant connect 5G network
2021-04-23 02:55:16

@Faizan_Yahaya Hello, 

 

May I know did range extender detect router's 5Ghz signal during set up?

 

If RE did not detect your 5Ghz WiFi, please try suggestion in FAQ below and change router channel to 36/40/44/48

Why my Range Extender is unable to detect 5GHz wireless network of my root router?

https://www.tp-link.com/support/faq/1314/

 

If RE is able to detect router's 5Ghz signal, but 5Ghz Led does not light up, please examine your 5Ghz password, reset RE and set up again. 

 

1>Please verify your Wi-Fi password by forgetting your 5Ghz Wi-Fi network on cell phone first :  
Go to Settings-> WiFi on your phone, Tap (or Long press  the router's WiFi name  ->Forget / Delete the network 
Please reconnect to your router wifi and it will ask for a password, will it accept your router password?

 

If still does not work, please let us know the model of your router, and also firmware & hardware of your RE as well, thank you. 

https://www.tp-link.com/support/faq/315/#2

0
0
#2
Options