Message: Unavailable for current firmware

Message: Unavailable for current firmware
Message: Unavailable for current firmware
2021-05-03 13:41:15 - last edited 2021-05-04 12:24:20
Hardware Version: V2
Firmware Version: 1.5.1 Build 20210126

I have a network of 4 Decos: 01 M9 Plus as main and 03 M5 as satellites. They work as routers.

 

After a firmware update I noticed that my 2017 Samsung Smart TV model un55mu7500gxzd no longer connects to my main Deco (M9 Plus). It connects to one of the M5 located in a room far from the M9 Plus, which is located inches away from it (photo).

 

 

So I decided to disconnect the TV from the network and reconnect it. When it happens, the TV connects with the M9 Plus, but the message "Unavailable for current firmware" appears.

 

When I turn the TV off and on again, it goes back connecting to the further away Deco.

 

The "Fast roaming" feature is on. Should I turn it off?

0
0
#1
Options
1 Accepted Solution
Re:Message: Unavailable for current firmware-Solution
2021-05-04 12:23:36 - last edited 2021-05-04 12:25:27

Hi, Friend. Thank you again for your time. I remember doing the full reset of all my equipment before and it did work, but the issue eventualy came back. I've noticed it is related to "fast roaming". The Smart TV is not compatible with IEEE 802.11k/v/r protocols and it connected perfectly with the main Deco (M9 Plus) when I disabled it. I haven't noticed any issues with the other devices after turning fast roaming off, so I'll be keeping it off for now. But I'll follow your suggestion and buy a 5 foot ethernet cable to connect the TV on the available port. Once again thanks.

Recommended Solution
3
3
#3
Options
3 Reply
Re:Message: Unavailable for current firmware
2021-05-03 15:34:15 - last edited 2021-05-03 15:55:31

@Elbetosan 

 

I had once similar error message for Android set-top box connected to one of my not smart TVs. I had to power off/on everything together: Decos (Main M9, Satellite M9, Satellite M5), ISP router/modem and set-top box to get rid of it. Just bouncing Decos didn't help, just bouncing set-top box didn't work.

 

If you want to try, this is the order of powering off/on for your equipment:

 

1. Power off all Decos. Satellite Decos first, Main Deco last.

2. Power off ISP router/modem.

3. Reboot Smart TV. It should have Reboot option, usually under About, but if not - unplug it from power outlet for 10-15 seconds and plug it back.

 

4. Power on ISP router/modem. Wait till it is fully operational.

5. Power on Main Deco. Wait till its light goes green.

6. At this point, if Samsung TV hasn't connected to Main Deco on its own, make it to and check if error message gone. The success would be to see Samsung TV connected (Active) in Deco app and when you open screen with its detailed info - have IP address, MAC address and Connection Type properly shown there.

7. Power on Satellite Decos.

 

I can't guarantee it will definitely work, but it worked for me in similar situation. 

--------------------------

 

On a side node, if I am not mistaken your Samsung TV model has Ethernet port. If it does, I strongly recommend connecting your TV to Main Deco by Ethernet cable.

 

If I to share photo of my TV and other electronics under it, the picture will look almost as yours, except it'll be Sony. Main Deco is right beside it. I turned off WiFi in Sony TV and use Ethernet cable to connect TV to second Main Deco port. If you have both ports in use, you may need to get additional gigabit switch, but it will be worth it. 

For streaming on big screen TV, wired always beats wireless. 

1
1
#2
Options
Re:Message: Unavailable for current firmware-Solution
2021-05-04 12:23:36 - last edited 2021-05-04 12:25:27

Hi, Friend. Thank you again for your time. I remember doing the full reset of all my equipment before and it did work, but the issue eventualy came back. I've noticed it is related to "fast roaming". The Smart TV is not compatible with IEEE 802.11k/v/r protocols and it connected perfectly with the main Deco (M9 Plus) when I disabled it. I haven't noticed any issues with the other devices after turning fast roaming off, so I'll be keeping it off for now. But I'll follow your suggestion and buy a 5 foot ethernet cable to connect the TV on the available port. Once again thanks.

Recommended Solution
3
3
#3
Options
Re:Message: Unavailable for current firmware
2021-05-24 09:09:28
This is the only solution!
0
0
#4
Options